summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-02-05 15:50:21 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-02-12 10:11:38 +0000
commitcabaf4ef690ab5dcde901822edfd4fe5067497ac (patch)
treece006f10ef4ee9e36142c9f0a322b72ac3315f8f
parente91280bbcb99d7f4e3f79c2efe9c1fbc40b144fc (diff)
downloadmeta-boot2qt-cabaf4ef690ab5dcde901822edfd4fe5067497ac.tar.gz
qt5: Upgrade to Qt 5.11.0
QtQuickCompiler is now part of qtdeclarative, separate recipe is no longer needed. Keeping qtquickcompiler.bbclass still for backwards compatibility. Change-Id: I8e6a66b176fc17c4bb161ae4638125238518e22a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--classes/qtquickcompiler.bbclass27
-rw-r--r--conf/distro/b2qt.conf2
-rw-r--r--conf/local.conf.sample3
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb2
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb2
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb2
-rw-r--r--recipes-qt/qt5-addons/qtquickcompiler-sdk.bb79
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend1
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bbappend (renamed from recipes-qt/qt5/qtcharts_git.bbappend)8
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb51
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bbappend4
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch47
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bbappend34
-rw-r--r--scripts/manifest.xml2
-rwxr-xr-xscripts/update-qt5-modules.sh5
15 files changed, 15 insertions, 254 deletions
diff --git a/classes/qtquickcompiler.bbclass b/classes/qtquickcompiler.bbclass
index 3a1bcbe..f54887c 100644
--- a/classes/qtquickcompiler.bbclass
+++ b/classes/qtquickcompiler.bbclass
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -27,27 +27,4 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30python __anonymous() { 30EXTRA_QMAKEVARS_PRE += "CONFIG+=qtquickcompiler"
31 if d.getVar('DISABLE_QTQUICKCOMPILER', True) == "1":
32 return
33
34 provider = ""
35 sdk_path = d.getVar('B2QTBASE', True) + "/recipes-qt/qt5-addons/qtquickcompiler-sdk"
36 pn = d.getVar("PN", True)
37
38 if d.getVar('ENABLE_QTQUICKCOMPILER', True) == "1":
39 provider = "qtquickcompiler"
40 elif os.path.isdir(sdk_path):
41 provider = "qtquickcompiler-sdk"
42 else:
43 bb.note("qtquickcompiler not enabled for %s" % pn)
44 return
45
46 if "toolchain-host" in pn:
47 d.appendVar('RDEPENDS_' + pn, " nativesdk-%s-tools" % provider)
48 if "toolchain-target" in pn:
49 d.appendVar('RDEPENDS_' + pn, " %s-dev" % provider)
50 else:
51 d.appendVar('DEPENDS', " %s %s-native" % (provider, provider))
52 d.appendVar('EXTRA_QMAKEVARS_PRE', " CONFIG+=qtquickcompiler")
53}
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index 08efdf1..1aa4bd5 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -76,8 +76,6 @@ OE_QMAKE_PLATFORM_mingw32 = "win32-g++-oe"
76# Disable SHA validation for branch 76# Disable SHA validation for branch
77QT_MODULE_BRANCH_PARAM = "nobranch=1" 77QT_MODULE_BRANCH_PARAM = "nobranch=1"
78 78
79PACKAGE_EXCLUDE_COMPLEMENTARY ?= "qtquickcompiler"
80
81IMAGE_FSTYPES = "conf" 79IMAGE_FSTYPES = "conf"
82IMAGE_CLASSES += "image_types_sdcard deploy-conf" 80IMAGE_CLASSES += "image_types_sdcard deploy-conf"
83 81
diff --git a/conf/local.conf.sample b/conf/local.conf.sample
index 166ae94..ae60ef4 100644
--- a/conf/local.conf.sample
+++ b/conf/local.conf.sample
@@ -281,9 +281,6 @@ CONF_VERSION = "1"
281INHERIT += "image-buildinfo" 281INHERIT += "image-buildinfo"
282INHERIT += "internal-build" 282INHERIT += "internal-build"
283 283
284# Enables use of QtQuickCompiler if you have access to the gerrit project
285#ENABLE_QTQUICKCOMPILER = "1"
286
287ACCEPT_FSL_EULA = "1" 284ACCEPT_FSL_EULA = "1"
288LICENSE_FLAGS_WHITELIST = "commercial" 285LICENSE_FLAGS_WHITELIST = "commercial"
289 286
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb
index acae372..0acd0a7 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb
@@ -31,7 +31,7 @@ DESCRIPTION = "Host packages for B2Qt automotive Qt5 SDK"
31LICENSE = "The-Qt-Company-DCLA-2.1" 31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0" 32PR = "r0"
33 33
34inherit nativesdk packagegroup qtquickcompiler 34inherit nativesdk packagegroup
35 35
36RDEPENDS_${PN} += "\ 36RDEPENDS_${PN} += "\
37 nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host \ 37 nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host \
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
index c3f07b8..3ce2e79 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
@@ -31,7 +31,7 @@ DESCRIPTION = "Host packages for B2Qt embedded Qt5 SDK"
31LICENSE = "The-Qt-Company-DCLA-2.1" 31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0" 32PR = "r0"
33 33
34inherit nativesdk packagegroup qtquickcompiler 34inherit nativesdk packagegroup
35 35
36python __anonymous() { 36python __anonymous() {
37 overrides = d.getVar("OVERRIDES", True).split(":") 37 overrides = d.getVar("OVERRIDES", True).split(":")
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index 7a22951..2af00da 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -31,7 +31,7 @@ DESCRIPTION = "Target packages for B2Qt embedded Qt5 SDK"
31LICENSE = "The-Qt-Company-DCLA-2.1" 31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0" 32PR = "r0"
33 33
34inherit packagegroup qtquickcompiler 34inherit packagegroup
35 35
36PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" 36PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
37 37
diff --git a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
deleted file mode 100644
index 1fad9f3..0000000
--- a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
+++ /dev/null
@@ -1,79 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Quick Compiler using prebuilt binaries from Qt SDK"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33
34inherit allarch qmake5_paths
35
36do_unpack[depends] += "p7zip-native:do_populate_sysroot"
37
38SRC_URI = "http://download.qt.io/development_releases/prebuilt/mingw_32/i686-4.9.2-release-posix-dwarf-rt_v3-rev1-runtime.7z"
39
40SRC_URI[md5sum] = "a7d673c4ad8bcef9e464ea5386492cb3"
41SRC_URI[sha256sum] = "f7e58b0fb1f5aa4c23eefdc60abb88cb642eaa272fb741dca23068c70ca86542"
42
43S = "${WORKDIR}"
44
45NATIVESDK_BINARY = "qtquickcompiler"
46NATIVESDK_BINARY_mingw32 = "qtquickcompiler.exe"
47
48do_install() {
49 install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features
50 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/mkspecs/features/qtquickcompiler.prf ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features
51 install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler
52 install -m 0644 ${THISDIR}/qtquickcompiler-sdk/lib/cmake/Qt5QuickCompiler/Qt5QuickCompilerConfig.cmake ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler
53
54 if [ "${PN}" = "qtquickcompiler-sdk-native" ]; then
55 install -d ${D}${OE_QMAKE_PATH_BINS}
56 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/qtquickcompiler ${D}${OE_QMAKE_PATH_BINS}
57 elif [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then
58 install -d ${D}${OE_QMAKE_PATH_BINS}
59 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/${NATIVESDK_BINARY} ${D}${OE_QMAKE_PATH_BINS}
60 fi
61
62 # Use the EffectivePath instead of installation path
63 sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
64}
65
66do_install_append_mingw32() {
67 if [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then
68 install -m 0644 ${WORKDIR}/libgcc_s_dw2-1.dll ${D}${OE_QMAKE_PATH_BINS}
69 fi
70}
71
72INHIBIT_PACKAGE_STRIP = "1"
73ALLOW_EMPTY_${PN} = "1"
74PACKAGES =+ "${PN}-tools"
75FILES_${PN}-tools = "${OE_QMAKE_PATH_BINS}"
76FILES_${PN}-dev = "${OE_QMAKE_PATH_ARCHDATA}"
77INSANE_SKIP_${PN} += "already-stripped"
78
79BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
index 7685c5a..e7c7adf 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -43,7 +43,6 @@ PACKAGECONFIG += " \
43 icu \ 43 icu \
44 libinput \ 44 libinput \
45 linuxfb \ 45 linuxfb \
46 qml-debug \
47 sql-sqlite \ 46 sql-sqlite \
48 tslib \ 47 tslib \
49 xkbcommon-evdev \ 48 xkbcommon-evdev \
diff --git a/recipes-qt/qt5/qtcharts_git.bbappend b/recipes-qt/qt5/qtdeclarative_git.bbappend
index 8297a74..e33664b 100644
--- a/recipes-qt/qt5/qtcharts_git.bbappend
+++ b/recipes-qt/qt5/qtdeclarative_git.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -27,4 +27,8 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30inherit qtquickcompiler 30PACKAGECONFIG += "qml-debug"
31
32FILES_${PN}-plugins_mingw32 = " \
33 ${OE_QMAKE_PATH_PLUGINS}/*/*.dll \
34"
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
deleted file mode 100644
index 36d2c19..0000000
--- a/recipes-qt/qt5/qtquickcompiler_git.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Quick Compiler"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=02f6307ab0d6c4bd38a1540f16ea705d;beginline=1;endline=17"
33
34inherit qt5-module
35
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \
38 "
39
40SRCREV = "4e05e09f19bac2901cb16bf1229e396930b831ee"
41
42S = "${WORKDIR}/git"
43
44DEPENDS = "qtbase qtdeclarative"
45
46do_install_append() {
47 # Use the EffectivePath instead of installation path
48 sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
49}
50
51BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend b/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
index b7368ff..4f48099 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
@@ -27,7 +27,5 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30inherit qtquickcompiler 30PACKAGECONFIG_append = " hunspell"
31
32PACKAGECONFIG = "lipi-toolkit lang-all hunspell"
33RDEPENDS_${PN} += "hunspell-dicts" 31RDEPENDS_${PN} += "hunspell-dicts"
diff --git a/recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch b/recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch
deleted file mode 100644
index 2af19e8..0000000
--- a/recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From 4903971e1e4b58f03b0f636a1ab494bfbc5d76d4 Mon Sep 17 00:00:00 2001
2From: Michal Klocek <michal.klocek@theqtcompany.com>
3Date: Mon, 7 Dec 2015 15:48:32 +0200
4Subject: [PATCH] Fix slow video with webengine on nitrogen6x
5
6Disable texture_rg on nitrogen6x. Yocto
7image 1.8 has driver which reports opengl es 3.0
8support, however texture_rg does not
9work properly.
10---
11 src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc | 18 ------------------
12 1 file changed, 18 deletions(-)
13
14diff --git a/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc b/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc
15index 58aa147..4ab682a 100644
16--- a/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc
17+++ b/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc
18@@ -1258,26 +1258,6 @@ void FeatureInfo::InitializeFeatures() {
19 }
20 }
21
22- if ((gl_version_info_->is_es3 || gl_version_info_->is_desktop_core_profile ||
23- extensions.Contains("GL_EXT_texture_rg") ||
24- extensions.Contains("GL_ARB_texture_rg")) &&
25- IsGL_REDSupportedOnFBOs()) {
26- feature_flags_.ext_texture_rg = true;
27- AddExtensionString("GL_EXT_texture_rg");
28-
29- validators_.texture_format.AddValue(GL_RED_EXT);
30- validators_.texture_format.AddValue(GL_RG_EXT);
31- validators_.texture_internal_format.AddValue(GL_RED_EXT);
32- validators_.texture_internal_format.AddValue(GL_R8_EXT);
33- validators_.texture_internal_format.AddValue(GL_RG_EXT);
34- validators_.texture_internal_format.AddValue(GL_RG8_EXT);
35- validators_.read_pixel_format.AddValue(GL_RED_EXT);
36- validators_.read_pixel_format.AddValue(GL_RG_EXT);
37- validators_.render_buffer_format.AddValue(GL_R8_EXT);
38- validators_.render_buffer_format.AddValue(GL_RG8_EXT);
39- validators_.texture_unsized_internal_format.AddValue(GL_RED_EXT);
40- validators_.texture_unsized_internal_format.AddValue(GL_RG_EXT);
41- }
42 UMA_HISTOGRAM_BOOLEAN("GPU.TextureRG", feature_flags_.ext_texture_rg);
43
44 bool has_opengl_dual_source_blending =
45--
461.9.1
47
diff --git a/recipes-qt/qt5/qtwebengine_git.bbappend b/recipes-qt/qt5/qtwebengine_git.bbappend
deleted file mode 100644
index 9d4ef68..0000000
--- a/recipes-qt/qt5/qtwebengine_git.bbappend
+++ /dev/null
@@ -1,34 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31
32SRC_URI_append_mx6 = " \
33 file://0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch \
34 "
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 1aa053b..46c5f2a 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -25,7 +25,7 @@
25 path="sources/meta-openembedded"/> 25 path="sources/meta-openembedded"/>
26 <project name="meta-qt5" 26 <project name="meta-qt5"
27 remote="qtyocto" 27 remote="qtyocto"
28 revision="a358108b09762390ec951f560540bb99aaf9f2a2" 28 revision="50c4963980164ae0e9992d652fd934d85fd2400e"
29 path="sources/meta-qt5"/> 29 path="sources/meta-qt5"/>
30 <project name="meta-mingw" 30 <project name="meta-mingw"
31 remote="qtyocto" 31 remote="qtyocto"
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh
index e6d945f..4ae42e8 100755
--- a/scripts/update-qt5-modules.sh
+++ b/scripts/update-qt5-modules.sh
@@ -53,9 +53,8 @@ for S in $SHA1S; do
53 elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then 53 elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then
54 sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* 54 sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb*
55 echo "qtlocation (mapboxgl) -> ${SHA1}" 55 echo "qtlocation (mapboxgl) -> ${SHA1}"
56 elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then 56 elif [ "${PROJECT}" = "qtenginio" ] || [ "${PROJECT}" = "qtquick1" ] || [ "${PROJECT}" = "qtsystems" ]; then
57 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb 57 echo "${PROJECT} -> ignored"
58 echo "qtquickcompiler -> ${SHA1}"
59 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then 58 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then
60 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* 59 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb*
61 echo "${PROJECT} -> ${SHA1}" 60 echo "${PROJECT} -> ${SHA1}"