summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2014-11-10 10:19:31 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2014-11-12 15:10:34 +0200
commitc47be497b6a6bbcf9cd1abd5d93d74d2ab456b35 (patch)
tree48e18ee2bee57042649e7c4e67021b96a7dfe14e
parentb5742f386fd5b2a713f19b9a311d3c83b2cd2b01 (diff)
downloadmeta-boot2qt-c47be497b6a6bbcf9cd1abd5d93d74d2ab456b35.tar.gz
nitrogen6x: update kernel configs
Previous kernel config changes are now merged upstream, and the fix for the imx-vpu is also in, so all configuration changes can be removed. Add support for Nitrogen6_Lite. The Nitrogen6_Lite board supports a Broadcom 4331 WiFi/Bluetooth module, and typically has one of its' GPIO ports configured as an LED_GPIO control (for a dry-contact output). Change-Id: I840e7703624c652acf0a0262102e6491a3908719 Signed-off-by: Eric Nelson <eric.nelson@boundarydevices.com> Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_3.10.17.bbappend20
1 files changed, 8 insertions, 12 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.17.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_3.10.17.bbappend
index da33ff5..7c924b2 100644
--- a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.17.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-boundary_3.10.17.bbappend
@@ -24,19 +24,15 @@
24RDEPENDS_kernel-base = "" 24RDEPENDS_kernel-base = ""
25 25
26do_configure_prepend() { 26do_configure_prepend() {
27 # Use multitouch protocol for touchscreen that support it 27 # fix imx-vpu break on video decoding
28 echo "CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH=n" >> ${WORKDIR}/defconfig 28 echo "CONFIG_VMSPLIT_2G=y" >> ${WORKDIR}/defconfig
29 echo "CONFIG_TOUCHSCREEN_FT5X06_SINGLE_TOUCH=n" >> ${WORKDIR}/defconfig
30 29
31 # FunctionFS for adb 30 # include H4 UART for Broadcom BT on Nitrogen6_Lite
32 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig 31 echo "CONFIG_BT_HCIUART_H4=y" >> ${WORKDIR}/defconfig
33 32
34 # Enable USB serial support 33 # include Broadcom WiFi for Nitrogen6_Lite
35 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig 34 echo "CONFIG_BRCMFMAC=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
37 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
38 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
39 35
40 # fix imx-vpu break on video decoding 36 # include LEDS_GPIO for Nitrogen6_Lite
41 echo "CONFIG_VMSPLIT_2G=y" >> ${WORKDIR}/defconfig 37 echo "CONFIG_LEDS_GPIO=y" >> ${WORKDIR}/defconfig
42} 38}