summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-05-30 16:59:28 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-06-07 09:19:09 +0000
commitba5a0bfd217b429be7d3cb941b5fe72bbfc11494 (patch)
tree0a75af2b88f164301c72acb476c01717dea34e18
parent6f2af94226caa4a816a7004a39c8ffca4d465f19 (diff)
downloadmeta-boot2qt-ba5a0bfd217b429be7d3cb941b5fe72bbfc11494.tar.gz
qt5: update to 5.10
Qt Quick Compiler needs to be disabled. Use latest from meta-mingw to get c++11 pthread support. Change-Id: I03773d08e0c78e87601d73838c67148248244902 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--conf/local.conf.sample1
-rw-r--r--recipes-qt/qt5-addons/qtquickcompiler-sdk.bb1
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb2
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb1
-rw-r--r--scripts/manifest.xml6
5 files changed, 6 insertions, 5 deletions
diff --git a/conf/local.conf.sample b/conf/local.conf.sample
index 166ae94..097c1ce 100644
--- a/conf/local.conf.sample
+++ b/conf/local.conf.sample
@@ -283,6 +283,7 @@ INHERIT += "internal-build"
283 283
284# Enables use of QtQuickCompiler if you have access to the gerrit project 284# Enables use of QtQuickCompiler if you have access to the gerrit project
285#ENABLE_QTQUICKCOMPILER = "1" 285#ENABLE_QTQUICKCOMPILER = "1"
286DISABLE_QTQUICKCOMPILER = "1"
286 287
287ACCEPT_FSL_EULA = "1" 288ACCEPT_FSL_EULA = "1"
288LICENSE_FLAGS_WHITELIST = "commercial" 289LICENSE_FLAGS_WHITELIST = "commercial"
diff --git a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
index 98c3deb..7f3e85b 100644
--- a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
+++ b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
@@ -61,7 +61,6 @@ do_install() {
61do_install_append_mingw32() { 61do_install_append_mingw32() {
62 if [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then 62 if [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then
63 install -m 0644 ${WORKDIR}/libgcc_s_dw2-1.dll ${D}${OE_QMAKE_PATH_BINS} 63 install -m 0644 ${WORKDIR}/libgcc_s_dw2-1.dll ${D}${OE_QMAKE_PATH_BINS}
64 install -m 0644 ${WORKDIR}/libwinpthread-1.dll ${D}${OE_QMAKE_PATH_BINS}
65 fi 64 fi
66} 65}
67 66
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
index 23fbaf8..2ca1d7d 100644
--- a/recipes-qt/qt5/qtquickcompiler_git.bb
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
@@ -37,7 +37,7 @@ SRC_URI = " \
37 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \ 37 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \
38 " 38 "
39 39
40SRCREV = "86d362f4ed6baeab0dfc6d892f18458a65ec7361" 40SRCREV = "7ec4bc57c417b68eb6f6cfcaa26c376883824d61"
41 41
42S = "${WORKDIR}/git" 42S = "${WORKDIR}/git"
43 43
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index 9f43fff..9e55ca3 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -57,4 +57,5 @@ RDEPENDS_${PN}_append_mingw32 = "\
57 nativesdk-make \ 57 nativesdk-make \
58 nativesdk-libgcc \ 58 nativesdk-libgcc \
59 nativesdk-libstdc++ \ 59 nativesdk-libstdc++ \
60 nativesdk-mingw-w64-winpthreads \
60 " 61 "
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index a91147b..4ea0f90 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -24,12 +24,12 @@
24 path="sources/meta-openembedded"/> 24 path="sources/meta-openembedded"/>
25 <project name="meta-qt5" 25 <project name="meta-qt5"
26 remote="qtyocto" 26 remote="qtyocto"
27 revision="e91e6a01a6623225290059073e806217f23e1f07" 27 revision="044ba1621532deed80ef79a15f5b225d8b9471ec"
28 path="sources/meta-qt5"/> 28 path="sources/meta-qt5"/>
29 <project name="meta-mingw" 29 <project name="meta-mingw"
30 remote="qtyocto" 30 remote="qtyocto"
31 path="sources/meta-mingw" 31 revision="46d0746d53f863d9d76fa117f1259459803a36e3"
32 revision="bfda0f040958b3c533123071ff031037389eed62"/> 32 path="sources/meta-mingw"/>
33 33
34 <project name="meta-freescale" 34 <project name="meta-freescale"
35 remote="freescale" 35 remote="freescale"