summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimmo Ollila <kimmo.ollila@theqtcompany.com>2016-06-23 17:30:54 +0300
committerRisto Avila <risto.avila@qt.io>2016-06-29 17:49:22 +0000
commit7dc5d514c72cf3634ef3f1b0fc6643ceb7938c2d (patch)
tree236666fa5c480fff5446c76af55a59c48e80c0c2
parent30a175a5600825bda75f56fba8c29313dbe05540 (diff)
downloadmeta-boot2qt-7dc5d514c72cf3634ef3f1b0fc6643ceb7938c2d.tar.gz
Added QMLLive to automotive images
Change-Id: Iaf4721429e97d480ec4938186cc4115231ca86c1 Reviewed-by: Risto Avila <risto.avila@qt.io>
-rw-r--r--recipes-qt/automotive/qmllive-target/qmllive-target.patch19
-rw-r--r--recipes-qt/automotive/qmllive-target_git.bb20
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb1
3 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qmllive-target/qmllive-target.patch b/recipes-qt/automotive/qmllive-target/qmllive-target.patch
new file mode 100644
index 0000000..e3f81fa
--- /dev/null
+++ b/recipes-qt/automotive/qmllive-target/qmllive-target.patch
@@ -0,0 +1,19 @@
1diff --git a/runtime.pro b/runtime.pro
2index 73dd6d7..e569b23 100644
3--- a/runtime.pro
4+++ b/runtime.pro
5@@ -1,5 +1,4 @@
6 TARGET = qmlliveruntime
7-DESTDIR = ../../bin
8
9 QT *= widgets quick
10 osx: CONFIG -= app_bundle
11@@ -14,6 +13,6 @@ include(../src.pri)
12 RESOURCES += \
13 qml.qrc
14
15-
16-
17+target.path += /usr/bin
18+INSTALLS += target
19
diff --git a/recipes-qt/automotive/qmllive-target_git.bb b/recipes-qt/automotive/qmllive-target_git.bb
new file mode 100644
index 0000000..efcac4d
--- /dev/null
+++ b/recipes-qt/automotive/qmllive-target_git.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "QML Live target runtime"
2
3LICENSE = "GPL-3.0"
4LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
5
6inherit qmake5 sdk-sources
7
8FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
9
10SRC_URI = " \
11 git://codereview.qt-project.org/qt-apps/qmllive.git;branch=${BRANCH};protocol=ssh;name=tools \
12 file://qmllive-target.patch \
13"
14
15BRANCH = "master"
16SRCREV_tools="d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
17
18S = "${WORKDIR}/git/src/runtime"
19
20DEPENDS = "qtbase qtdeclarative"
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
index aee96d9..5ec66b4 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -43,4 +43,5 @@ RDEPENDS_${PN} += " \
43 neptune-ui-apps \ 43 neptune-ui-apps \
44 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \ 44 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \
45 gammaray \ 45 gammaray \
46 qmllive-target \
46 " 47 "