summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRainer Keller <rainer.keller@theqtcompany.com>2015-07-16 10:33:14 +0200
committerRainer Keller <rainer.keller@theqtcompany.com>2015-08-06 07:06:35 +0000
commit7b7b6b9f369a2b707e8ed9334e0d81cdb588e2b1 (patch)
treeb63bff35225f56db0329e024a91a0427fc4b1261
parentbcc532e5142c40d15e9bb2c7f10e02c37a45d507 (diff)
downloadmeta-boot2qt-7b7b6b9f369a2b707e8ed9334e0d81cdb588e2b1.tar.gz
Add Emulator sdcardmountd
Change-Id: Ib760d0c25c645b1c44216081c42714f8e9a8ca32 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r--conf/distro/include/emulator.conf1
-rw-r--r--recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb49
-rwxr-xr-xrecipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmountd.sh42
3 files changed, 92 insertions, 0 deletions
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf
index 79ebd07..0457756 100644
--- a/conf/distro/include/emulator.conf
+++ b/conf/distro/include/emulator.conf
@@ -46,6 +46,7 @@ MACHINE_EXTRA_INSTALL_QT = "\
46 qtglesstream \ 46 qtglesstream \
47 b2qt-emulator-proxy \ 47 b2qt-emulator-proxy \
48 b2qt-emulator-vinput \ 48 b2qt-emulator-vinput \
49 b2qt-emulator-sdcardmountd \
49 " 50 "
50MACHINE_EXTRA_INSTALL_QT_SDK = "\ 51MACHINE_EXTRA_INSTALL_QT_SDK = "\
51 qtglesstream-dev \ 52 qtglesstream-dev \
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb
new file mode 100644
index 0000000..cb0b2ce
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "SD-Card mount daemon for Emulator"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://sdcardmountd.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://codereview.qt-project.org/tqtc-boot2qt/emulator;branch=${BRANCH};protocol=ssh \
31 file://sdcardmountd.sh \
32 "
33
34SRCREV = "1d001910d45349ae2a44fa01516baaa7ff4c9eda"
35BRANCH = "master"
36
37S = "${WORKDIR}/git/src/helperlibs/sdcarddaemon"
38
39DEPENDS = "qtbase qtsimulator"
40
41do_install_append() {
42 install -m 0755 -d ${D}${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/sdcardmountd.sh ${D}${sysconfdir}/init.d/
44}
45
46INITSCRIPT_NAME = "sdcardmountd.sh"
47INITSCRIPT_PARAMS = "defaults 97 10"
48
49inherit update-rc.d
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmountd.sh b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmountd.sh
new file mode 100755
index 0000000..565d9b5
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmountd.sh
@@ -0,0 +1,42 @@
1#!/bin/sh
2#############################################################################
3##
4## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
5##
6## This file is part of the Qt Enterprise Embedded Scripts of the Qt
7## framework.
8##
9## $QT_BEGIN_LICENSE$
10## Commercial License Usage Only
11## Licensees holding valid commercial Qt license agreements with Digia
12## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
13## may use this file in accordance with the terms contained in said license
14## agreement.
15##
16## For further information use the contact form at
17## http://www.qt.io/contact-us.
18##
19##
20## $QT_END_LICENSE$
21##
22#############################################################################
23
24DAEMON=/usr/bin/sdcardmountd
25
26case "$1" in
27start)
28 start-stop-daemon --start --quiet --exec $DAEMON &
29 ;;
30stop)
31 start-stop-daemon --stop --quiet --exec $DAEMON
32 ;;
33restart)
34 start-stop-daemon --stop --quiet --exec $DAEMON
35 sleep 1
36 start-stop-daemon --start --quiet --exec $DAEMON &
37 ;;
38*)
39 echo "Usage: $0 {start|stop|restart}"
40 exit 1
41esac
42exit 0