summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-11-02 10:56:11 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-11-06 07:31:54 +0000
commit563f0dc52d87742b64729f70e5881b02b2f9db50 (patch)
treecfb19276037df27fc2d2798dc83e758b518f5839
parente084dffbd643f65f03b33fd4485d3f98435bc7c0 (diff)
downloadmeta-boot2qt-563f0dc52d87742b64729f70e5881b02b2f9db50.tar.gz
otf-noto: get files from the git repo
The checksum of the zip file changes too often, which always breaks the build. Change to using the git repo for the files. Unfortunately the repo is massive (>1Gb), but at least it should not cause build breaks anymore. Task-number: QTBUG-64231 Change-Id: Iddfe71c8189caf4e66d78c46e9ca9410b333a8dd Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes/fonts/otf-noto_git.bb (renamed from recipes/fonts/otf-noto.bb)15
1 files changed, 7 insertions, 8 deletions
diff --git a/recipes/fonts/otf-noto.bb b/recipes/fonts/otf-noto_git.bb
index 1c17d33..3be53c2 100644
--- a/recipes/fonts/otf-noto.bb
+++ b/recipes/fonts/otf-noto_git.bb
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -31,23 +31,22 @@ SUMMARY = "Noto Sans CJK"
31SECTION = "fonts" 31SECTION = "fonts"
32HOMEPAGE = "http://www.google.com/get/noto" 32HOMEPAGE = "http://www.google.com/get/noto"
33LICENSE = "OFL-1.1" 33LICENSE = "OFL-1.1"
34LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE_OFL.txt;md5=55719faa0112708e946b820b24b14097" 34LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=55719faa0112708e946b820b24b14097"
35 35
36INHIBIT_DEFAULT_DEPS = "1" 36INHIBIT_DEFAULT_DEPS = "1"
37 37
38inherit allarch fontcache 38inherit allarch fontcache
39 39
40PV = "1.004" 40PV = "1.004"
41SRC_URI = "https://noto-website-2.storage.googleapis.com/pkgs/NotoSansCJKsc-hinted.zip" 41SRC_URI = "git://github.com/googlei18n/noto-cjk.git"
42SRCREV = "40d9f5b179a59a06b98373c76bdc3e2119e4e6b2"
42 43
43SRC_URI[md5sum] = "539a04d2a14a12096897f84ba046d110" 44S = "${WORKDIR}/git"
44SRC_URI[sha256sum] = "c0a77b24ce1964c5d244be7576ada5899d681638e0abd0917e6a661df56e0232"
45
46S = "${WORKDIR}"
47 45
48do_install() { 46do_install() {
49 install -m 0755 -d ${D}${datadir}/fonts/otf/noto 47 install -m 0755 -d ${D}${datadir}/fonts/otf/noto
50 install -m 0644 ${WORKDIR}/*.otf ${D}${datadir}/fonts/otf/noto 48 install -m 0644 ${S}/NotoSansCJKsc-*.otf ${D}${datadir}/fonts/otf/noto
49 install -m 0644 ${S}/NotoSansMonoCJKsc-*.otf ${D}${datadir}/fonts/otf/noto
51} 50}
52 51
53PACKAGES = "${PN}" 52PACKAGES = "${PN}"