diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-22 15:59:05 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-22 15:59:05 +0300 |
commit | 83b656eb3219ee37d95d6453d692562406fe7be0 (patch) | |
tree | 47b52b59932c23c4e9cfeb8bfc0a3e75c23117de | |
parent | 1778a81a6d214b27f20cb5242b28d5c41fbbf5b6 (diff) | |
parent | 797b8c96bd53cd15b6540a989353f89d285c8de9 (diff) | |
download | meta-boot2qt-83b656eb3219ee37d95d6453d692562406fe7be0.tar.gz |
Merge remote-tracking branch 'origin/fido' into jethro
* origin/fido:
Correctly update qtquickcompiler SHA1
Reuse qt5-git.inc to define git repo location
Remove automotive recipes
Update Qt5 submodules
Handle qtquickcompiler in update-qt5-modules.sh script
Correctly use QtQuickCompiler when available
Change git protocol from ssh to http
Update qtdeclarative module
Update boot2qt-demos version
Conflicts:
conf/distro/b2qt-auto.conf
recipes-qt/automotive/gammaray_git.bb
recipes-qt/automotive/neptune-ui/neptune.service
recipes-qt/automotive/neptune-ui_git.bb
recipes-qt/automotive/qtapplicationmanager_git.bb
recipes-qt/automotive/qtivi_git.bb
recipes-qt/automotive/qtwebbrowser_git.bb
recipes-qt/b2qt-addons/b2qt-demos.bb
recipes-qt/b2qt-addons/b2qt-launcher.bb
recipes-qt/b2qt-addons/democompositor_git.bb
recipes-qt/images/b2qt-automotive-qt5-image.bb
recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb
recipes-qt/qt5/nativesdk-qtbase_git.bbappend
recipes-qt/qt5/qt3d_git.bbappend
recipes-qt/qt5/qtbase-native_git.bbappend
recipes-qt/qt5/qtbase_git.bbappend
recipes-qt/qt5/qtcanvas3d_git.bbappend
recipes-qt/qt5/qtcharts_git.bb
recipes-qt/qt5/qtconnectivity_git.bbappend
recipes-qt/qt5/qtdatavis3d_git.bb
recipes-qt/qt5/qtdeclarative-render2d_git.bb
recipes-qt/qt5/qtdeclarative_git.bbappend
recipes-qt/qt5/qtgraphicaleffects_git.bbappend
recipes-qt/qt5/qtimageformats_git.bbappend
recipes-qt/qt5/qtlocation_git.bbappend
recipes-qt/qt5/qtmultimedia_git.bbappend
recipes-qt/qt5/qtquickcompiler_git.bb
recipes-qt/qt5/qtquickcontrols2_git.bb
recipes-qt/qt5/qtquickcontrols_git.bbappend
recipes-qt/qt5/qtsensors_git.bbappend
recipes-qt/qt5/qtserialbus_git.bb
recipes-qt/qt5/qtserialport_git.bbappend
recipes-qt/qt5/qtsvg_git.bbappend
recipes-qt/qt5/qttools_git.bbappend
recipes-qt/qt5/qttranslations_git.bbappend
recipes-qt/qt5/qtvirtualkeyboard_git.bb
recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
recipes-qt/qt5/qtwayland-native_5.7-wip.bb
recipes-qt/qt5/qtwayland-native_git.bbappend
recipes-qt/qt5/qtwayland_5.7-wip.bb
recipes-qt/qt5/qtwayland_git.bbappend
recipes-qt/qt5/qtwebchannel_git.bbappend
recipes-qt/qt5/qtwebengine_git.bbappend
recipes-qt/qt5/qtwebsockets_git.bbappend
recipes-qt/qt5/qtxmlpatterns_git.bbappend
scripts/manifest.xml
Change-Id: Ibf7f89a35c9e19bd8cf81c49cb44f6fd454838b4
-rw-r--r-- | classes/internal-build.bbclass | 1 | ||||
-rw-r--r-- | classes/qtquickcompiler.bbclass | 20 | ||||
-rw-r--r-- | conf/distro/b2qt-auto.conf | 33 | ||||
-rw-r--r-- | conf/local.conf.sample | 3 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/b2qt-demos.bb | 6 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/b2qt-launcher.bb | 10 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/democompositor_git.bb | 7 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquickcompiler_git.bb (renamed from recipes-qt/qt5-addons/qtquickcompiler_git.bb) | 0 | ||||
-rwxr-xr-x | scripts/update-qt5-modules.sh | 3 |
9 files changed, 26 insertions, 57 deletions
diff --git a/classes/internal-build.bbclass b/classes/internal-build.bbclass index 3b7f422..ecee863 100644 --- a/classes/internal-build.bbclass +++ b/classes/internal-build.bbclass | |||
@@ -34,6 +34,7 @@ python enable_internal_build () { | |||
34 | except: | 34 | except: |
35 | return | 35 | return |
36 | 36 | ||
37 | e.data.setVar('ENABLE_QTQUICKCOMPILER', "1") | ||
37 | e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH") | 38 | e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH") |
38 | e.data.setVar('PREMIRRORS', "\ | 39 | e.data.setVar('PREMIRRORS', "\ |
39 | ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \ | 40 | ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \ |
diff --git a/classes/qtquickcompiler.bbclass b/classes/qtquickcompiler.bbclass index 8dbaf49..3564ad1 100644 --- a/classes/qtquickcompiler.bbclass +++ b/classes/qtquickcompiler.bbclass | |||
@@ -28,18 +28,18 @@ | |||
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | python __anonymous() { | 30 | python __anonymous() { |
31 | provider = "qtquickcompiler" | 31 | provider = "" |
32 | sdk_path = d.getVar('B2QTBASE', True) + "/recipes-qt/qt5-addons/qtquickcompiler-sdk" | ||
33 | pn = d.getVar("PN", True) | ||
32 | 34 | ||
33 | sdk_path = d.getVar('QT_SDK_PATH', True) or "" | 35 | if d.getVar('ENABLE_QTQUICKCOMPILER', True) == "1": |
34 | if len(sdk_path) != 0: | 36 | provider = "qtquickcompiler" |
35 | qtquickcompiler_path = d.getVar('B2QTBASE', True) + "/recipes-qt/qt5-addons/qtquickcompiler-sdk" | 37 | elif os.path.isdir(sdk_path): |
36 | if not os.path.isdir(qtquickcompiler_path): | 38 | provider = "qtquickcompiler-sdk" |
37 | bb.note("QtQuickCompiler not available") | 39 | else: |
38 | return | 40 | bb.note("qtquickcompiler not enabled for %s" % pn) |
39 | else: | 41 | return |
40 | provider = "qtquickcompiler-sdk" | ||
41 | 42 | ||
42 | pn = d.getVar("PN", True) | ||
43 | if "toolchain-host" in pn: | 43 | if "toolchain-host" in pn: |
44 | d.appendVar('RDEPENDS_' + pn, " nativesdk-%s-tools" % provider) | 44 | d.appendVar('RDEPENDS_' + pn, " nativesdk-%s-tools" % provider) |
45 | if "toolchain-target" in pn: | 45 | if "toolchain-target" in pn: |
diff --git a/conf/distro/b2qt-auto.conf b/conf/distro/b2qt-auto.conf deleted file mode 100644 index 2744cad..0000000 --- a/conf/distro/b2qt-auto.conf +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | include conf/distro/b2qt.conf | ||
31 | |||
32 | PREFERRED_VERSION_qtwayland = "5.6%" | ||
33 | PREFERRED_VERSION_qtwayland-native = "5.6%" | ||
diff --git a/conf/local.conf.sample b/conf/local.conf.sample index 9a1eb66..6851361 100644 --- a/conf/local.conf.sample +++ b/conf/local.conf.sample | |||
@@ -281,6 +281,9 @@ INHERIT += "rm_work" | |||
281 | INHERIT += "image-buildinfo" | 281 | INHERIT += "image-buildinfo" |
282 | INHERIT += "internal-build" | 282 | INHERIT += "internal-build" |
283 | 283 | ||
284 | # Enables use of QtQuickCompiler if you have access to the gerrit project | ||
285 | #ENABLE_QTQUICKCOMPILER = "1" | ||
286 | |||
284 | ACCEPT_FSL_EULA = "1" | 287 | ACCEPT_FSL_EULA = "1" |
285 | LICENSE_FLAGS_WHITELIST = "commercial" | 288 | LICENSE_FLAGS_WHITELIST = "commercial" |
286 | 289 | ||
diff --git a/recipes-qt/b2qt-addons/b2qt-demos.bb b/recipes-qt/b2qt-addons/b2qt-demos.bb index bd0b9f7..eec5bc4 100644 --- a/recipes-qt/b2qt-addons/b2qt-demos.bb +++ b/recipes-qt/b2qt-addons/b2qt-demos.bb | |||
@@ -31,13 +31,13 @@ DESCRIPTION = "Boot to Qt Demos" | |||
31 | LICENSE = "BSD | The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "BSD | The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://about-b2qt/AboutBoot2Qt.qml;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49" | 32 | LIC_FILES_CHKSUM = "file://about-b2qt/AboutBoot2Qt.qml;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49" |
33 | 33 | ||
34 | inherit qmake5 sdk-sources | 34 | inherit qmake5 |
35 | 35 | ||
36 | SRC_URI = " \ | 36 | SRC_URI = " \ |
37 | git://codereview.qt-project.org/qt-apps/boot2qt-demos.git;branch=${BRANCH};protocol=http;name=demos \ | 37 | ${QT_GIT}/qt-apps-boot2qt-demos.git;branch=${BRANCH};name=demos \ |
38 | ${QT_GIT}/qtcanvas3d.git;branch=${QT_BRANCH};name=qtcanvas3d;destsuffix=qtcanvas3d \ | 38 | ${QT_GIT}/qtcanvas3d.git;branch=${QT_BRANCH};name=qtcanvas3d;destsuffix=qtcanvas3d \ |
39 | ${QT_GIT}/qtquickcontrols.git;branch=${QT_BRANCH};name=qtquickcontrols;destsuffix=qtquickcontrols \ | 39 | ${QT_GIT}/qtquickcontrols.git;branch=${QT_BRANCH};name=qtquickcontrols;destsuffix=qtquickcontrols \ |
40 | git://codereview.qt-project.org/qt-apps/qtwebbrowser.git;branch=${BROWSER_BRANCH};protocol=http;name=qtwebbrowser;destsuffix=git/basicsuite/qtwebbrowser/tqtc-qtwebbrowser;sdk-uri=5.7/Boot2Qt/sources/b2qt-demos/basicsuite/qtwebbrowser/tqtc-qtwebbrowser \ | 40 | ${QT_GIT}/qt-apps-qtwebbrowser.git;branch=${BROWSER_BRANCH};name=qtwebbrowser;destsuffix=git/basicsuite/qtwebbrowser/tqtc-qtwebbrowser \ |
41 | https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt_video_720p.webm;name=video1 \ | 41 | https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt_video_720p.webm;name=video1 \ |
42 | https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt+World+Summit+2015+Recap.mp4;name=video2 \ | 42 | https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt+World+Summit+2015+Recap.mp4;name=video2 \ |
43 | " | 43 | " |
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher.bb b/recipes-qt/b2qt-addons/b2qt-launcher.bb index d5ff015..e131b2a 100644 --- a/recipes-qt/b2qt-addons/b2qt-launcher.bb +++ b/recipes-qt/b2qt-addons/b2qt-launcher.bb | |||
@@ -32,19 +32,17 @@ LICENSE = "(BSD & GPL-3.0) | The-Qt-Company-DCLA-2.1" | |||
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504" | 32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504" |
33 | 33 | ||
34 | inherit qmake5 | 34 | inherit qmake5 |
35 | require recipes-qt/qt5/qt5-git.inc | ||
35 | 36 | ||
36 | SRC_URI = " \ | 37 | QT_MODULE = "qt-apps-boot2qt-launcher" |
37 | git://codereview.qt-project.org/qt-apps/boot2qt-launcher;branch=${BRANCH};protocol=http \ | 38 | |
39 | SRC_URI += " \ | ||
38 | file://b2qt-startup.sh \ | 40 | file://b2qt-startup.sh \ |
39 | file://qtlauncher.service \ | 41 | file://qtlauncher.service \ |
40 | file://b2qt.service \ | 42 | file://b2qt.service \ |
41 | " | 43 | " |
42 | 44 | ||
43 | SRCREV = "7ff96b74f8721dbaf50722561770815a4530b6a0" | 45 | SRCREV = "7ff96b74f8721dbaf50722561770815a4530b6a0" |
44 | BRANCH = "5.7" | ||
45 | PV = "5.7+git${SRCPV}" | ||
46 | |||
47 | S = "${WORKDIR}/git" | ||
48 | 46 | ||
49 | DEPENDS = "qtbase qtdeclarative \ | 47 | DEPENDS = "qtbase qtdeclarative \ |
50 | ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" | 48 | ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" |
diff --git a/recipes-qt/b2qt-addons/democompositor_git.bb b/recipes-qt/b2qt-addons/democompositor_git.bb index a12e83b..d63df0e 100644 --- a/recipes-qt/b2qt-addons/democompositor_git.bb +++ b/recipes-qt/b2qt-addons/democompositor_git.bb | |||
@@ -32,14 +32,11 @@ LICENSE = "BSD | The-Qt-Company-DCLA-2.1" | |||
32 | LIC_FILES_CHKSUM = "file://main.cpp;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49" | 32 | LIC_FILES_CHKSUM = "file://main.cpp;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49" |
33 | 33 | ||
34 | inherit qmake5 | 34 | inherit qmake5 |
35 | require recipes-qt/qt5/qt5-git.inc | ||
35 | 36 | ||
36 | SRC_URI = " \ | 37 | QT_MODULE = "qt-apps-boot2qt-demos" |
37 | git://codereview.qt-project.org/qt-apps/boot2qt-demos.git;branch=${BRANCH};protocol=http \ | ||
38 | " | ||
39 | 38 | ||
40 | SRCREV = "a6d8f7ce79fb5c17e706f25daf4dda4d97b5323e" | 39 | SRCREV = "a6d8f7ce79fb5c17e706f25daf4dda4d97b5323e" |
41 | BRANCH = "5.7" | ||
42 | PV = "5.7+git${SRCPV}" | ||
43 | 40 | ||
44 | S = "${WORKDIR}/git/wayland/democompositor/" | 41 | S = "${WORKDIR}/git/wayland/democompositor/" |
45 | 42 | ||
diff --git a/recipes-qt/qt5-addons/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb index 564fc3d..564fc3d 100644 --- a/recipes-qt/qt5-addons/qtquickcompiler_git.bb +++ b/recipes-qt/qt5/qtquickcompiler_git.bb | |||
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh index c9e3949..d4087c3 100755 --- a/scripts/update-qt5-modules.sh +++ b/scripts/update-qt5-modules.sh | |||
@@ -47,6 +47,9 @@ for S in $SHA1S; do | |||
47 | elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then | 47 | elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then |
48 | sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* | 48 | sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* |
49 | echo "qtwebengine (chromium) -> ${SHA1}" | 49 | echo "qtwebengine (chromium) -> ${SHA1}" |
50 | elif [ "${PROJECT}" = "tqtc-qmlcompiler" ]; then | ||
51 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb* | ||
52 | echo "qtquickcompiler -> ${SHA1}" | ||
50 | elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then | 53 | elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then |
51 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* | 54 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* |
52 | echo "${PROJECT} -> ${SHA1}" | 55 | echo "${PROJECT} -> ${SHA1}" |