summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-09-26 10:43:26 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-28 08:57:46 +0000
commitaa863717a1e24a3c08a94726e95493780ccff1f3 (patch)
tree51ba08637efc4f99b0caeede3032c10ce6db6aa0
parent168f62cc6d06b205a3ddcb941570103e7910e14d (diff)
downloadmeta-boot2qt-aa863717a1e24a3c08a94726e95493780ccff1f3.tar.gz
poky: update to 2.5 branch (sumo)
Update yocto from 2.3.4 (pyro) to 2.5.1 (sumo): - Update poky, meta-openembedded & meta-mingw to sumo branch - update image classes (obsolete IMAGE_DEPENDS definitions) - Update bbappends under meta-boot2qt-distro - Update meta-*-extras layers bbappends & patches All recipes related to nitrogen6x are fixed here, but this depends on follow up commits to work correctly. Task-number: QTBUG-68681 Change-Id: Ic5802c5c1a3989bed746f96f8cf173743ec755bb Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-boot2qt-distro/conf/distro/include/boundary.inc2
-rw-r--r--meta-boot2qt-distro/conf/distro/include/fsl.inc2
-rw-r--r--meta-boot2qt-distro/conf/distro/include/nitrogen6x.conf39
-rw-r--r--meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend (renamed from meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_7.%.bbappend)0
-rw-r--r--meta-boot2qt/classes/deploy-conf.bbclass4
-rw-r--r--meta-boot2qt/classes/image_types_sdcard.bbclass14
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_4.%.bbappend2
-rw-r--r--meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend2
-rw-r--r--meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend2
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch45
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch8
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch36
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary_%.bbappend (renamed from meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend)5
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch13
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_%.bbappend (renamed from meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend)2
-rw-r--r--scripts/manifest.xml12
16 files changed, 108 insertions, 80 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/boundary.inc b/meta-boot2qt-distro/conf/distro/include/boundary.inc
index c8f5424..b08e11a 100644
--- a/meta-boot2qt-distro/conf/distro/include/boundary.inc
+++ b/meta-boot2qt-distro/conf/distro/include/boundary.inc
@@ -35,8 +35,6 @@ BBMASK += " \
35 meta-boundary/recipes-mozilla/firefox \ 35 meta-boundary/recipes-mozilla/firefox \
36 " 36 "
37 37
38EXTRA_IMAGEDEPENDS += "u-boot u-boot-script-boundary"
39
40MACHINE_EXTRA_INSTALL += "\ 38MACHINE_EXTRA_INSTALL += "\
41 kernel-module-qcacld \ 39 kernel-module-qcacld \
42 linux-firmware-bdsdmac-wlan \ 40 linux-firmware-bdsdmac-wlan \
diff --git a/meta-boot2qt-distro/conf/distro/include/fsl.inc b/meta-boot2qt-distro/conf/distro/include/fsl.inc
index 32fec1b..5f22dd4 100644
--- a/meta-boot2qt-distro/conf/distro/include/fsl.inc
+++ b/meta-boot2qt-distro/conf/distro/include/fsl.inc
@@ -29,7 +29,7 @@
29 29
30BBMASK += "meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5" 30BBMASK += "meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5"
31 31
32IMAGE_FSTYPES += "ext3 sdcard" 32IMAGE_FSTYPES += "ext3 wic"
33IMAGE_CLASSES += "image_types_fsl" 33IMAGE_CLASSES += "image_types_fsl"
34 34
35QBSP_IMAGE_CONTENT ?= "\ 35QBSP_IMAGE_CONTENT ?= "\
diff --git a/meta-boot2qt-distro/conf/distro/include/nitrogen6x.conf b/meta-boot2qt-distro/conf/distro/include/nitrogen6x.conf
index 894d51d..f6871be 100644
--- a/meta-boot2qt-distro/conf/distro/include/nitrogen6x.conf
+++ b/meta-boot2qt-distro/conf/distro/include/nitrogen6x.conf
@@ -33,25 +33,26 @@ include conf/distro/include/opencv.inc
33DEPLOY_CONF_NAME = "Boundary Devices i.MX6" 33DEPLOY_CONF_NAME = "Boundary Devices i.MX6"
34 34
35BOOT_SPACE = "16384" 35BOOT_SPACE = "16384"
36BOOT_SCRIPTS += "6x_upgrade-${MACHINE}:6x_upgrade \ 36IMAGE_BOOT_FILES += "\
37 u-boot-nit6xlite-*.imx:u-boot.nit6xlite \ 37 upgrade.scr-${MACHINE};upgrade.scr \
38 u-boot-nit6xlite1g-*.imx:u-boot.nit6xlite1g \ 38 upgrade.scr-${MACHINE};6x_upgrade \
39 u-boot-nitrogen6dl-*.imx:u-boot.nitrogen6dl \ 39 u-boot-${MACHINE}.imx-nit6xlite;u-boot.nit6xlite \
40 u-boot-nitrogen6dl2g-*.imx:u-boot.nitrogen6dl2g \ 40 u-boot-${MACHINE}.imx-nit6xlite1g;u-boot.nit6xlite1g \
41 u-boot-nitrogen6q2g-*.imx:u-boot.nitrogen6q2g \ 41 u-boot-${MACHINE}.imx-nitrogen6dl;u-boot.nitrogen6dl \
42 u-boot-nitrogen6q-*.imx:u-boot.nitrogen6q \ 42 u-boot-${MACHINE}.imx-nitrogen6dl2g;u-boot.nitrogen6dl2g \
43 u-boot-nitrogen6q_fl-*.imx:u-boot.nitrogen6q_fl \ 43 u-boot-${MACHINE}.imx-nitrogen6q2g;u-boot.nitrogen6q2g \
44 u-boot-nitrogen6qp_max-*.imx:u-boot.nitrogen6qp_max \ 44 u-boot-${MACHINE}.imx-nitrogen6q;u-boot.nitrogen6q \
45 u-boot-nitrogen6s1g-*.imx:u-boot.nitrogen6s1g \ 45 u-boot-${MACHINE}.imx-nitrogen6q_fl;u-boot.nitrogen6q_fl \
46 u-boot-nitrogen6s-*.imx:u-boot.nitrogen6s \ 46 u-boot-${MACHINE}.imx-nitrogen6qp_max;u-boot.nitrogen6qp_max \
47 u-boot-nitrogen6sx-*.imx:u-boot.nitrogen6sx \ 47 u-boot-${MACHINE}.imx-nitrogen6s1g;u-boot.nitrogen6s1g \
48 u-boot-nitrogen6_lum_dl1-*.imx:u-boot.nitrogen6_lum_dl1 \ 48 u-boot-${MACHINE}.imx-nitrogen6s;u-boot.nitrogen6s \
49 u-boot-nitrogen6_max-*.imx:u-boot.nitrogen6_max \ 49 u-boot-${MACHINE}.imx-nitrogen6sx;u-boot.nitrogen6sx \
50 u-boot-nitrogen6_vm1g-*.imx:u-boot.nitrogen6_vm1g \ 50 u-boot-${MACHINE}.imx-nitrogen6_lum_dl1;u-boot.nitrogen6_lum_dl1 \
51 u-boot-nitrogen6_vm-*.imx:u-boot.nitrogen6_vm \ 51 u-boot-${MACHINE}.imx-nitrogen6_max;u-boot.nitrogen6_max \
52 " 52 u-boot-${MACHINE}.imx-nitrogen6_vm1g;u-boot.nitrogen6_vm1g \
53 53 u-boot-${MACHINE}.imx-nitrogen6_vm;u-boot.nitrogen6_vm \
54PREFERRED_PROVIDER_virtual/bootloader = "u-boot-boundary" 54 "
55WKS_FILE_DEPENDS += "u-boot"
55 56
56UBOOT_MACHINE = "" 57UBOOT_MACHINE = ""
57UBOOT_CONFIG ??= "nit6xlite nit6xlite1g \ 58UBOOT_CONFIG ??= "nit6xlite nit6xlite1g \
diff --git a/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_7.%.bbappend b/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
index 4e55e66..4e55e66 100644
--- a/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_7.%.bbappend
+++ b/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
diff --git a/meta-boot2qt/classes/deploy-conf.bbclass b/meta-boot2qt/classes/deploy-conf.bbclass
index 22c6ef7..4999d4d 100644
--- a/meta-boot2qt/classes/deploy-conf.bbclass
+++ b/meta-boot2qt/classes/deploy-conf.bbclass
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -29,7 +29,7 @@
29 29
30inherit image_types 30inherit image_types
31 31
32IMAGE_DEPENDS_conf = "qtbase-native" 32do_image_conf[depends] += "qtbase-native:do_populate_sysroot"
33 33
34DEPLOY_CONF_NAME ?= "${MACHINE}" 34DEPLOY_CONF_NAME ?= "${MACHINE}"
35DEPLOY_CONF_TYPE ?= "Boot2Qt" 35DEPLOY_CONF_TYPE ?= "Boot2Qt"
diff --git a/meta-boot2qt/classes/image_types_sdcard.bbclass b/meta-boot2qt/classes/image_types_sdcard.bbclass
index 970c34b..3258dbd 100644
--- a/meta-boot2qt/classes/image_types_sdcard.bbclass
+++ b/meta-boot2qt/classes/image_types_sdcard.bbclass
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -28,14 +28,10 @@
28############################################################################ 28############################################################################
29 29
30IMAGE_ROOTFS_EXTRA_SPACE = "100000" 30IMAGE_ROOTFS_EXTRA_SPACE = "100000"
31SDCARD_ROOTFS = "${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.ext3"
32SDCARD_GENERATION_COMMAND ?= "generate_imx_sdcard"
33
34IMAGE_CMD_sdcard_append() {
35 parted -s ${SDCARD} set 1 boot on
36 31
32IMAGE_CMD_wic_append() {
37 rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img 33 rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img
38 ln -s ${IMAGE_NAME}.rootfs.sdcard ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img 34 ln -s ${IMAGE_NAME}.rootfs.wic ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img
39} 35}
40 36
41IMAGE_CMD_rpi-sdimg_append() { 37IMAGE_CMD_rpi-sdimg_append() {
@@ -48,7 +44,7 @@ build_hddimg_append() {
48 ln -s ${IMAGE_NAME}.hddimg ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img 44 ln -s ${IMAGE_NAME}.hddimg ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.img
49} 45}
50 46
51IMAGE_DEPENDS_tegraflash_append = " parted-native:do_populate_sysroot" 47do_image_tegraflash[depends] += "parted-native:do_populate_sysroot"
52create_tegraflash_pkg_prepend() { 48create_tegraflash_pkg_prepend() {
53 # Create partition table 49 # Create partition table
54 SDCARD=${IMGDEPLOYDIR}/${IMAGE_NAME}.img 50 SDCARD=${IMGDEPLOYDIR}/${IMAGE_NAME}.img
@@ -88,7 +84,7 @@ END
88 ln -sf ${IMAGE_NAME}.flasher.tar.gz ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.flasher.tar.gz 84 ln -sf ${IMAGE_NAME}.flasher.tar.gz ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.flasher.tar.gz
89} 85}
90 86
91IMAGE_DEPENDS_teziimg_append = " qtbase-native:do_populate_sysroot" 87do_image_teziimg[depends] += "qtbase-native:do_populate_sysroot"
92IMAGE_CMD_teziimg_append() { 88IMAGE_CMD_teziimg_append() {
93 ${IMAGE_CMD_TAR} --transform 's,^,${IMAGE_NAME}-Tezi_${PV}/,' -rhf ${IMGDEPLOYDIR}/${IMAGE_NAME}-Tezi_${PV}${TDX_VERDATE}.tar TEZI_B2QT_EULA.TXT Built_with_Qt.png 89 ${IMAGE_CMD_TAR} --transform 's,^,${IMAGE_NAME}-Tezi_${PV}/,' -rhf ${IMGDEPLOYDIR}/${IMAGE_NAME}-Tezi_${PV}${TDX_VERDATE}.tar TEZI_B2QT_EULA.TXT Built_with_Qt.png
94 ln -fs ${IMAGE_NAME}-Tezi_${PV}${TDX_VERDATE}.tar ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.tezi.tar 90 ln -fs ${IMAGE_NAME}-Tezi_${PV}${TDX_VERDATE}.tar ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.tezi.tar
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_4.%.bbappend
index da4b2c1..9bf3498 100644
--- a/meta-fsl-extras/recipes/linux/linux-boundary_4.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-boundary_4.%.bbappend
@@ -33,7 +33,7 @@ SRC_URI += " \
33 " 33 "
34 34
35# kernel image files are not needed in the image 35# kernel image files are not needed in the image
36RDEPENDS_kernel-base = "" 36RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
37 37
38do_preconfigure_prepend() { 38do_preconfigure_prepend() {
39 echo "CONFIG_HID_MULTITOUCH=m" >> ${WORKDIR}/defconfig 39 echo "CONFIG_HID_MULTITOUCH=m" >> ${WORKDIR}/defconfig
diff --git a/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend
index 74fa4ab..a668575 100644
--- a/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend
@@ -28,7 +28,7 @@
28############################################################################ 28############################################################################
29 29
30# kernel image files are not needed in the image 30# kernel image files are not needed in the image
31RDEPENDS_kernel-base = "" 31RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
32 32
33do_preconfigure_prepend() { 33do_preconfigure_prepend() {
34 # FunctionFS for qdbd 34 # FunctionFS for qdbd
diff --git a/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend
index 47fd1bf..eb5364d 100644
--- a/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend
@@ -28,7 +28,7 @@
28############################################################################ 28############################################################################
29 29
30# kernel image files are not needed in the image 30# kernel image files are not needed in the image
31RDEPENDS_kernel-base = "" 31RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
32 32
33do_preconfigure_prepend() { 33do_preconfigure_prepend() {
34 # FunctionFS for qdbd 34 # FunctionFS for qdbd
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
index 0343f06..123782e 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
@@ -1,23 +1,23 @@
1From 554d219b3485402c6992abc0aa32c74e8f251876 Mon Sep 17 00:00:00 2001 1From 07234c1c0f991a560010672a619740e385778f90 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com> 2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Thu, 11 Feb 2016 10:17:51 +0200 3Date: Thu, 11 Feb 2016 10:17:51 +0200
4Subject: [PATCH] Add support for KOE tx31d200vm0baa display 4Subject: [PATCH] Add support for KOE tx31d200vm0baa display
5 5
6Used for the cluster demo 6Used for the cluster demo
7--- 7---
8 arch/arm/include/asm/imx-common/fbpanel.h | 27 +++++++++++++++++++++++++++ 8 arch/arm/include/asm/imx-common/fbpanel.h | 27 ++++++++++++++++++++
9 board/boundary/nitrogen6_max/nitrogen6_max.c | 1 + 9 board/boundary/nitrogen6_max/nitrogen6_max.c | 1 +
10 board/boundary/nitrogen6sx/nitrogen6sx.c | 1 + 10 board/boundary/nitrogen6sx/nitrogen6sx.c | 1 +
11 board/boundary/nitrogen6x/nitrogen6x.c | 1 + 11 board/boundary/nitrogen6x/nitrogen6x.c | 1 +
12 4 files changed, 30 insertions(+) 12 4 files changed, 30 insertions(+)
13 13
14diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h 14diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h
15index b6f7af4..b8acdae 100644 15index f5465c3c80..643cd86e29 100644
16--- a/arch/arm/include/asm/imx-common/fbpanel.h 16--- a/arch/arm/include/asm/imx-common/fbpanel.h
17+++ b/arch/arm/include/asm/imx-common/fbpanel.h 17+++ b/arch/arm/include/asm/imx-common/fbpanel.h
18@@ -39,6 +39,33 @@ void fbp_enable_fb(struct display_info_t const *di, int enable); 18@@ -116,6 +116,33 @@ void fbp_setup_display(const struct display_info_t *displays, int cnt);
19 int fbp_detect_i2c(struct display_info_t const *di); 19 .fbtype = FB_##_mode,\
20 void fbp_setup_display(const struct display_info_t *displays, int cnt); 20 .fbflags = _flags
21 21
22+/* tx31d200vm0baa == koe */ 22+/* tx31d200vm0baa == koe */
23+#define IMX_VD_KOE(_mode, _detect, _bus) \ 23+#define IMX_VD_KOE(_mode, _detect, _bus) \
@@ -47,44 +47,41 @@ index b6f7af4..b8acdae 100644
47+} 47+}
48+ 48+
49 /* hdmi settings */ 49 /* hdmi settings */
50 #define IMX_VD50_1280_720M_60(_mode, _detect, _bus) \ 50 #define VDF_1280_720M_60(_mode, _name, _fmt, _flags, _detect, _bus, _addr) \
51 {\ 51 {\
52diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c 52diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c
53index 337e9b5..ba29aee 100644 53index 1c4106e735..51bc0bd8f3 100644
54--- a/board/boundary/nitrogen6_max/nitrogen6_max.c 54--- a/board/boundary/nitrogen6_max/nitrogen6_max.c
55+++ b/board/boundary/nitrogen6_max/nitrogen6_max.c 55+++ b/board/boundary/nitrogen6_max/nitrogen6_max.c
56@@ -568,6 +568,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) 56@@ -497,6 +497,7 @@ int fbp_detect_serializer(struct display_info_t const *di)
57 } 57 }
58 58
59 static const struct display_info_t displays[] = { 59 static const struct display_info_t displays[] = {
60+ IMX_VD_KOE(LVDS, 0, 2), 60+ IMX_VD_KOE(LVDS, 0, 2),
61 /* hdmi */ 61 /* hdmi */
62 IMX_VD50_1280_720M_60(HDMI, 1, 1), 62 VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
63 IMX_VD50_1920_1080M_60(HDMI, 0, 1), 63 VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
64diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c 64diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c
65index cdabcd8..de6582e 100644 65index dc05042add..3725d63cf3 100644
66--- a/board/boundary/nitrogen6sx/nitrogen6sx.c 66--- a/board/boundary/nitrogen6sx/nitrogen6sx.c
67+++ b/board/boundary/nitrogen6sx/nitrogen6sx.c 67+++ b/board/boundary/nitrogen6sx/nitrogen6sx.c
68@@ -685,6 +685,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) 68@@ -436,6 +436,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
69 69 }
70 70
71 static const struct display_info_t displays[] = { 71 static const struct display_info_t displays[] = {
72+ IMX_VD_KOE(LVDS, 0, 2), 72+ IMX_VD_KOE(LVDS, 0, 2),
73 /* hdmi/lcd */ 73 /* hdmi/lcd via tfp410 */
74 _IMX_VD_1280_720M_60(LCD, 1, 2, 50, 0), 74 VDF_1280_720M_60(LCD, "1280x720M@60", RGB24, 0, fbp_detect_i2c, 2, 0x50),
75 _IMX_VD_1920_1080M_60(LCD, 0, 2, 50, 0), 75 VDF_1920_1080M_60(LCD, "1920x1080M@60", RGB24, 0, NULL, 2, 0x50),
76diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c 76diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c
77index 21d6cd7..b24f2f6 100644 77index d9f6a829f1..80b102e206 100644
78--- a/board/boundary/nitrogen6x/nitrogen6x.c 78--- a/board/boundary/nitrogen6x/nitrogen6x.c
79+++ b/board/boundary/nitrogen6x/nitrogen6x.c 79+++ b/board/boundary/nitrogen6x/nitrogen6x.c
80@@ -525,6 +525,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) 80@@ -359,6 +359,7 @@ void board_pre_enable(const struct display_info_t *di)
81 } 81 }
82 82
83 static const struct display_info_t displays[] = { 83 static const struct display_info_t displays[] = {
84+ IMX_VD_KOE(LVDS, 0, 2), 84+ IMX_VD_KOE(LVDS, 0, 2),
85 /* hdmi */ 85 /* hdmi */
86 IMX_VD50_1280_720M_60(HDMI, 1, 1), 86 VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
87 IMX_VD50_1920_1080M_60(HDMI, 0, 1), 87 VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
88--
891.9.1
90
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
index 9eda199..b0791e9 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
@@ -1,4 +1,4 @@
1From 59d272d9df5337bb4bd62a96fc16c8e280c49344 Mon Sep 17 00:00:00 2001 1From fa2e83db63fe5abdfa00d205301d12e1a271a291 Mon Sep 17 00:00:00 2001
2From: Mikko Gronoff <mikko.gronoff@qt.io> 2From: Mikko Gronoff <mikko.gronoff@qt.io>
3Date: Sun, 23 Apr 2017 21:47:01 +0300 3Date: Sun, 23 Apr 2017 21:47:01 +0300
4Subject: [PATCH] set CMA reserved size to 384MB 4Subject: [PATCH] set CMA reserved size to 384MB
@@ -10,12 +10,12 @@ video decoding cannot work for high resolution videos.
10 1 file changed, 1 insertion(+) 10 1 file changed, 1 insertion(+)
11 11
12diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h 12diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h
13index 646c505..ddbb4c5 100644 13index bd4e54cb67..48114d5739 100644
14--- a/include/configs/nitrogen6x.h 14--- a/include/configs/nitrogen6x.h
15+++ b/include/configs/nitrogen6x.h 15+++ b/include/configs/nitrogen6x.h
16@@ -28,6 +28,7 @@ 16@@ -33,6 +33,7 @@
17 #define CONFIG_USB_MAX_CONTROLLER_COUNT 2 17 #define CONFIG_USB_MAX_CONTROLLER_COUNT 2
18 #define CONFIG_VIDEO 18
19 #define BD_I2C_MASK 7 19 #define BD_I2C_MASK 7
20+#define BD_CMA "384M" 20+#define BD_CMA "384M"
21 21
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
new file mode 100644
index 0000000..c5fa923
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
@@ -0,0 +1,36 @@
1From 22c5a278b98cf6ea4e4a402bca19d1354ab3c431 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Tue, 25 Sep 2018 16:05:17 +0300
4Subject: [PATCH] Disable build for tools and use mkimage from sysroot
5
6fails when trying to compile with host gcc: unable to execute
7'x86_64-linux-gnu-gcc': No such file or directory
8---
9 Makefile | 2 +-
10 scripts/Makefile.lib | 2 +-
11 2 files changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/Makefile b/Makefile
14index 119ad49eec..022690e26e 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -698,7 +698,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/)
18
19 libs-y := $(sort $(libs-y))
20
21-u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y))) tools examples
22+u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y)))
23
24 u-boot-alldirs := $(sort $(u-boot-dirs) $(patsubst %/,%,$(filter %/, $(libs-))))
25
26diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
27index 80ddb08474..e86c949f08 100644
28--- a/scripts/Makefile.lib
29+++ b/scripts/Makefile.lib
30@@ -493,5 +493,5 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \
31 # ---------------------------------------------------------------------------
32 MKIMAGEOUTPUT ?= /dev/null
33 quiet_cmd_mkimage = MKIMAGE $@
34-cmd_mkimage = $(objtree)/tools/mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
35+cmd_mkimage = mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
36 $(if $(KBUILD_VERBOSE:1=), >$(MKIMAGEOUTPUT))
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_%.bbappend
index 013e54b..3b5235f 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_%.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -31,4 +31,7 @@ FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31SRC_URI += " \ 31SRC_URI += " \
32 file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \ 32 file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \
33 file://0002-set-CMA-reserved-size-to-384MB.patch \ 33 file://0002-set-CMA-reserved-size-to-384MB.patch \
34 file://0003-Disable-build-for-tools.patch \
34 " 35 "
36
37DEPENDS += "u-boot-mkimage-native"
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch
index 7d8e8ec..02a1e33 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch
@@ -1,4 +1,4 @@
1From 3fdf74d6934858d04d9e7df7cd24779bf7d9fdbb Mon Sep 17 00:00:00 2001 1From 3c3c3284727076f4ae751bfc9cadb222423c9a4b Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com> 2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Wed, 13 Jan 2016 08:55:41 +0200 3Date: Wed, 13 Jan 2016 08:55:41 +0200
4Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display 4Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display
@@ -8,12 +8,12 @@ Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display
8 1 file changed, 6 insertions(+) 8 1 file changed, 6 insertions(+)
9 9
10diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt 10diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
11index 7c11f4c..86242b5 100644 11index f6bf2f5..427d837 100644
12--- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt 12--- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
13+++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt 13+++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
14@@ -105,6 +105,12 @@ else 14@@ -130,6 +130,12 @@ if itest.s "x" != "x${disable_msi}" ; then
15 setenv bootargs "${bootargs} root=/dev/mmcblk${disk}p${bpart}" 15 setenv bootargs ${bootargs} pci=nomsi
16 fi 16 fi;
17 17
18+if test "hannstar" = "${fb_lvds}" || test "hannstar" = "${fb_lvds2}" ; then 18+if test "hannstar" = "${fb_lvds}" || test "hannstar" = "${fb_lvds2}" ; then
19+ setenv bootargs ${bootargs} ft5x06_ts.screenres=1024,600 19+ setenv bootargs ${bootargs} ft5x06_ts.screenres=1024,600
@@ -24,6 +24,3 @@ index 7c11f4c..86242b5 100644
24 if itest.s "x" != "x${disable_giga}" ; then 24 if itest.s "x" != "x${disable_giga}" ; then
25 setenv bootargs ${bootargs} fec.disable_giga=1 25 setenv bootargs ${bootargs} fec.disable_giga=1
26 fi 26 fi
27--
281.9.1
29
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_%.bbappend
index dafcf84..e4b3730 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_%.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index f81e384..0c9155b 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -18,11 +18,11 @@
18 18
19 <project name="poky" 19 <project name="poky"
20 remote="yocto" 20 remote="yocto"
21 revision="ebb42af2829edfca1a23c7a51a431c656ffc2090" 21 revision="5b5ebab2998b2f6c05edf933cd54a1592d4bcc5c"
22 path="sources/poky"/> 22 path="sources/poky"/>
23 <project name="meta-openembedded" 23 <project name="meta-openembedded"
24 remote="oe-mirror" 24 remote="oe-mirror"
25 revision="9eaebc6e783f1394bb5444326cd05a976b3122e9" 25 revision="b0950aeff5b630256bb5e25ca15f4d59c115e7c1"
26 path="sources/meta-openembedded"/> 26 path="sources/meta-openembedded"/>
27 <project name="meta-qt5" 27 <project name="meta-qt5"
28 remote="qtyocto" 28 remote="qtyocto"
@@ -30,17 +30,17 @@
30 path="sources/meta-qt5"/> 30 path="sources/meta-qt5"/>
31 <project name="meta-mingw" 31 <project name="meta-mingw"
32 remote="qtyocto" 32 remote="qtyocto"
33 revision="2a5619ffdc0f02f57e0c36387fd25c8540c60a8a" 33 revision="fde300483f2133489c1f16b5b03a22050613787b"
34 path="sources/meta-mingw"/> 34 path="sources/meta-mingw"/>
35 35
36 <project name="meta-freescale" 36 <project name="meta-freescale"
37 remote="freescale" 37 remote="freescale"
38 revision="af5a8cf74d488ba45715ed0b0e0441e60b10c31d" 38 revision="2813c0c59a81498afab26a2b1f90db07728df2ed"
39 path="sources/meta-freescale" 39 path="sources/meta-freescale"
40 groups="notdefault,external,fsl,toradex,smx6,renesas-gen3,boundary,fsl-imx8"/> 40 groups="notdefault,external,fsl,toradex,smx6,renesas-gen3,boundary,fsl-imx8"/>
41 <project name="meta-freescale-3rdparty" 41 <project name="meta-freescale-3rdparty"
42 remote="freescale" 42 remote="freescale"
43 revision="9613dbc02ca970122a01c935bc9e5789ced73a9d" 43 revision="ba684412e6983eeda0ef7158a724305f0f1a2f0a"
44 path="sources/meta-freescale-3rdparty" 44 path="sources/meta-freescale-3rdparty"
45 groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8"/> 45 groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8"/>
46 <project name="meta-raspberrypi" 46 <project name="meta-raspberrypi"
@@ -80,7 +80,7 @@
80 groups="notdefault,external,toradex"/> 80 groups="notdefault,external,toradex"/>
81 <project name="meta-boundary" 81 <project name="meta-boundary"
82 remote="boundary" 82 remote="boundary"
83 revision="42b00061076b2a6e15c1eeed7da6fc14a0dae9d8" 83 revision="107a7ceba84b87e1e2a463fea27ae5c53c4e452f"
84 path="sources/meta-boundary" 84 path="sources/meta-boundary"
85 groups="notdefault,external,boundary"/> 85 groups="notdefault,external,boundary"/>
86 <project name="meta-fsl-bsp-release" 86 <project name="meta-fsl-bsp-release"