summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-08-14 15:10:25 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-08-19 09:50:27 +0000
commiteff7572615b2145d3db67565eef124edb0f60bc6 (patch)
tree69004d6953be4c7753f3961d461939cc628ad254
parent304d492506a62cd7a24dbed39f822f442fbe6230 (diff)
downloadmeta-boot2qt-eff7572615b2145d3db67565eef124edb0f60bc6.tar.gz
tibidabo: fix PRIC usage in meta-tibidabo
The bbappends in meta-tibidabo try to use PRIC, which cases error with fido. Prevent this by setting PRINC to -1 in main bb files. Change-Id: Icd307d671260c330b10988158fb157048b66561c Reviewed-by: aavit <eirik.aavitsland@theqtcompany.com>
-rw-r--r--meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb3
-rw-r--r--meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb b/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
index 948382f..4fbd2b3 100644
--- a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
+++ b/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
@@ -33,3 +33,6 @@ do_configure_prepend() {
33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig 33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig 34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
35} 35}
36
37# bbappend in meta-tibidabo still tries to use PRINC, set to -1 to prevent errors
38PRINC = "-1"
diff --git a/meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb b/meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb
index 73d4371..f72844e 100644
--- a/meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb
+++ b/meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb
@@ -23,3 +23,6 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
23 HOSTSTRIP=true' 23 HOSTSTRIP=true'
24 24
25PACKAGE_ARCH = "${MACHINE_ARCH}" 25PACKAGE_ARCH = "${MACHINE_ARCH}"
26
27# bbappend in meta-tibidabo still tries to use PRINC, set to -1 to prevent errors
28PRINC = "-1"