summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Schulz <david.schulz@theqtcompany.com>2016-03-07 08:16:11 +0100
committerDavid Schulz <david.schulz@theqtcompany.com>2016-03-08 07:23:34 +0000
commit7eba608a92ee934440a5468ed81237bbae90f12a (patch)
tree7840848db231e4ea0605eeedfaff33e60ce5f1b8
parentad78ccfc7e6f9a311161cde3951ca37d7d3601b0 (diff)
downloadmeta-boot2qt-7eba608a92ee934440a5468ed81237bbae90f12a.tar.gz
Disable ethernet over usb on beaglebone.
Otherwise the device isn't auto detected by adb on windows. Change-Id: I147689233562c16b23353c67cf8646c14e5da378 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r--meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend b/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend
index 5d02ff6..a945ea8 100644
--- a/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend
+++ b/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend
@@ -33,5 +33,8 @@ KERNEL_IMAGETYPE = "zImage"
33B = "${S}" 33B = "${S}"
34 34
35do_configure_prepend() { 35do_configure_prepend() {
36 sed -e '/CONFIG_USB_FUNCTIONFS_ETH=/d' \
37 -e '/CONFIG_USB_FUNCTIONFS_RNDIS=/d' \
38 -i ${WORKDIR}/defconfig
36 echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig 39 echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
37} 40}