summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-10-15 12:57:05 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-10-26 14:32:28 +0000
commit4157cb42693171cb4f8e47752393a240461f7efa (patch)
tree4bc773b9aaf6d4cb092fb86b6b9928c10c10a440
parenta2d7a1698ebebdb40829fc20cd89115bc584fd94 (diff)
downloadmeta-boot2qt-4157cb42693171cb4f8e47752393a240461f7efa.tar.gz
qt5: oe-device-extra.pri is now supported in upstream
Use of oe-device-extra.pri was merged upstream, so remove unneeded parts for our layer. Change-Id: I40ffeadc80780d49ba777e7cfd24fc2048d3a418 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf2
-rw-r--r--recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri3
-rw-r--r--recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri2
-rw-r--r--recipes-qt/qt5/qtbase/oe-device-extra.pri2
-rw-r--r--recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri2
-rw-r--r--recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri3
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend9
-rw-r--r--scripts/manifest.xml2
8 files changed, 13 insertions, 12 deletions
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf
index dadea00..b5962dc 100644
--- a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf
+++ b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk/qmake.conf
@@ -4,8 +4,6 @@
4 4
5include(../common/linux_device_pre.conf) 5include(../common/linux_device_pre.conf)
6 6
7QMAKE_PLATFORM += boot2qt
8
9# Load device-specific qmake.conf part, if any 7# Load device-specific qmake.conf part, if any
10exists(../../oe-device-extra.pri):include(../../oe-device-extra.pri) 8exists(../../oe-device-extra.pri):include(../../oe-device-extra.pri)
11 9
diff --git a/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri b/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri
index 3c0971c..9f6fdc3 100644
--- a/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri
+++ b/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri
@@ -1,2 +1,5 @@
1QMAKE_LIBS_EGL = -lQtGlesStreamClient 1QMAKE_LIBS_EGL = -lQtGlesStreamClient
2QMAKE_LIBS_OPENGL_ES2 = -lQtGlesStreamClient 2QMAKE_LIBS_OPENGL_ES2 = -lQtGlesStreamClient
3
4QMAKE_PLATFORM += boot2qt
5QT_QPA_DEFAULT_PLATFORM = eglfs
diff --git a/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri b/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri
index f365169..f5445e3 100644
--- a/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri
+++ b/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri
@@ -5,4 +5,6 @@ QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL
5QMAKE_CFLAGS += $$IMX6_CFLAGS 5QMAKE_CFLAGS += $$IMX6_CFLAGS
6QMAKE_CXXFLAGS += $$IMX6_CFLAGS 6QMAKE_CXXFLAGS += $$IMX6_CFLAGS
7 7
8QMAKE_PLATFORM += boot2qt
9QT_QPA_DEFAULT_PLATFORM = eglfs
8EGLFS_DEVICE_INTEGRATION = eglfs_viv 10EGLFS_DEVICE_INTEGRATION = eglfs_viv
diff --git a/recipes-qt/qt5/qtbase/oe-device-extra.pri b/recipes-qt/qt5/qtbase/oe-device-extra.pri
index 6c4bdd9..250c999 100644
--- a/recipes-qt/qt5/qtbase/oe-device-extra.pri
+++ b/recipes-qt/qt5/qtbase/oe-device-extra.pri
@@ -1 +1,3 @@
1# This file contains device-specific qmake.conf settings 1# This file contains device-specific qmake.conf settings
2QMAKE_PLATFORM += boot2qt
3QT_QPA_DEFAULT_PLATFORM = eglfs
diff --git a/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri b/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri
index 84488cb..9f64808 100644
--- a/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri
+++ b/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri
@@ -6,4 +6,6 @@ QMAKE_LIBS_EGL = -lEGL -lGLESv2
6QMAKE_CFLAGS += $$RPI_CFLAGS 6QMAKE_CFLAGS += $$RPI_CFLAGS
7QMAKE_CXXFLAGS += $$RPI_CFLAGS 7QMAKE_CXXFLAGS += $$RPI_CFLAGS
8 8
9QMAKE_PLATFORM += boot2qt
10QT_QPA_DEFAULT_PLATFORM = eglfs
9EGLFS_DEVICE_INTEGRATION = eglfs_brcm 11EGLFS_DEVICE_INTEGRATION = eglfs_brcm
diff --git a/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri b/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri
index 6a5edd9..0a18a5d 100644
--- a/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri
+++ b/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri
@@ -1,3 +1,6 @@
1QMAKE_LIBS_EGL = -lEGL -lIMGegl -lsrv_um 1QMAKE_LIBS_EGL = -lEGL -lIMGegl -lsrv_um
2QMAKE_LIBS_OPENGL_ES2 = -lGLESv2 $${QMAKE_LIBS_EGL} 2QMAKE_LIBS_OPENGL_ES2 = -lGLESv2 $${QMAKE_LIBS_EGL}
3QMAKE_LIBS_OPENVG = -lOpenVG $${QMAKE_LIBS_EGL} 3QMAKE_LIBS_OPENVG = -lOpenVG $${QMAKE_LIBS_EGL}
4
5QMAKE_PLATFORM += boot2qt
6QT_QPA_DEFAULT_PLATFORM = eglfs
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index f29cb10..adddd94 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -43,13 +43,4 @@ SRC_URI += " \
43 43
44do_configure_prepend() { 44do_configure_prepend() {
45 install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs 45 install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs
46 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
47 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
48QMAKE_PLATFORM += boot2qt
49QT_QPA_DEFAULT_PLATFORM = eglfs
50
51exists(../oe-device-extra.pri):include(../oe-device-extra.pri)
52
53load(qt_config)
54EOF
55} 46}
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index acdbe21..e1e7e4c 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -21,7 +21,7 @@
21 path="sources/meta-openembedded"/> 21 path="sources/meta-openembedded"/>
22 <project name="meta-qt5" 22 <project name="meta-qt5"
23 remote="meta-qt5" 23 remote="meta-qt5"
24 revision="51b4620392aa9041d8512549bfa554bea368c5ea" 24 revision="89038bffd224a0d43aa8627472374503b3023f61"
25 path="sources/meta-qt5"/> 25 path="sources/meta-qt5"/>
26 26
27 <project name="meta-fsl-arm" 27 <project name="meta-fsl-arm"