summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-01-23 13:36:37 +0200
committerSamuli Piippo <samuli.piippo@digia.com>2014-01-30 12:16:59 +0200
commit20a3734c0da057a51aadc89e3dba163367611dc5 (patch)
treed12c2482dc7faccd3cb25220ac1d22d8173c70e9
parentc3918d45cd6ae9601d99bf695d8672f2fc7f1f1e (diff)
downloadmeta-boot2qt-20a3734c0da057a51aadc89e3dba163367611dc5.tar.gz
upgrade emulator components
- kernel 3.10 - LLVM 3.3 - mesa 9.1.6 Change-Id: Ib15c6826ab480e39e4efb7a16d42030b55ad6c3b Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
-rw-r--r--classes/image-hdd.bbclass19
-rw-r--r--conf/distro/include/emulator.conf2
-rw-r--r--conf/machine/emulator.conf1
-rw-r--r--recipes/linux/linux-yocto_3.10.bbappend (renamed from recipes/linux/linux-yocto_3.8.bbappend)3
-rw-r--r--recipes/llvm/llvm-common.bb44
-rw-r--r--recipes/llvm/llvm-common/llvm-config10
-rw-r--r--recipes/llvm/llvm.inc226
-rw-r--r--recipes/llvm/llvm3.2/arm_fenv_uclibc.patch14
-rw-r--r--recipes/llvm/llvm3.2_3.2.bb127
-rw-r--r--recipes/mesa/mesa_9.1.6.bbappend6
10 files changed, 11 insertions, 441 deletions
diff --git a/classes/image-hdd.bbclass b/classes/image-hdd.bbclass
index 123c417..fb59c20 100644
--- a/classes/image-hdd.bbclass
+++ b/classes/image-hdd.bbclass
@@ -29,32 +29,17 @@ SYSLINUX_PROMPT = "0"
29SYSLINUX_TIMEOUT = "1" 29SYSLINUX_TIMEOUT = "1"
30SYSLINUX_LABELS = "boot" 30SYSLINUX_LABELS = "boot"
31LABELS_append = " ${SYSLINUX_LABELS} " 31LABELS_append = " ${SYSLINUX_LABELS} "
32SYSLINUX_DEFAULT_CONSOLE = "console=ttyS0,115200"
32 33
33inherit image_types boot-directdisk 34inherit image_types boot-directdisk
34 35
35create_hdd_image () { 36create_hdd_image () {
36 ln -s ${IMAGE_NAME}.hdddirect ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.hdd 37 ln -fs ${IMAGE_NAME}.hdddirect ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.hdd
37} 38}
38 39
39python do_hddimg() { 40python do_hddimg() {
40 bb.build.exec_func('create_hdd_image', d) 41 bb.build.exec_func('create_hdd_image', d)
41} 42}
42 43
43python build_syslinux_cfg_append () {
44 import re
45
46 try:
47 cfgfile = file(cfile, 'r+')
48 except OSError:
49 raise bb.build.funcFailed('Unable to open %s' % (cfile))
50
51 f_content = cfgfile.read()
52 f_content = re.sub('tty0', 'ttyS0,115200', f_content)
53
54 cfgfile.seek(0)
55 cfgfile.write(f_content)
56 cfgfile.close()
57}
58
59addtask hddimg after do_bootdirectdisk before do_build 44addtask hddimg after do_bootdirectdisk before do_build
60do_hddimg[nostamp] = "1" 45do_hddimg[nostamp] = "1"
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf
index ce17052..d3d5efd 100644
--- a/conf/distro/include/emulator.conf
+++ b/conf/distro/include/emulator.conf
@@ -32,7 +32,7 @@ MACHINE_EXTRA_RRECOMMENDS += "\
32kernel_autoload_snd-intel8x0 = "snd-intel8x0" 32kernel_autoload_snd-intel8x0 = "snd-intel8x0"
33 33
34MACHINE_EXTRA_INSTALL = "\ 34MACHINE_EXTRA_INSTALL = "\
35 llvm3.2 \ 35 llvm3.3 \
36 libegl-mesa \ 36 libegl-mesa \
37 libegl-gallium \ 37 libegl-gallium \
38 libgles2-mesa \ 38 libgles2-mesa \
diff --git a/conf/machine/emulator.conf b/conf/machine/emulator.conf
index 2aac3ab..f2628d5 100644
--- a/conf/machine/emulator.conf
+++ b/conf/machine/emulator.conf
@@ -29,7 +29,6 @@ PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
29PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa" 29PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
30 30
31PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 31PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
32PREFERRED_VERSION_linux-yocto ?= "3.8%"
33 32
34require conf/machine/include/tune-i586.inc 33require conf/machine/include/tune-i586.inc
35 34
diff --git a/recipes/linux/linux-yocto_3.8.bbappend b/recipes/linux/linux-yocto_3.10.bbappend
index fa6d5eb..9cd7e69 100644
--- a/recipes/linux/linux-yocto_3.8.bbappend
+++ b/recipes/linux/linux-yocto_3.10.bbappend
@@ -25,4 +25,5 @@ SRC_URI += "\
25 file://snd_intel8x0.cfg \ 25 file://snd_intel8x0.cfg \
26 " 26 "
27 27
28COMPATIBLE_MACHINE += "|emulator" 28KMACHINE_emulator = "qemux86"
29COMPATIBLE_MACHINE_emulator = "emulator"
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
deleted file mode 100644
index 0e20600..0000000
--- a/recipes/llvm/llvm-common.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Helper script for OE's llvm support"
24LICENSE = "MIT"
25LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
26 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
27"
28
29SRC_URI = "file://llvm-config"
30
31ALLOW_EMPTY_${PN} = "1"
32SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_common_sysroot_preprocess"
33
34llvm_common_sysroot_preprocess() {
35 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
36 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
37}
38
39do_install_virtclass-native() {
40 install -d ${D}${bindir}
41 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
42}
43
44BBCLASSEXTEND = "native"
diff --git a/recipes/llvm/llvm-common/llvm-config b/recipes/llvm/llvm-common/llvm-config
deleted file mode 100644
index a9a416d..0000000
--- a/recipes/llvm/llvm-common/llvm-config
+++ /dev/null
@@ -1,10 +0,0 @@
1#!/bin/sh
2# Wrapper script for real llvm-config. Simply calls
3
4if [ $WANT_LLVM_RELEASE ]; then
5 exec `dirname $0`/${TARGET_PREFIX}llvm-config$WANT_LLVM_RELEASE ${@}
6else
7 echo "The variable WANT_LLVM_RELEASE is not defined and exported"
8 echo "by your build recipe. Go figure."
9 exit 1
10fi
diff --git a/recipes/llvm/llvm.inc b/recipes/llvm/llvm.inc
deleted file mode 100644
index fcd2666..0000000
--- a/recipes/llvm/llvm.inc
+++ /dev/null
@@ -1,226 +0,0 @@
1# LLVM does not provide ABI stability between different versions. For this
2# reason OE makes it possible to build and install different llvm versions
3# at the same time.
4#
5# This is true for the normal recipes as well as the native ones.
6#
7# All regular installation directories are prefixed with 'llvm${LLVM_RELEASE}'
8# e.g. "${STAGING_BINDIR}/llvm2.5" or "${STAGING_INCDIR}/llvm2.5"
9#
10# For your program or library that makes use of llvm you do should not need to
11# modify anything as long as it uses the results of various llvm-config
12# invocations. If you need customizations something is wrong and it needs to be
13# fixed (report bug).
14#
15# However the *recipe* for your program/library *must* declare
16# export WANT_LLVM_RELEASE = "<valid version number>"
17# The version number is picked up by a generic wrapper script which just calls
18# the variant of the specified version.
19
20DESCRIPTION = "The Low Level Virtual Machine"
21HOMEPAGE = "http://llvm.org"
22# 3-clause BSD-like
23LICENSE = "NCSA"
24LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0ac5f799a2d89477c75b0a378b221855"
25
26DEPENDS = "llvm${LLVM_RELEASE}-native llvm-common"
27DEPENDS_virtclass-native = "llvm-common-native cmake-native"
28
29INC_PR = "r2"
30
31SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.tgz"
32
33S = "${WORKDIR}/llvm-${PV}"
34
35inherit cmake perlnative pythonnative
36
37# Defines the LLVM supported arches. By now we always build either for ${BUILD}
38# (native) or ${TARGET}. In the future it may make sense to enable all backends
39# for the non-native build. The decision which backends are used is made by
40# the 3rd party program or library that uses llvm anyway.
41LLVM_ARCH = "${@get_llvm_arch(d)}"
42
43# This is used for generating the install directory for the llvm libraries,
44# binaries and headers. It makes side by side installation of those possible.
45LLVM_RELEASE = "${PV}"
46
47# llvm *must* be built out of tree
48OECMAKE_SOURCEPATH = ".."
49OECMAKE_BUILDPATH = "build"
50EXTRA_OECMAKE = "\
51 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm${LLVM_RELEASE}/tblgen \
52 -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
53 -DCMAKE_LINKER:FILEPATH=${LD} \
54 -DCMAKE_AR:FILEPATH=${AR} \
55 -DCMAKE_OBJCOPY:FILEPATH=${OBJCOPY} \
56 -DCMAKE_OBJDUMP:FILEPATH=${OBJDUMP} \
57 -DCMAKE_RANLIB:FILEPATH=${RANLIB} \
58 -DCMAKE_STRIP:FILEPATH=${STRIP} \
59 -DNM_PATH:FILEPATH=${NM} \
60 -DLLVM_ENABLE_PIC:BOOL=ON \
61 -DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
62 -DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
63 -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
64 -DBUILD_SHARED_LIBS:BOOL=ON \
65 -DCMAKE_SKIP_BUILD_RPATH:BOOL=ON \
66"
67# We need to reset this to avoid breakage as we build out of tree
68TOOLCHAIN_OPTIONS = ""
69
70PACKAGES_DYNAMIC = "llvm-*"
71
72# the difference to the non-native build is that we do not need
73# to declare the location of the tblgen executable.
74EXTRA_OECMAKE_virtclass-native = "\
75 -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
76 -DCMAKE_LINKER:FILEPATH=${LD} \
77 -DCMAKE_AR:FILEPATH=${AR} \
78 -DCMAKE_OBJCOPY:FILEPATH=${OBJCOPY} \
79 -DCMAKE_OBJDUMP:FILEPATH=${OBJDUMP} \
80 -DCMAKE_RANLIB:FILEPATH=${RANLIB} \
81 -DCMAKE_STRIP:FILEPATH=${STRIP} \
82 -DNM_PATH:FILEPATH=${NM} \
83"
84
85PACKAGES_virtclass-native = ""
86
87PACKAGES_DYNAMIC_virtclass-native = ""
88
89python populate_packages_prepend () {
90 libllvm_libdir = bb.data.expand('${libdir}/llvm${LLVM_RELEASE}', d)
91 do_split_packages(d, libllvm_libdir, '^lib(.*)\.so$', 'libllvm-%s', 'Split package for %s', allow_dirs=True)
92}
93
94FILES_${PN} = ""
95ALLOW_EMPTY_${PN} = "1"
96
97FILES_${PN}-dbg += "${libdir}/llvm${LLVM_RELEASE}/.debug ${bindir}/llvm${LLVM_RELEASE}/.debug"
98
99FILES_${PN}-dev = " \
100 ${includedir} \
101 ${bindir}/* \
102 ${libdir}/llvm${LLVM_RELEASE}/LLVMHello.so \
103 ${libdir}/llvm${LLVM_RELEASE}/BugpointPasses.so \
104 ${libdir}/llvm${LLVM_RELEASE}/*.a \
105"
106
107base_do_compile_prepend() {
108 # Avoid *** No rule to make target `native/bin/tblgen', needed by `include/llvm/Intrinsics.gen.tmp'
109 oe_runmake tblgen
110}
111
112do_install() {
113 # Install into a private directory to be able to reorganize the files.
114
115 cd ${OECMAKE_BUILDPATH}
116
117 oe_runmake DESTDIR=${WORKDIR}/llvm-install install
118
119 # Create our custom target directories
120 install -d ${D}${bindir}/llvm${LLVM_RELEASE}
121 install -d ${D}${includedir}/llvm${LLVM_RELEASE}
122 install -d ${D}${libdir}/llvm${LLVM_RELEASE}
123
124 # Move headers into their own directory
125 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm \
126 ${D}${includedir}/llvm${LLVM_RELEASE}/
127 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm-c \
128 ${D}${includedir}/llvm${LLVM_RELEASE}/
129
130 find ${WORKDIR}/llvm-install/${prefix}/lib -name "*" -maxdepth 1 -exec \
131 install {} ${D}${libdir}/llvm${LLVM_RELEASE} \;
132
133 # I dont know another way out. Binaries are installed into a special subdir
134 find ${WORKDIR}/llvm-install/${prefix}/bin -name "*" -maxdepth 1 -exec \
135 install {} ${D}${bindir}/llvm${LLVM_RELEASE} \;
136
137 # LLVM does not install this by default.
138 install bin/tblgen ${D}${bindir}/llvm${LLVM_RELEASE}
139
140 # we install it here unmodified for native and none native and overwrite it
141 # later for native case
142 install -d ${D}${bindir}
143 install -m 0755 bin/llvm-config ${D}${bindir}
144}
145
146SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_sysroot_preprocess"
147
148llvm_sysroot_preprocess() {
149 cd ${OECMAKE_BUILDPATH}
150
151 # Fix the paths in the config script to make it find the binaries and
152 # library files. Doing so allows 3rd party configure scripts working
153 # unmodified.
154 sed -e's!my.*ABS_RUN_DIR =.*!my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";!' \
155 -e's!my.*INCLUDEDIR =.*!my $INCLUDEDIR = "${STAGING_INCDIR}/llvm${LLVM_RELEASE}";!' \
156 -e's!my.*LIBDIR.*!my $LIBDIR = "${STAGING_LIBDIR}/llvm${LLVM_RELEASE}";!' \
157 -e's!my.*BINDIR.*!my $BINDIR = "${STAGING_BINDIR}/llvm${LLVM_RELEASE}";!' \
158 bin/llvm-config > bin/llvm-config${LLVM_RELEASE}
159
160 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
161 install -m 0755 bin/llvm-config${LLVM_RELEASE} ${SYSROOT_DESTDIR}${bindir_crossscripts}
162}
163
164do_install_virtclass-native() {
165 # Install into a private directory to be able to reorganize the files.
166
167 cd ${OECMAKE_BUILDPATH}
168
169 oe_runmake DESTDIR=${WORKDIR}/llvm-install install
170
171 # Create our custom target directories
172 install -d ${D}${bindir}/llvm${LLVM_RELEASE}
173 install -d ${D}${includedir}/llvm${LLVM_RELEASE}
174 install -d ${D}${libdir}/llvm${LLVM_RELEASE}
175
176 # Move headers into their own directory
177 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm \
178 ${D}${includedir}/llvm${LLVM_RELEASE}/
179 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm-c \
180 ${D}${includedir}/llvm${LLVM_RELEASE}/
181
182 find ${WORKDIR}/llvm-install/${prefix}/lib -name "*" -maxdepth 1 -exec \
183 install {} ${D}${libdir}/llvm${LLVM_RELEASE} \;
184
185 # I dont know another way out. Binaries are installed into a special subdir
186 find ${WORKDIR}/llvm-install/${prefix}/bin -name "*" -maxdepth 1 -exec \
187 install {} ${D}${bindir}/llvm${LLVM_RELEASE} \;
188
189 # LLVM does not install this by default.
190 install bin/tblgen ${D}${bindir}/llvm${LLVM_RELEASE}
191
192 # Fix the paths in the config script to make it find the binaries and
193 # library files. Doing so allows 3rd party configure scripts working
194 # unmodified.
195 sed -e's!my.*ABS_RUN_DIR =.*!my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";!' \
196 -e's!my.*INCLUDEDIR =.*!my $INCLUDEDIR = "${STAGING_INCDIR}/llvm${LLVM_RELEASE}";!' \
197 -e's!my.*LIBDIR.*!my $LIBDIR = "${STAGING_LIBDIR}/llvm${LLVM_RELEASE}";!' \
198 -e's!my.*BINDIR.*!my $BINDIR = "${STAGING_BINDIR}/llvm${LLVM_RELEASE}";!' \
199 bin/llvm-config > bin/llvm-config${LLVM_RELEASE}
200
201 install -d ${D}${bindir}
202 install -m 0755 bin/llvm-config${LLVM_RELEASE} ${D}${bindir}
203}
204
205
206# Retrieve the target in a way that is compatible to the arch
207# value in llvm (>= 2.5)
208def get_llvm_arch(d):
209 import bb;
210
211 arch = bb.data.getVar('TARGET_ARCH', d, 1)
212 if arch == "x86_64" or arch == "i486" or arch == "i586" or arch == "i686":
213 arch = "X86"
214 elif arch == "arm":
215 arch = "ARM"
216 elif arch == "mipsel" or arch == "mips":
217 arch = "mips"
218 elif arch == "powerpc" or arch == "powerpc64":
219 arch = "PowerPC"
220 else:
221 bb.warn("%s does not support %s yet" % (bb.data.getVar('PN', d, 1), arch) );
222
223 return arch
224
225BBCLASSEXTEND = "native"
226
diff --git a/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch b/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch
deleted file mode 100644
index c3ae494..0000000
--- a/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1Index: llvm-2.9/include/llvm/Support/FEnv.h
2===================================================================
3--- llvm-2.9.orig/include/llvm/Support/FEnv.h 2010-11-29 20:44:50.000000000 +0100
4+++ llvm-2.9/include/llvm/Support/FEnv.h 2011-11-18 18:42:22.580161297 +0100
5@@ -17,6 +17,9 @@
6
7 #include "llvm/Config/config.h"
8 #include <cerrno>
9+
10+#undef HAVE_FENV_H
11+
12 #ifdef HAVE_FENV_H
13 #include <fenv.h>
14 #endif
diff --git a/recipes/llvm/llvm3.2_3.2.bb b/recipes/llvm/llvm3.2_3.2.bb
deleted file mode 100644
index 92b62f9..0000000
--- a/recipes/llvm/llvm3.2_3.2.bb
+++ /dev/null
@@ -1,127 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "The Low Level Virtual Machine"
24HOMEPAGE = "http://llvm.org"
25# 3-clause BSD-like
26LICENSE = "NCSA"
27LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=60fdd7739841f04a2ce2171a726be8f3"
28
29DEPENDS = "libffi libxml2-native llvm-common"
30
31SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz"
32SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch "
33
34SRC_URI[md5sum] = "71610289bbc819e3e15fdd562809a2d7"
35SRC_URI[sha256sum] = "125090c4d26740f1d5e9838477c931ed7d9ad70d599ba265f46f3a42cb066343"
36
37S = "${WORKDIR}/llvm-${PV}.src"
38
39inherit autotools perlnative pythonnative
40
41LLVM_BUILD_DIR = "${WORKDIR}/llvm-${PV}.build"
42LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
43LLVM_DIR = "llvm${PV}"
44
45EXTRA_OECONF += "--disable-assertions \
46 --enable-debug-runtime \
47 --disable-expensive-checks \
48 --enable-bindings=none \
49 --enable-keep-symbols \
50 --enable-libffi \
51 --enable-optimized \
52 --enable-shared \
53 --enable-targets=host-only"
54EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1"
55FILES_${PN} = "${libdir}/lib*.so \
56 ${libdir}/${LLVM_DIR}/*"
57FILES_${PN}-dbg = "${bindir}/${LLVM_DIR}/.debug \
58 ${libdir}/${LLVM_DIR}/.debug \
59 ${libdir}/.debug \
60 /usr/src/debug"
61FILES_${PN}-dev = "${bindir}/${LLVM_DIR} \
62 ${includedir}/${LLVM_DIR} \
63 ${libdir}/${LLVM_DIR}/BugpointPasses.so \
64 ${libdir}/${LLVM_DIR}/LLVMHello.so"
65FILES_${PN}-static-dev = "${libdir}/${LLVM_DIR}/*.a"
66FILES_SOLIBSDEV = ""
67INSANE_SKIP_${PN} = "dev-so"
68
69do_configure_prepend() {
70 # Remove RPATHs
71 sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules
72
73 # Drop "svn" suffix from version string
74 sed -i 's/3\.2svn/3.2/g' configure
75
76 # Fix paths in llvm-config
77 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" tools/llvm-config/llvm-config.cpp
78 sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" tools/llvm-config/llvm-config.cpp
79
80 # Fails to build unless using separate directory from source
81 mkdir -p ${LLVM_BUILD_DIR}
82 cd ${LLVM_BUILD_DIR}
83}
84
85do_compile() {
86 cd ${LLVM_BUILD_DIR}
87 oe_runmake \
88 AR="${BUILD_AR}" \
89 CC="${BUILD_CC}" \
90 CFLAGS="${BUILD_CFLAGS}" \
91 CXX="${BUILD_CXX}" \
92 CXXFLAGS="${BUILD_CXXFLAGS}" \
93 CPP="${BUILD_CPP}" \
94 CPPFLAGS="${BUILD_CPPFLAGS}" \
95 NM="${BUILD_NM}" \
96 RANLIB="${BUILD_RANLIB}" \
97 PATH="${STAGING_BINDIR_NATIVE}:$PATH" \
98 cross-compile-build-tools
99 oe_runmake
100}
101
102do_install() {
103 cd ${LLVM_BUILD_DIR}
104 oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install
105
106 mv ${LLVM_INSTALL_DIR}${bindir}/${HOST_SYS}-llvm-config-host ${LLVM_INSTALL_DIR}/llvm-config-host
107
108 install -d ${D}${bindir}/${LLVM_DIR}
109 mv ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/
110
111 install -d ${D}${includedir}/${LLVM_DIR}
112 mv ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/
113
114 install -d ${D}${libdir}/${LLVM_DIR}
115 mv ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/
116 ln -s ${LLVM_DIR}/libLLVM-${PV}.so ${D}${libdir}/libLLVM-${PV}.so
117
118 install -d ${D}${docdir}/${LLVM_DIR}
119 mv ${LLVM_INSTALL_DIR}${prefix}/docs/llvm/* ${D}${docdir}/${LLVM_DIR}
120}
121
122SYSROOT_PREPROCESS_FUNCS += "llvm_sysroot_preprocess"
123
124llvm_sysroot_preprocess() {
125 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
126 mv ${LLVM_INSTALL_DIR}/llvm-config-host ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV}
127}
diff --git a/recipes/mesa/mesa_9.1.6.bbappend b/recipes/mesa/mesa_9.1.6.bbappend
new file mode 100644
index 0000000..6c11709
--- /dev/null
+++ b/recipes/mesa/mesa_9.1.6.bbappend
@@ -0,0 +1,6 @@
1EGL_PLATFORMS = "fbdev"
2PACKAGECONFIG = "egl gles dri gallium gallium-llvm gallium-egl"
3GALLIUMDRIVERS_LLVM = ""
4DRIDRIVERS_remove = "swrast,radeon,r200,nouveau,i965,i915"
5DRIDRIVERS_append += "swrast"
6EXTRA_OECONF += "--with-dri-drivers="""