summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2013-08-07 16:30:26 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2013-08-29 08:59:01 +0300
commitd585732d86d074552706870d348543b5ed295282 (patch)
tree54c16fb423ef623b68a70d909cb58d5d813bd448
parentec2c87083fbeb5bfb284328e35302b24eaf69fee (diff)
downloadmeta-boot2qt-d585732d86d074552706870d348543b5ed295282.tar.gz
Include support for Raspberry Pi
Change-Id: I5987fe316966447240bb3cf52616fd84c4f8eecd Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
-rw-r--r--conf/bblayers.conf.sample1
-rw-r--r--conf/distro/include/raspberrypi.conf4
-rw-r--r--conf/local.conf.sample2
-rw-r--r--recipes/adbd/adbd.bb1
-rw-r--r--recipes/images/b2qt-embedded-image.bb4
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb4
-rw-r--r--recipes/vc-graphics/vc-graphics.bbappend1
7 files changed, 16 insertions, 1 deletions
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index 2ec582e..987a75d 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -11,6 +11,7 @@ BBLAYERS ?= " \
11 ##COREBASE##/meta-fsl-arm \ 11 ##COREBASE##/meta-fsl-arm \
12 ##COREBASE##/meta-fsl-arm-extra \ 12 ##COREBASE##/meta-fsl-arm-extra \
13 ##COREBASE##/meta-ti \ 13 ##COREBASE##/meta-ti \
14 ##COREBASE##/meta-raspberrypi \
14 ##COREBASE##/meta-openembedded/meta-oe \ 15 ##COREBASE##/meta-openembedded/meta-oe \
15 ##COREBASE##/meta-b2qt \ 16 ##COREBASE##/meta-b2qt \
16 " 17 "
diff --git a/conf/distro/include/raspberrypi.conf b/conf/distro/include/raspberrypi.conf
new file mode 100644
index 0000000..5045c13
--- /dev/null
+++ b/conf/distro/include/raspberrypi.conf
@@ -0,0 +1,4 @@
1IMAGE_FSTYPES = "tar.gz ext3 rpi-sdimg"
2
3PREFERRED_PROVIDER_virtual/libgles1 = "vc-graphics"
4PREFERRED_PROVIDER_virtual/libgl = "vc-graphics"
diff --git a/conf/local.conf.sample b/conf/local.conf.sample
index d2e1a70..00c9a07 100644
--- a/conf/local.conf.sample
+++ b/conf/local.conf.sample
@@ -62,7 +62,7 @@ MACHINE_HOSTNAME ?= "b2qt-linux-${MACHINE}"
62# 62#
63# The default is a downloads directory under TOPDIR which is the build directory. 63# The default is a downloads directory under TOPDIR which is the build directory.
64# 64#
65#DL_DIR ?= "${TOPDIR}/downloads" 65DL_DIR ?= "${TOPDIR}/../downloads"
66 66
67PREMIRRORS = "http://qt-rnd.it-local/yocto/" 67PREMIRRORS = "http://qt-rnd.it-local/yocto/"
68 68
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
index 3d3e9d6..88a3cfb 100644
--- a/recipes/adbd/adbd.bb
+++ b/recipes/adbd/adbd.bb
@@ -22,6 +22,7 @@ FILES_${PN} += "${bindir}/adbd"
22 22
23PRODUCTID_beagleboard = "0x9018" 23PRODUCTID_beagleboard = "0x9018"
24PRODUCTID_mx6 = "0x0d02" 24PRODUCTID_mx6 = "0x0d02"
25PRODUCTID_raspberrypi = "0xabcd"
25 26
26do_configure() { 27do_configure() {
27 if [ -n "${PRODUCTID}" ]; then 28 if [ -n "${PRODUCTID}" ]; then
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb
index de86a34..515898d 100644
--- a/recipes/images/b2qt-embedded-image.bb
+++ b/recipes/images/b2qt-embedded-image.bb
@@ -16,6 +16,10 @@ EXTRA_IMAGEDEPENDS_mx6 += "u-boot-script-boundary"
16 16
17MACHINE_EXTRA_INSTALL = "" 17MACHINE_EXTRA_INSTALL = ""
18 18
19MACHINE_EXTRA_INSTALL_raspberrypi += "\
20 vc-graphics \
21 "
22
19MACHINE_EXTRA_INSTALL_mx5 += "\ 23MACHINE_EXTRA_INSTALL_mx5 += "\
20 amd-gpu-x11-bin-mx51 \ 24 amd-gpu-x11-bin-mx51 \
21 " 25 "
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
index 474d566..322cc7d 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
@@ -7,6 +7,10 @@ PACKAGES = "${PN}"
7 7
8MACHINE_EXTRA_INSTALL = "" 8MACHINE_EXTRA_INSTALL = ""
9 9
10MACHINE_EXTRA_INSTALL_raspberrypi = " \
11 vc-graphics-dev \
12 "
13
10MACHINE_EXTRA_INSTALL_mx6 = " \ 14MACHINE_EXTRA_INSTALL_mx6 = " \
11 libgal-mx6 \ 15 libgal-mx6 \
12 libegl-mx6 \ 16 libegl-mx6 \
diff --git a/recipes/vc-graphics/vc-graphics.bbappend b/recipes/vc-graphics/vc-graphics.bbappend
new file mode 100644
index 0000000..c76f5c4
--- /dev/null
+++ b/recipes/vc-graphics/vc-graphics.bbappend
@@ -0,0 +1 @@
PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl"