summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2013-04-28 19:48:42 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2013-04-30 08:49:59 +0300
commitacd43e3affdbc21a80c8b73c9a2ca7775d1d277a (patch)
tree543308862f0e82605144ebe1cd606e19d6c6355f
parent59937b8ea07e92ff37d97175cc0943915caadfae (diff)
downloadmeta-boot2qt-acd43e3affdbc21a80c8b73c9a2ca7775d1d277a.tar.gz
basefiles: modified bases files
Include modified /etc/profile file which disables cursor blinking on VT (which shows through Qt applications) Writes configured hostname to /etc/hostname for DHCP registration Change-Id: I68ab5075c9868858061305c8eb5a9dcd67053a9c Reviewed-by: Kalle Viironen <kalle.viironen@digia.com>
-rw-r--r--recipes/base-files/base-files/profile36
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend7
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes/base-files/base-files/profile b/recipes/base-files/base-files/profile
new file mode 100644
index 0000000..7d4c4d7
--- /dev/null
+++ b/recipes/base-files/base-files/profile
@@ -0,0 +1,36 @@
1# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
2# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
3
4PATH="/usr/local/bin:/usr/bin:/bin"
5EDITOR="/bin/vi" # needed for packages like cron
6test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
7
8if [ ! -e /etc/localtime ]; then
9 TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
10 # for an explanation of how to set this to your local timezone.
11 export TZ
12fi
13
14if [ "$HOME" = "ROOTHOME" ]; then
15 PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
16fi
17if [ "$PS1" ]; then
18# works for bash and ash (no other shells known to be in use here)
19 PS1='\u@\h:\w\$ '
20fi
21
22if [ -d /etc/profile.d ]; then
23 for i in /etc/profile.d/* ; do
24 . $i
25 done
26 unset i
27fi
28
29LANG="en_US"
30
31export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM LANG
32
33umask 022
34
35# disable cursor blinking on VT
36echo 0 > /sys/class/graphics/fbcon/cursor_blink
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
new file mode 100644
index 0000000..b7e2d68
--- /dev/null
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3do_install_append() {
4 ln -s /home/root ${D}/root
5 echo ${MACHINE_HOSTNAME} > ${D}${sysconfdir}/hostname
6}
7