summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2013-05-06 09:17:50 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2013-05-06 12:03:08 +0300
commit368afd53358f6dbe4196c437be557161e1f27543 (patch)
tree61ff89a6aa9f5a206b1d263f1c1f0f65eb296594
parent7864ad804e7101608fd55552788474e1f5b97909 (diff)
downloadmeta-boot2qt-368afd53358f6dbe4196c437be557161e1f27543.tar.gz
u-boot-script-boundary: correctly build sabrelite bootscripts
Build bootscript for sabrelite with correct MACHINE_ARCH. Also add dependency to image, so that bootscripts are built for sdcard image. Change-Id: I6cbf8d0b35b9aaa828ef26740384135c8691b11d Reviewed-by: Kalle Viironen <kalle.viironen@digia.com>
-rw-r--r--recipes/images/b2qt-embedded-image.bb2
-rw-r--r--recipes/u-boot/u-boot-script-boundary_git.bbappend11
2 files changed, 6 insertions, 7 deletions
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb
index cf92174..dc88e81 100644
--- a/recipes/images/b2qt-embedded-image.bb
+++ b/recipes/images/b2qt-embedded-image.bb
@@ -13,6 +13,8 @@ IMAGE_FEATURES += "\
13 13
14inherit core-image 14inherit core-image
15 15
16EXTRA_IMAGEDEPENDS_mx6 += "u-boot-script-boundary"
17
16MACHINE_EXTRA_INSTALL = "" 18MACHINE_EXTRA_INSTALL = ""
17 19
18MACHINE_EXTRA_INSTALL_mx6 += "\ 20MACHINE_EXTRA_INSTALL_mx6 += "\
diff --git a/recipes/u-boot/u-boot-script-boundary_git.bbappend b/recipes/u-boot/u-boot-script-boundary_git.bbappend
index 2f02fb6..8db57e0 100644
--- a/recipes/u-boot/u-boot-script-boundary_git.bbappend
+++ b/recipes/u-boot/u-boot-script-boundary_git.bbappend
@@ -1,9 +1,6 @@
1MACHINE = "nitrogen6x"
2 1
3do_deploy_append () { 2do_mkimage_prepend () {
4 cd ${DEPLOYDIR} 3 if [ ! -e board/boundary/${MACHINE} ]; then
5 rm -f 6x_bootscript 6x_upgrade 4 cp -r board/boundary/nitrogen6x board/boundary/${MACHINE}
6 ln -sf 6x_bootscript-${MACHINE}-${PV}-${PR} 6x_bootscript 5 fi
7 ln -sf 6x_upgrade-${MACHINE}-${PV}-${PR} 6x_upgrade
8} 6}
9