summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2013-07-03 12:17:20 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2013-07-08 10:51:00 +0300
commit2aaccd81fafa7b5b234ee07629af4fe15bef20d5 (patch)
treeb12770f12fb09bc5b98c0ffb6ab8c66b17f01c67
parent1cd6345fe5ec75a9517ecef6acb008ab3b716214 (diff)
downloadmeta-boot2qt-2aaccd81fafa7b5b234ee07629af4fe15bef20d5.tar.gz
llvm: recipes for llvm 3.2
Pulled from meta-oe/master Change-Id: I3fe51eca1b64263a6f90c9bb96059cc3307880c5 Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
-rw-r--r--recipes/llvm/llvm-common.bb22
-rw-r--r--recipes/llvm/llvm-common/llvm-config10
-rw-r--r--recipes/llvm/llvm.inc226
-rw-r--r--recipes/llvm/llvm3.2/arm_fenv_uclibc.patch14
-rw-r--r--recipes/llvm/llvm3.2_3.2.bb105
5 files changed, 377 insertions, 0 deletions
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
new file mode 100644
index 0000000..192919e
--- /dev/null
+++ b/recipes/llvm/llvm-common.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Helper script for OE's llvm support"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
5"
6
7SRC_URI = "file://llvm-config"
8
9ALLOW_EMPTY_${PN} = "1"
10SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_common_sysroot_preprocess"
11
12llvm_common_sysroot_preprocess() {
13 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
14 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
15}
16
17do_install_virtclass-native() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
20}
21
22BBCLASSEXTEND = "native"
diff --git a/recipes/llvm/llvm-common/llvm-config b/recipes/llvm/llvm-common/llvm-config
new file mode 100644
index 0000000..a9a416d
--- /dev/null
+++ b/recipes/llvm/llvm-common/llvm-config
@@ -0,0 +1,10 @@
1#!/bin/sh
2# Wrapper script for real llvm-config. Simply calls
3
4if [ $WANT_LLVM_RELEASE ]; then
5 exec `dirname $0`/${TARGET_PREFIX}llvm-config$WANT_LLVM_RELEASE ${@}
6else
7 echo "The variable WANT_LLVM_RELEASE is not defined and exported"
8 echo "by your build recipe. Go figure."
9 exit 1
10fi
diff --git a/recipes/llvm/llvm.inc b/recipes/llvm/llvm.inc
new file mode 100644
index 0000000..fcd2666
--- /dev/null
+++ b/recipes/llvm/llvm.inc
@@ -0,0 +1,226 @@
1# LLVM does not provide ABI stability between different versions. For this
2# reason OE makes it possible to build and install different llvm versions
3# at the same time.
4#
5# This is true for the normal recipes as well as the native ones.
6#
7# All regular installation directories are prefixed with 'llvm${LLVM_RELEASE}'
8# e.g. "${STAGING_BINDIR}/llvm2.5" or "${STAGING_INCDIR}/llvm2.5"
9#
10# For your program or library that makes use of llvm you do should not need to
11# modify anything as long as it uses the results of various llvm-config
12# invocations. If you need customizations something is wrong and it needs to be
13# fixed (report bug).
14#
15# However the *recipe* for your program/library *must* declare
16# export WANT_LLVM_RELEASE = "<valid version number>"
17# The version number is picked up by a generic wrapper script which just calls
18# the variant of the specified version.
19
20DESCRIPTION = "The Low Level Virtual Machine"
21HOMEPAGE = "http://llvm.org"
22# 3-clause BSD-like
23LICENSE = "NCSA"
24LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0ac5f799a2d89477c75b0a378b221855"
25
26DEPENDS = "llvm${LLVM_RELEASE}-native llvm-common"
27DEPENDS_virtclass-native = "llvm-common-native cmake-native"
28
29INC_PR = "r2"
30
31SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.tgz"
32
33S = "${WORKDIR}/llvm-${PV}"
34
35inherit cmake perlnative pythonnative
36
37# Defines the LLVM supported arches. By now we always build either for ${BUILD}
38# (native) or ${TARGET}. In the future it may make sense to enable all backends
39# for the non-native build. The decision which backends are used is made by
40# the 3rd party program or library that uses llvm anyway.
41LLVM_ARCH = "${@get_llvm_arch(d)}"
42
43# This is used for generating the install directory for the llvm libraries,
44# binaries and headers. It makes side by side installation of those possible.
45LLVM_RELEASE = "${PV}"
46
47# llvm *must* be built out of tree
48OECMAKE_SOURCEPATH = ".."
49OECMAKE_BUILDPATH = "build"
50EXTRA_OECMAKE = "\
51 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm${LLVM_RELEASE}/tblgen \
52 -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
53 -DCMAKE_LINKER:FILEPATH=${LD} \
54 -DCMAKE_AR:FILEPATH=${AR} \
55 -DCMAKE_OBJCOPY:FILEPATH=${OBJCOPY} \
56 -DCMAKE_OBJDUMP:FILEPATH=${OBJDUMP} \
57 -DCMAKE_RANLIB:FILEPATH=${RANLIB} \
58 -DCMAKE_STRIP:FILEPATH=${STRIP} \
59 -DNM_PATH:FILEPATH=${NM} \
60 -DLLVM_ENABLE_PIC:BOOL=ON \
61 -DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
62 -DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
63 -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
64 -DBUILD_SHARED_LIBS:BOOL=ON \
65 -DCMAKE_SKIP_BUILD_RPATH:BOOL=ON \
66"
67# We need to reset this to avoid breakage as we build out of tree
68TOOLCHAIN_OPTIONS = ""
69
70PACKAGES_DYNAMIC = "llvm-*"
71
72# the difference to the non-native build is that we do not need
73# to declare the location of the tblgen executable.
74EXTRA_OECMAKE_virtclass-native = "\
75 -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
76 -DCMAKE_LINKER:FILEPATH=${LD} \
77 -DCMAKE_AR:FILEPATH=${AR} \
78 -DCMAKE_OBJCOPY:FILEPATH=${OBJCOPY} \
79 -DCMAKE_OBJDUMP:FILEPATH=${OBJDUMP} \
80 -DCMAKE_RANLIB:FILEPATH=${RANLIB} \
81 -DCMAKE_STRIP:FILEPATH=${STRIP} \
82 -DNM_PATH:FILEPATH=${NM} \
83"
84
85PACKAGES_virtclass-native = ""
86
87PACKAGES_DYNAMIC_virtclass-native = ""
88
89python populate_packages_prepend () {
90 libllvm_libdir = bb.data.expand('${libdir}/llvm${LLVM_RELEASE}', d)
91 do_split_packages(d, libllvm_libdir, '^lib(.*)\.so$', 'libllvm-%s', 'Split package for %s', allow_dirs=True)
92}
93
94FILES_${PN} = ""
95ALLOW_EMPTY_${PN} = "1"
96
97FILES_${PN}-dbg += "${libdir}/llvm${LLVM_RELEASE}/.debug ${bindir}/llvm${LLVM_RELEASE}/.debug"
98
99FILES_${PN}-dev = " \
100 ${includedir} \
101 ${bindir}/* \
102 ${libdir}/llvm${LLVM_RELEASE}/LLVMHello.so \
103 ${libdir}/llvm${LLVM_RELEASE}/BugpointPasses.so \
104 ${libdir}/llvm${LLVM_RELEASE}/*.a \
105"
106
107base_do_compile_prepend() {
108 # Avoid *** No rule to make target `native/bin/tblgen', needed by `include/llvm/Intrinsics.gen.tmp'
109 oe_runmake tblgen
110}
111
112do_install() {
113 # Install into a private directory to be able to reorganize the files.
114
115 cd ${OECMAKE_BUILDPATH}
116
117 oe_runmake DESTDIR=${WORKDIR}/llvm-install install
118
119 # Create our custom target directories
120 install -d ${D}${bindir}/llvm${LLVM_RELEASE}
121 install -d ${D}${includedir}/llvm${LLVM_RELEASE}
122 install -d ${D}${libdir}/llvm${LLVM_RELEASE}
123
124 # Move headers into their own directory
125 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm \
126 ${D}${includedir}/llvm${LLVM_RELEASE}/
127 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm-c \
128 ${D}${includedir}/llvm${LLVM_RELEASE}/
129
130 find ${WORKDIR}/llvm-install/${prefix}/lib -name "*" -maxdepth 1 -exec \
131 install {} ${D}${libdir}/llvm${LLVM_RELEASE} \;
132
133 # I dont know another way out. Binaries are installed into a special subdir
134 find ${WORKDIR}/llvm-install/${prefix}/bin -name "*" -maxdepth 1 -exec \
135 install {} ${D}${bindir}/llvm${LLVM_RELEASE} \;
136
137 # LLVM does not install this by default.
138 install bin/tblgen ${D}${bindir}/llvm${LLVM_RELEASE}
139
140 # we install it here unmodified for native and none native and overwrite it
141 # later for native case
142 install -d ${D}${bindir}
143 install -m 0755 bin/llvm-config ${D}${bindir}
144}
145
146SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_sysroot_preprocess"
147
148llvm_sysroot_preprocess() {
149 cd ${OECMAKE_BUILDPATH}
150
151 # Fix the paths in the config script to make it find the binaries and
152 # library files. Doing so allows 3rd party configure scripts working
153 # unmodified.
154 sed -e's!my.*ABS_RUN_DIR =.*!my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";!' \
155 -e's!my.*INCLUDEDIR =.*!my $INCLUDEDIR = "${STAGING_INCDIR}/llvm${LLVM_RELEASE}";!' \
156 -e's!my.*LIBDIR.*!my $LIBDIR = "${STAGING_LIBDIR}/llvm${LLVM_RELEASE}";!' \
157 -e's!my.*BINDIR.*!my $BINDIR = "${STAGING_BINDIR}/llvm${LLVM_RELEASE}";!' \
158 bin/llvm-config > bin/llvm-config${LLVM_RELEASE}
159
160 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
161 install -m 0755 bin/llvm-config${LLVM_RELEASE} ${SYSROOT_DESTDIR}${bindir_crossscripts}
162}
163
164do_install_virtclass-native() {
165 # Install into a private directory to be able to reorganize the files.
166
167 cd ${OECMAKE_BUILDPATH}
168
169 oe_runmake DESTDIR=${WORKDIR}/llvm-install install
170
171 # Create our custom target directories
172 install -d ${D}${bindir}/llvm${LLVM_RELEASE}
173 install -d ${D}${includedir}/llvm${LLVM_RELEASE}
174 install -d ${D}${libdir}/llvm${LLVM_RELEASE}
175
176 # Move headers into their own directory
177 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm \
178 ${D}${includedir}/llvm${LLVM_RELEASE}/
179 cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm-c \
180 ${D}${includedir}/llvm${LLVM_RELEASE}/
181
182 find ${WORKDIR}/llvm-install/${prefix}/lib -name "*" -maxdepth 1 -exec \
183 install {} ${D}${libdir}/llvm${LLVM_RELEASE} \;
184
185 # I dont know another way out. Binaries are installed into a special subdir
186 find ${WORKDIR}/llvm-install/${prefix}/bin -name "*" -maxdepth 1 -exec \
187 install {} ${D}${bindir}/llvm${LLVM_RELEASE} \;
188
189 # LLVM does not install this by default.
190 install bin/tblgen ${D}${bindir}/llvm${LLVM_RELEASE}
191
192 # Fix the paths in the config script to make it find the binaries and
193 # library files. Doing so allows 3rd party configure scripts working
194 # unmodified.
195 sed -e's!my.*ABS_RUN_DIR =.*!my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";!' \
196 -e's!my.*INCLUDEDIR =.*!my $INCLUDEDIR = "${STAGING_INCDIR}/llvm${LLVM_RELEASE}";!' \
197 -e's!my.*LIBDIR.*!my $LIBDIR = "${STAGING_LIBDIR}/llvm${LLVM_RELEASE}";!' \
198 -e's!my.*BINDIR.*!my $BINDIR = "${STAGING_BINDIR}/llvm${LLVM_RELEASE}";!' \
199 bin/llvm-config > bin/llvm-config${LLVM_RELEASE}
200
201 install -d ${D}${bindir}
202 install -m 0755 bin/llvm-config${LLVM_RELEASE} ${D}${bindir}
203}
204
205
206# Retrieve the target in a way that is compatible to the arch
207# value in llvm (>= 2.5)
208def get_llvm_arch(d):
209 import bb;
210
211 arch = bb.data.getVar('TARGET_ARCH', d, 1)
212 if arch == "x86_64" or arch == "i486" or arch == "i586" or arch == "i686":
213 arch = "X86"
214 elif arch == "arm":
215 arch = "ARM"
216 elif arch == "mipsel" or arch == "mips":
217 arch = "mips"
218 elif arch == "powerpc" or arch == "powerpc64":
219 arch = "PowerPC"
220 else:
221 bb.warn("%s does not support %s yet" % (bb.data.getVar('PN', d, 1), arch) );
222
223 return arch
224
225BBCLASSEXTEND = "native"
226
diff --git a/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch b/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch
new file mode 100644
index 0000000..c3ae494
--- /dev/null
+++ b/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch
@@ -0,0 +1,14 @@
1Index: llvm-2.9/include/llvm/Support/FEnv.h
2===================================================================
3--- llvm-2.9.orig/include/llvm/Support/FEnv.h 2010-11-29 20:44:50.000000000 +0100
4+++ llvm-2.9/include/llvm/Support/FEnv.h 2011-11-18 18:42:22.580161297 +0100
5@@ -17,6 +17,9 @@
6
7 #include "llvm/Config/config.h"
8 #include <cerrno>
9+
10+#undef HAVE_FENV_H
11+
12 #ifdef HAVE_FENV_H
13 #include <fenv.h>
14 #endif
diff --git a/recipes/llvm/llvm3.2_3.2.bb b/recipes/llvm/llvm3.2_3.2.bb
new file mode 100644
index 0000000..71a53c1
--- /dev/null
+++ b/recipes/llvm/llvm3.2_3.2.bb
@@ -0,0 +1,105 @@
1DESCRIPTION = "The Low Level Virtual Machine"
2HOMEPAGE = "http://llvm.org"
3# 3-clause BSD-like
4LICENSE = "NCSA"
5LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=60fdd7739841f04a2ce2171a726be8f3"
6
7DEPENDS = "libffi libxml2-native llvm-common"
8
9SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz"
10SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch "
11
12SRC_URI[md5sum] = "71610289bbc819e3e15fdd562809a2d7"
13SRC_URI[sha256sum] = "125090c4d26740f1d5e9838477c931ed7d9ad70d599ba265f46f3a42cb066343"
14
15S = "${WORKDIR}/llvm-${PV}.src"
16
17inherit autotools perlnative pythonnative
18
19LLVM_BUILD_DIR = "${WORKDIR}/llvm-${PV}.build"
20LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
21LLVM_DIR = "llvm${PV}"
22
23EXTRA_OECONF += "--disable-assertions \
24 --enable-debug-runtime \
25 --disable-expensive-checks \
26 --enable-bindings=none \
27 --enable-keep-symbols \
28 --enable-libffi \
29 --enable-optimized \
30 --enable-shared \
31 --enable-targets=host-only"
32EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1"
33FILES_${PN} = "${libdir}/lib*.so \
34 ${libdir}/${LLVM_DIR}/*"
35FILES_${PN}-dbg = "${bindir}/${LLVM_DIR}/.debug \
36 ${libdir}/${LLVM_DIR}/.debug \
37 ${libdir}/.debug \
38 /usr/src/debug"
39FILES_${PN}-dev = "${bindir}/${LLVM_DIR} \
40 ${includedir}/${LLVM_DIR} \
41 ${libdir}/${LLVM_DIR}/BugpointPasses.so \
42 ${libdir}/${LLVM_DIR}/LLVMHello.so"
43FILES_${PN}-static-dev = "${libdir}/${LLVM_DIR}/*.a"
44FILES_SOLIBSDEV = ""
45INSANE_SKIP_${PN} = "dev-so"
46
47do_configure_prepend() {
48 # Remove RPATHs
49 sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules
50
51 # Drop "svn" suffix from version string
52 sed -i 's/3\.2svn/3.2/g' configure
53
54 # Fix paths in llvm-config
55 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" tools/llvm-config/llvm-config.cpp
56 sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" tools/llvm-config/llvm-config.cpp
57
58 # Fails to build unless using separate directory from source
59 mkdir -p ${LLVM_BUILD_DIR}
60 cd ${LLVM_BUILD_DIR}
61}
62
63do_compile() {
64 cd ${LLVM_BUILD_DIR}
65 oe_runmake \
66 AR="${BUILD_AR}" \
67 CC="${BUILD_CC}" \
68 CFLAGS="${BUILD_CFLAGS}" \
69 CXX="${BUILD_CXX}" \
70 CXXFLAGS="${BUILD_CXXFLAGS}" \
71 CPP="${BUILD_CPP}" \
72 CPPFLAGS="${BUILD_CPPFLAGS}" \
73 NM="${BUILD_NM}" \
74 RANLIB="${BUILD_RANLIB}" \
75 PATH="${STAGING_BINDIR_NATIVE}:$PATH" \
76 cross-compile-build-tools
77 oe_runmake
78}
79
80do_install() {
81 cd ${LLVM_BUILD_DIR}
82 oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install
83
84 mv ${LLVM_INSTALL_DIR}${bindir}/${HOST_SYS}-llvm-config-host ${LLVM_INSTALL_DIR}/llvm-config-host
85
86 install -d ${D}${bindir}/${LLVM_DIR}
87 mv ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/
88
89 install -d ${D}${includedir}/${LLVM_DIR}
90 mv ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/
91
92 install -d ${D}${libdir}/${LLVM_DIR}
93 mv ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/
94 ln -s ${LLVM_DIR}/libLLVM-${PV}.so ${D}${libdir}/libLLVM-${PV}.so
95
96 install -d ${D}${docdir}/${LLVM_DIR}
97 mv ${LLVM_INSTALL_DIR}${prefix}/docs/llvm/* ${D}${docdir}/${LLVM_DIR}
98}
99
100SYSROOT_PREPROCESS_FUNCS += "llvm_sysroot_preprocess"
101
102llvm_sysroot_preprocess() {
103 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
104 mv ${LLVM_INSTALL_DIR}/llvm-config-host ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV}
105}