summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2013-07-09 16:28:09 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2013-07-23 13:41:00 +0300
commit243f97e9f5262c1ef3bcaeba202b81d8e9403817 (patch)
tree0156044f8b62d142ef87944dfe382b77f7e18474
parent79e70fa7c3d503a7a9fb48c52eaa72ac3ab55c72 (diff)
downloadmeta-boot2qt-243f97e9f5262c1ef3bcaeba202b81d8e9403817.tar.gz
Disable cursor blinking on VT with kernel arguments
Change-Id: I5ff46bba20c574d4d3650de50a1dd696614c02e3 Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
-rw-r--r--recipes/base-files/base-files/profile36
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend3
-rw-r--r--recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-kernel-args.patch (renamed from recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-resolution-and-increase-VRAM-f.patch)47
-rw-r--r--recipes/u-boot/u-boot-beagleboard_2011.09.bbappend2
-rw-r--r--recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch24
-rw-r--r--recipes/u-boot/u-boot-script-boundary_git.bbappend10
6 files changed, 62 insertions, 60 deletions
diff --git a/recipes/base-files/base-files/profile b/recipes/base-files/base-files/profile
deleted file mode 100644
index 7d4c4d7..0000000
--- a/recipes/base-files/base-files/profile
+++ /dev/null
@@ -1,36 +0,0 @@
1# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
2# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
3
4PATH="/usr/local/bin:/usr/bin:/bin"
5EDITOR="/bin/vi" # needed for packages like cron
6test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
7
8if [ ! -e /etc/localtime ]; then
9 TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
10 # for an explanation of how to set this to your local timezone.
11 export TZ
12fi
13
14if [ "$HOME" = "ROOTHOME" ]; then
15 PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
16fi
17if [ "$PS1" ]; then
18# works for bash and ash (no other shells known to be in use here)
19 PS1='\u@\h:\w\$ '
20fi
21
22if [ -d /etc/profile.d ]; then
23 for i in /etc/profile.d/* ; do
24 . $i
25 done
26 unset i
27fi
28
29LANG="en_US"
30
31export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM LANG
32
33umask 022
34
35# disable cursor blinking on VT
36echo 0 > /sys/class/graphics/fbcon/cursor_blink
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
index b7e2d68..81c758c 100644
--- a/recipes/base-files/base-files_3.0.14.bbappend
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -1,7 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3do_install_append() { 1do_install_append() {
4 ln -s /home/root ${D}/root 2 ln -s /home/root ${D}/root
5 echo ${MACHINE_HOSTNAME} > ${D}${sysconfdir}/hostname 3 echo ${MACHINE_HOSTNAME} > ${D}${sysconfdir}/hostname
6} 4}
7
diff --git a/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-resolution-and-increase-VRAM-f.patch b/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-kernel-args.patch
index fbae3f3..1dea7f5 100644
--- a/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-resolution-and-increase-VRAM-f.patch
+++ b/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-kernel-args.patch
@@ -1,14 +1,19 @@
1From 4fe2e7b7b9a83f36b409892e854aed68dbd45a0a Mon Sep 17 00:00:00 2001 1From 9ac6875931f5f9d073ca31cd6e1fb7636afb76bc Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com> 2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Thu, 23 May 2013 14:37:10 +0300 3Date: Thu, 23 May 2013 14:37:10 +0300
4Subject: [PATCH] beagle: change default resolution and increase VRAM for fb0 4Subject: [PATCH] beagle: change default kernel args
5 5
6- default resolution to 800x600
7- increase VRAM for fb0
8- disable console blank
9- disable console cursor blinking
10- use extrabootargs
6--- 11---
7 include/configs/omap3_beagle.h | 8 +++++++- 12 include/configs/omap3_beagle.h | 20 ++++++++++++++++----
8 1 file changed, 7 insertions(+), 1 deletion(-) 13 1 file changed, 16 insertions(+), 4 deletions(-)
9 14
10diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h 15diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
11index 1cc46dc..04862d1 100644 16index 1cc46dc..945e15e 100644
12--- a/include/configs/omap3_beagle.h 17--- a/include/configs/omap3_beagle.h
13+++ b/include/configs/omap3_beagle.h 18+++ b/include/configs/omap3_beagle.h
14@@ -224,7 +224,7 @@ 19@@ -224,7 +224,7 @@
@@ -20,39 +25,53 @@ index 1cc46dc..04862d1 100644
20 "defaultdisplay=dvi\0" \ 25 "defaultdisplay=dvi\0" \
21 "mmcdev=0\0" \ 26 "mmcdev=0\0" \
22 "mmcroot=/dev/mmcblk0p2 ro\0" \ 27 "mmcroot=/dev/mmcblk0p2 ro\0" \
23@@ -240,8 +240,10 @@ 28@@ -240,20 +240,28 @@
24 "buddy2=${buddy2} "\ 29 "buddy2=${buddy2} "\
25 "camera=${camera} "\ 30 "camera=${camera} "\
26 "vram=${vram} " \ 31 "vram=${vram} " \
27+ "omapfb.vram=0:${vram} " \ 32+ "omapfb.vram=0:${vram} " \
28 "omapfb.mode=dvi:${dvimode} " \ 33 "omapfb.mode=dvi:${dvimode} " \
29 "omapdss.def_disp=${defaultdisplay} " \ 34 "omapdss.def_disp=${defaultdisplay} " \
30+ "consoleblank=0 " \
31 "root=${mmcroot} " \ 35 "root=${mmcroot} " \
32 "rootfstype=${mmcrootfstype}\0" \ 36- "rootfstype=${mmcrootfstype}\0" \
37+ "rootfstype=${mmcrootfstype} " \
38+ "consoleblank=0 " \
39+ "vt.global_cursor_default=0 " \
40+ "${extrabootargs}\0" \
33 "nandargs=setenv bootargs console=${console} " \ 41 "nandargs=setenv bootargs console=${console} " \
34@@ -250,8 +252,10 @@ 42 "${optargs} " \
43 "mpurate=${mpurate} " \
35 "buddy=${buddy} "\ 44 "buddy=${buddy} "\
36 "camera=${camera} "\ 45 "camera=${camera} "\
37 "vram=${vram} " \ 46 "vram=${vram} " \
38+ "omapfb.vram=0:${vram} " \ 47+ "omapfb.vram=0:${vram} " \
39 "omapfb.mode=dvi:${dvimode} " \ 48 "omapfb.mode=dvi:${dvimode} " \
40 "omapdss.def_disp=${defaultdisplay} " \ 49 "omapdss.def_disp=${defaultdisplay} " \
41+ "consoleblank=0 " \
42 "root=${nandroot} " \ 50 "root=${nandroot} " \
43 "rootfstype=${nandrootfstype}\0" \ 51- "rootfstype=${nandrootfstype}\0" \
52+ "rootfstype=${nandrootfstype} " \
53+ "consoleblank=0 " \
54+ "vt.global_cursor_default=0 " \
55+ "${extrabootargs}\0" \
44 "bootenv=uEnv.txt\0" \ 56 "bootenv=uEnv.txt\0" \
45@@ -263,8 +267,10 @@ 57 "loadbootenv=fatload mmc ${mmcdev} ${loadaddr} ${bootenv}\0" \
58 "importbootenv=echo Importing environment from mmc ...; " \
59@@ -263,10 +271,14 @@
46 "mpurate=${mpurate} " \ 60 "mpurate=${mpurate} " \
47 "buddy=${buddy} "\ 61 "buddy=${buddy} "\
48 "vram=${vram} " \ 62 "vram=${vram} " \
49+ "omapfb.vram=0:${vram} " \ 63+ "omapfb.vram=0:${vram} " \
50 "omapfb.mode=dvi:${dvimode} " \ 64 "omapfb.mode=dvi:${dvimode} " \
51 "omapdss.def_disp=${defaultdisplay} " \ 65 "omapdss.def_disp=${defaultdisplay} " \
52+ "consoleblank=0 " \
53 "root=${ramroot} " \ 66 "root=${ramroot} " \
54 "rootfstype=${ramrootfstype}\0" \ 67- "rootfstype=${ramrootfstype}\0" \
68+ "rootfstype=${ramrootfstype} " \
69+ "consoleblank=0 " \
70+ "vt.global_cursor_default=0 " \
71+ "${extrabootargs}\0" \
55 "loadramdisk=fatload mmc ${mmcdev} ${rdaddr} ramdisk.gz\0" \ 72 "loadramdisk=fatload mmc ${mmcdev} ${rdaddr} ramdisk.gz\0" \
73 "loaduimagefat=fatload mmc ${mmcdev} ${loadaddr} uImage\0" \
74 "loaduimage=ext2load mmc ${mmcdev}:2 ${loadaddr} /boot/uImage\0" \
56-- 75--
571.7.10.4 761.7.10.4
58 77
diff --git a/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend b/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
index 28c08bc..787ac42 100644
--- a/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
+++ b/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2SRC_URI += " \ 2SRC_URI += " \
3 file://0001-beagle-change-default-resolution-and-increase-VRAM-f.patch \ 3 file://0001-beagle-change-default-kernel-args.patch \
4 " 4 "
diff --git a/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch b/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch
new file mode 100644
index 0000000..3c65a20
--- /dev/null
+++ b/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch
@@ -0,0 +1,24 @@
1From 6b894707404a1aeb3072d4b3bfc486ff9ad37ac4 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Tue, 9 Jul 2013 15:31:30 +0300
4Subject: [PATCH] nitrogen6x: disable console cursor blinking
5
6---
7 board/boundary/nitrogen6x/6x_bootscript.txt | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/board/boundary/nitrogen6x/6x_bootscript.txt b/board/boundary/nitrogen6x/6x_bootscript.txt
11index 1d766ca..80b91ea 100644
12--- a/board/boundary/nitrogen6x/6x_bootscript.txt
13+++ b/board/boundary/nitrogen6x/6x_bootscript.txt
14@@ -53,6 +53,6 @@ done
15
16 setenv bootargs $bootargs $fbmem
17
18-setenv bootargs $bootargs console=ttymxc1,115200 vmalloc=400M root=/dev/mmcblk0p2 rootwait consoleblank=0 ;
19+setenv bootargs $bootargs console=ttymxc1,115200 vmalloc=400M root=/dev/mmcblk0p2 rootwait consoleblank=0 vt.global_cursor_default=0 ;
20 ${fs}load mmc ${disk}:1 10800000 uImage && bootm 10800000 ; echo "Error loading kernel image"
21
22--
231.7.10.4
24
diff --git a/recipes/u-boot/u-boot-script-boundary_git.bbappend b/recipes/u-boot/u-boot-script-boundary_git.bbappend
index 8db57e0..c845717 100644
--- a/recipes/u-boot/u-boot-script-boundary_git.bbappend
+++ b/recipes/u-boot/u-boot-script-boundary_git.bbappend
@@ -1,6 +1,4 @@
1 1FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
2do_mkimage_prepend () { 2SRC_URI += " \
3 if [ ! -e board/boundary/${MACHINE} ]; then 3 file://0001-nitrogen6x-disable-console-cursor-blinking.patch \
4 cp -r board/boundary/nitrogen6x board/boundary/${MACHINE} 4 "
5 fi
6}