summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-01-25 09:37:59 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-02-01 06:58:36 +0000
commit12f3a11c1930152c17c70e34dc01c80feca20333 (patch)
treedad2d9ad2dfb5e2f36461872dd612d4fae216c08
parent334546f57a18032f146bab09fe3f097db254b1b2 (diff)
downloadmeta-boot2qt-12f3a11c1930152c17c70e34dc01c80feca20333.tar.gz
nitrogen6x: update u-boot-boundary patches
Update meta-boundary to master branch where thud layer compatibility is set & update patches for yocto thud Task-number: QTBUG-72413 Change-Id: Ie654dbb1d82799e3170e947cf80baf64aa725ab6 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch46
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch8
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch14
-rw-r--r--scripts/manifest.xml2
4 files changed, 39 insertions, 31 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
index 123782e..9378f0a 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
@@ -1,21 +1,21 @@
1From 07234c1c0f991a560010672a619740e385778f90 Mon Sep 17 00:00:00 2001 1From ea15ee300074cb1453dce6a068feec0771a28418 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com> 2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Thu, 11 Feb 2016 10:17:51 +0200 3Date: Thu, 11 Feb 2016 10:17:51 +0200
4Subject: [PATCH] Add support for KOE tx31d200vm0baa display 4Subject: [PATCH] Add support for KOE tx31d200vm0baa display
5 5
6Used for the cluster demo 6Used for the cluster demo
7--- 7---
8 arch/arm/include/asm/imx-common/fbpanel.h | 27 ++++++++++++++++++++ 8 arch/arm/include/asm/mach-imx/fbpanel.h | 27 ++++++++++++++++++++
9 board/boundary/nitrogen6_max/nitrogen6_max.c | 1 + 9 board/boundary/nitrogen6_max/nitrogen6_max.c | 3 ++-
10 board/boundary/nitrogen6sx/nitrogen6sx.c | 1 + 10 board/boundary/nitrogen6sx/nitrogen6sx.c | 3 ++-
11 board/boundary/nitrogen6x/nitrogen6x.c | 1 + 11 board/boundary/nitrogen6x/nitrogen6x.c | 3 ++-
12 4 files changed, 30 insertions(+) 12 4 files changed, 33 insertions(+), 3 deletions(-)
13 13
14diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h 14diff --git a/arch/arm/include/asm/mach-imx/fbpanel.h b/arch/arm/include/asm/mach-imx/fbpanel.h
15index f5465c3c80..643cd86e29 100644 15index 4b924d2ac8..d4ef998faf 100644
16--- a/arch/arm/include/asm/imx-common/fbpanel.h 16--- a/arch/arm/include/asm/mach-imx/fbpanel.h
17+++ b/arch/arm/include/asm/imx-common/fbpanel.h 17+++ b/arch/arm/include/asm/mach-imx/fbpanel.h
18@@ -116,6 +116,33 @@ void fbp_setup_display(const struct display_info_t *displays, int cnt); 18@@ -174,6 +174,33 @@ void fbp_setup_env_cmds(void);
19 .fbtype = FB_##_mode,\ 19 .fbtype = FB_##_mode,\
20 .fbflags = _flags 20 .fbflags = _flags
21 21
@@ -50,38 +50,44 @@ index f5465c3c80..643cd86e29 100644
50 #define VDF_1280_720M_60(_mode, _name, _fmt, _flags, _detect, _bus, _addr) \ 50 #define VDF_1280_720M_60(_mode, _name, _fmt, _flags, _detect, _bus, _addr) \
51 {\ 51 {\
52diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c 52diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c
53index 1c4106e735..51bc0bd8f3 100644 53index 12e3af89d0..3be475efc0 100644
54--- a/board/boundary/nitrogen6_max/nitrogen6_max.c 54--- a/board/boundary/nitrogen6_max/nitrogen6_max.c
55+++ b/board/boundary/nitrogen6_max/nitrogen6_max.c 55+++ b/board/boundary/nitrogen6_max/nitrogen6_max.c
56@@ -497,6 +497,7 @@ int fbp_detect_serializer(struct display_info_t const *di) 56@@ -499,7 +499,8 @@ int fbp_detect_serializer(struct display_info_t const *di)
57 } 57 }
58 58
59 static const struct display_info_t displays[] = { 59 static const struct display_info_t displays[] = {
60- /* hdmi */
60+ IMX_VD_KOE(LVDS, 0, 2), 61+ IMX_VD_KOE(LVDS, 0, 2),
61 /* hdmi */ 62+ /* hdmi */
62 VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50), 63 VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
63 VD_1920_1080M_60(HDMI, NULL, 1, 0x50), 64 VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
65 VD_1024_768M_60(HDMI, NULL, 1, 0x50),
64diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c 66diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c
65index dc05042add..3725d63cf3 100644 67index 5581637424..5ded443c78 100644
66--- a/board/boundary/nitrogen6sx/nitrogen6sx.c 68--- a/board/boundary/nitrogen6sx/nitrogen6sx.c
67+++ b/board/boundary/nitrogen6sx/nitrogen6sx.c 69+++ b/board/boundary/nitrogen6sx/nitrogen6sx.c
68@@ -436,6 +436,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) 70@@ -435,7 +435,8 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
69 } 71 }
70 72
71 static const struct display_info_t displays[] = { 73 static const struct display_info_t displays[] = {
74- /* hdmi/lcd via tfp410 */
72+ IMX_VD_KOE(LVDS, 0, 2), 75+ IMX_VD_KOE(LVDS, 0, 2),
73 /* hdmi/lcd via tfp410 */ 76+ /* hdmi/lcd via tfp410 */
74 VDF_1280_720M_60(LCD, "1280x720M@60", RGB24, 0, fbp_detect_i2c, 2, 0x50), 77 VDF_1280_720M_60(LCD, "1280x720M@60", RGB24, 0, fbp_detect_i2c, 2, 0x50),
75 VDF_1920_1080M_60(LCD, "1920x1080M@60", RGB24, 0, NULL, 2, 0x50), 78 VDF_1920_1080M_60(LCD, "1920x1080M@60", RGB24, 0, NULL, 2, 0x50),
79 VDF_1024_768M_60(LCD, "1024x768M@60", RGB24, 0, NULL, 2, 0x50),
76diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c 80diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c
77index d9f6a829f1..80b102e206 100644 81index 8ee7f641bf..dbf1bd4a99 100644
78--- a/board/boundary/nitrogen6x/nitrogen6x.c 82--- a/board/boundary/nitrogen6x/nitrogen6x.c
79+++ b/board/boundary/nitrogen6x/nitrogen6x.c 83+++ b/board/boundary/nitrogen6x/nitrogen6x.c
80@@ -359,6 +359,7 @@ void board_pre_enable(const struct display_info_t *di) 84@@ -362,7 +362,8 @@ void board_pre_enable(const struct display_info_t *di)
81 } 85 }
82 86
83 static const struct display_info_t displays[] = { 87 static const struct display_info_t displays[] = {
88- /* hdmi */
84+ IMX_VD_KOE(LVDS, 0, 2), 89+ IMX_VD_KOE(LVDS, 0, 2),
85 /* hdmi */ 90+ /* hdmi */
86 VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50), 91 VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
87 VD_1920_1080M_60(HDMI, NULL, 1, 0x50), 92 VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
93 VD_1024_768M_60(HDMI, NULL, 1, 0x50),
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
index b0791e9..d730e60 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
@@ -1,4 +1,4 @@
1From fa2e83db63fe5abdfa00d205301d12e1a271a291 Mon Sep 17 00:00:00 2001 1From e21337ad1663e6fd6da4a5175ad72e629c62bab5 Mon Sep 17 00:00:00 2001
2From: Mikko Gronoff <mikko.gronoff@qt.io> 2From: Mikko Gronoff <mikko.gronoff@qt.io>
3Date: Sun, 23 Apr 2017 21:47:01 +0300 3Date: Sun, 23 Apr 2017 21:47:01 +0300
4Subject: [PATCH] set CMA reserved size to 384MB 4Subject: [PATCH] set CMA reserved size to 384MB
@@ -10,14 +10,14 @@ video decoding cannot work for high resolution videos.
10 1 file changed, 1 insertion(+) 10 1 file changed, 1 insertion(+)
11 11
12diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h 12diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h
13index bd4e54cb67..48114d5739 100644 13index 62708b839b..eb3b30b2ce 100644
14--- a/include/configs/nitrogen6x.h 14--- a/include/configs/nitrogen6x.h
15+++ b/include/configs/nitrogen6x.h 15+++ b/include/configs/nitrogen6x.h
16@@ -33,6 +33,7 @@ 16@@ -26,6 +26,7 @@
17 #define CONFIG_USB_MAX_CONTROLLER_COUNT 2 17 #define CONFIG_USB_MAX_CONTROLLER_COUNT 2
18 18
19 #define BD_I2C_MASK 7 19 #define BD_I2C_MASK 7
20+#define BD_CMA "384M" 20+#define BD_CMA "384M"
21 21
22 #if defined(CONFIG_SABRELITE) 22 #if defined(CONFIG_SABRELITE)
23 #define CONFIG_ENV_IS_IN_MMC 23 #include "boundary.h"
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
index c5fa923..49af5e5 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
@@ -1,4 +1,4 @@
1From 22c5a278b98cf6ea4e4a402bca19d1354ab3c431 Mon Sep 17 00:00:00 2001 1From baed831959ba41b8d1cebfb5d960ddfa847ae915 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io> 2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Tue, 25 Sep 2018 16:05:17 +0300 3Date: Tue, 25 Sep 2018 16:05:17 +0300
4Subject: [PATCH] Disable build for tools and use mkimage from sysroot 4Subject: [PATCH] Disable build for tools and use mkimage from sysroot
@@ -11,10 +11,10 @@ fails when trying to compile with host gcc: unable to execute
11 2 files changed, 2 insertions(+), 2 deletions(-) 11 2 files changed, 2 insertions(+), 2 deletions(-)
12 12
13diff --git a/Makefile b/Makefile 13diff --git a/Makefile b/Makefile
14index 119ad49eec..022690e26e 100644 14index 7d5f801eea..d5d44c5def 100644
15--- a/Makefile 15--- a/Makefile
16+++ b/Makefile 16+++ b/Makefile
17@@ -698,7 +698,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/) 17@@ -730,7 +730,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/)
18 18
19 libs-y := $(sort $(libs-y)) 19 libs-y := $(sort $(libs-y))
20 20
@@ -24,13 +24,15 @@ index 119ad49eec..022690e26e 100644
24 u-boot-alldirs := $(sort $(u-boot-dirs) $(patsubst %/,%,$(filter %/, $(libs-)))) 24 u-boot-alldirs := $(sort $(u-boot-dirs) $(patsubst %/,%,$(filter %/, $(libs-))))
25 25
26diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib 26diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
27index 80ddb08474..e86c949f08 100644 27index f8c3fff1d1..f24ea9cc25 100644
28--- a/scripts/Makefile.lib 28--- a/scripts/Makefile.lib
29+++ b/scripts/Makefile.lib 29+++ b/scripts/Makefile.lib
30@@ -493,5 +493,5 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \ 30@@ -508,7 +508,7 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \
31 # --------------------------------------------------------------------------- 31 # ---------------------------------------------------------------------------
32 MKIMAGEOUTPUT ?= /dev/null 32 MKIMAGEOUTPUT ?= /dev/null
33 quiet_cmd_mkimage = MKIMAGE $@ 33 quiet_cmd_mkimage = MKIMAGE $@
34-cmd_mkimage = $(objtree)/tools/mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \ 34-cmd_mkimage = $(objtree)/tools/mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
35+cmd_mkimage = mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \ 35+cmd_mkimage = mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
36 $(if $(KBUILD_VERBOSE:1=), >$(MKIMAGEOUTPUT)) 36 >$(MKIMAGEOUTPUT) $(if $(KBUILD_VERBOSE:0=), && cat $(MKIMAGEOUTPUT))
37
38 # fdtgrep
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 012402d..64f6bcc 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -85,7 +85,7 @@
85 groups="notdefault,external,toradex"/> 85 groups="notdefault,external,toradex"/>
86 <project name="meta-boundary" 86 <project name="meta-boundary"
87 remote="boundary" 87 remote="boundary"
88 revision="412ef0b92df0575808c2292cc4983e118c1a19f8" 88 revision="0533dbf42abee6e07be572eacc3d965772aad7a4"
89 path="sources/meta-boundary" 89 path="sources/meta-boundary"
90 groups="notdefault,external,boundary"/> 90 groups="notdefault,external,boundary"/>
91 <project name="meta-fsl-bsp-release" 91 <project name="meta-fsl-bsp-release"