summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-06-13 10:32:40 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-06-13 10:33:05 +0300
commitba5acea9a6ffa24a216fc2a0f28db5595241745b (patch)
tree276ae7062f56b12f059b105cc37318466dfc3fc0
parentba5a0bfd217b429be7d3cb941b5fe72bbfc11494 (diff)
parent0ee666de9edf75b40215daf0f8609f659439458f (diff)
downloadmeta-boot2qt-ba5acea9a6ffa24a216fc2a0f28db5595241745b.tar.gz
Merge remote-tracking branch 'origin/morty' into pyro
* origin/morty: dracut: remove bbappend BBB: add systemd service for powervr drivers Jetson-TX1: Add ability to mount root via NFS NUC: disable hw cursor for intel nuc adbd: remove component Update update-qt5-modules script handle qtlocation Change-Id: Ied32e11749d81af9ea74714f4d3607d2680bf327
-rw-r--r--conf/distro/include/beagleboard.conf2
-rw-r--r--conf/distro/include/beaglebone.conf2
-rw-r--r--conf/distro/include/nitrogen6x.conf2
-rw-r--r--meta-intel-extras/recipes/qt5/b2qt-appcontroller.bbappend (renamed from recipes/dracut/dracut_git.bbappend)18
-rw-r--r--meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf7
-rw-r--r--meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf3
-rw-r--r--meta-intel-extras/recipes/qt5/qtbase_git.bbappend (renamed from meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend)0
-rw-r--r--meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh44
-rw-r--r--meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend33
-rw-r--r--meta-ti-extras/recipes/libgles/ti-sgx-ddk-um/pvr.service11
-rw-r--r--meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend20
-rw-r--r--recipes-qt/b2qt-addons/qdbd/qdbd.service2
-rw-r--r--recipes/adbd/adbd.bb87
-rw-r--r--recipes/adbd/files/Makefile.adbd34
-rwxr-xr-xrecipes/adbd/files/adb-init40
-rw-r--r--recipes/adbd/files/adbd.patch265
-rw-r--r--recipes/adbd/files/adbd.service12
-rw-r--r--recipes/adbd/files/defaults4
-rw-r--r--recipes/adbd/files/emulator/defaults4
-rw-r--r--recipes/adbd/files/imx53qsb/defaults4
-rw-r--r--recipes/adbd/files/intel-corei7-64/defaults4
-rw-r--r--recipes/adbd/files/nvidia-logan/adb-init46
-rw-r--r--recipes/adbd/files/nvidia-logan/defaults4
-rw-r--r--recipes/adbd/files/raspberrypi/defaults4
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb1
-rwxr-xr-xscripts/update-qt5-modules.sh6
26 files changed, 132 insertions, 527 deletions
diff --git a/conf/distro/include/beagleboard.conf b/conf/distro/include/beagleboard.conf
index fa446d2..d9b92f0 100644
--- a/conf/distro/include/beagleboard.conf
+++ b/conf/distro/include/beagleboard.conf
@@ -32,5 +32,3 @@ include conf/distro/include/ti.inc
32DEPLOY_CONF_NAME = "BeagleBoard" 32DEPLOY_CONF_NAME = "BeagleBoard"
33 33
34DISTRO_FEATURES_remove = "webengine opengl" 34DISTRO_FEATURES_remove = "webengine opengl"
35
36ADB_PRODUCTID = "0x9018"
diff --git a/conf/distro/include/beaglebone.conf b/conf/distro/include/beaglebone.conf
index 6f12d90..099be56 100644
--- a/conf/distro/include/beaglebone.conf
+++ b/conf/distro/include/beaglebone.conf
@@ -33,4 +33,4 @@ DEPLOY_CONF_NAME = "BeagleBone Black"
33 33
34DISTRO_FEATURES_remove = "webengine" 34DISTRO_FEATURES_remove = "webengine"
35 35
36ADB_PRODUCTID = "0xD002" 36BOOT_SPACE = "33792"
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf
index e59faca..389ac03 100644
--- a/conf/distro/include/nitrogen6x.conf
+++ b/conf/distro/include/nitrogen6x.conf
@@ -85,5 +85,3 @@ KERNEL_DEVICETREE += "\
85MACHINE_EXTRA_INSTALL += "\ 85MACHINE_EXTRA_INSTALL += "\
86 bcm4330-nvram-config \ 86 bcm4330-nvram-config \
87 " 87 "
88
89ADB_PRODUCTID = "0x0d02"
diff --git a/recipes/dracut/dracut_git.bbappend b/meta-intel-extras/recipes/qt5/b2qt-appcontroller.bbappend
index 657e30a..708ed85 100644
--- a/recipes/dracut/dracut_git.bbappend
+++ b/meta-intel-extras/recipes/qt5/b2qt-appcontroller.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -27,12 +27,12 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30PV = "044+git${SRCREV}" 30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRCREV = "1bc3e733f96033a508841e97fe08da7a12851782"
32SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git;protocol=http"
33 31
34# Upstream recipe mistakenly depends on systemd, we remove that dependency here. 32SRC_URI += "file://kms.conf"
35RDEPENDS_${PN}_remove = "systemd" 33
36REQUIRED_DISTRO_FEATURES_remove = "systemd" 34FILES_${PN} += "${sysconfdir}/kms.conf"
37# https://bugzilla.yoctoproject.org/show_bug.cgi?id=8522 35
38RDEPENDS_${PN} += "util-linux" 36do_install_append() {
37 install -m 0644 ${WORKDIR}/kms.conf ${D}${sysconfdir}/
38}
diff --git a/meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf
new file mode 100644
index 0000000..ca5f455
--- /dev/null
+++ b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf
@@ -0,0 +1,7 @@
1env=QT_QPA_EGLFS_KMS_CONFIG=/etc/kms.conf
2env=QML2_IMPORT_PATH=/data/user/qt/qmlplugins
3env=QT_IM_MODULE=qtvirtualkeyboard
4env=QT_QPA_EGLFS_FORCE888=0
5env=QT_QUICK_CONTROLS_1_STYLE=Flat
6env=XDG_RUNTIME_DIR=/tmp
7base=linux
diff --git a/meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf
new file mode 100644
index 0000000..d6da06c
--- /dev/null
+++ b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf
@@ -0,0 +1,3 @@
1{
2 "hwcursor": false
3}
diff --git a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-intel-extras/recipes/qt5/qtbase_git.bbappend
index 602782e..602782e 100644
--- a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
+++ b/meta-intel-extras/recipes/qt5/qtbase_git.bbappend
diff --git a/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh
new file mode 100644
index 0000000..3e43b60
--- /dev/null
+++ b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh
@@ -0,0 +1,44 @@
1#!/bin/sh
2PATH=/sbin:/bin:/usr/sbin:/usr/bin
3mount -t proc proc /proc
4mount -t devtmpfs none /dev
5mount -t sysfs sysfs /sys
6
7rootdev=""
8opt="rw"
9wait=""
10nfsroot=""
11nfsopts=""
12for bootarg in `cat /proc/cmdline`; do
13 case "$bootarg" in
14 root=*) rootdev="${bootarg##root=}" ;;
15 nfsroot=*)
16 nfsroot=$(echo ${bootarg##nfsroot=} | cut -d ',' -f 1)
17 nfsopts=$(echo ${bootarg##nfsroot=} | cut -d ',' -f 2-)
18 nfsopts=${nfsopts##${nfsroot}}
19 ;;
20 ro) opt="ro" ;;
21 rootwait) wait="yes" ;;
22 esac
23done
24if [ -n "$wait" -a ! -b "${rootdev}" ]; then
25 echo "Waiting for ${rootdev}..."
26 count=0
27 while [ $count -lt 25 ]; do
28 test -b "${rootdev}" && break
29 sleep 0.1
30 count=`expr $count + 1`
31 done
32fi
33echo "Mounting ${rootdev}..."
34if [ "$rootdev" = "/dev/nfs" ]; then
35 echo "Using NFS to boot..."
36 mount -t nfs -o "${opt},${nfsopts}" "${nfsroot}" /mnt || exec sh
37else
38 mount -t ext4 -o "$opt" "${rootdev}" /mnt || exec sh
39fi
40echo "Switching to rootfs on ${rootdev}..."
41mount --move /sys /mnt/sys
42mount --move /proc /mnt/proc
43mount --move /dev /mnt/dev
44exec switch_root /mnt /sbin/init
diff --git a/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend
new file mode 100644
index 0000000..788524a
--- /dev/null
+++ b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend
@@ -0,0 +1,33 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "\
32 file://init-boot.sh \
33 "
diff --git a/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um/pvr.service b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um/pvr.service
new file mode 100644
index 0000000..dca5ac4
--- /dev/null
+++ b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um/pvr.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=PVR Services
3
4[Service]
5Type=oneshot
6RemainAfterExit=yes
7ExecStart=/usr/bin/rc.pvr start
8ExecStop=/usr/bin/rc.pvr stop
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend
index 6079659..94ef641 100644
--- a/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend
+++ b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend
@@ -28,7 +28,14 @@
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31SRC_URI += "file://99-fb.rules" 31SRC_URI += "\
32 file://99-fb.rules \
33 file://pvr.service \
34 "
35
36inherit systemd
37
38SYSTEMD_SERVICE_${PN} = "pvr.service"
32 39
33# for supporting weston 40# for supporting weston
34PROVIDES += "virtual/mesa" 41PROVIDES += "virtual/mesa"
@@ -36,9 +43,18 @@ PROVIDES += "virtual/mesa"
36do_install_append() { 43do_install_append() {
37 install -d ${D}${base_libdir}/udev/rules.d 44 install -d ${D}${base_libdir}/udev/rules.d
38 install -m 0644 ${WORKDIR}/99-fb.rules ${D}${base_libdir}/udev/rules.d 45 install -m 0644 ${WORKDIR}/99-fb.rules ${D}${base_libdir}/udev/rules.d
46
47 install -d ${D}${systemd_unitdir}/system
48 install -m 0644 ${WORKDIR}/pvr.service ${D}${systemd_unitdir}/system
49
50 install -d ${D}${bindir}
51 install -m 0755 ${D}${sysconfdir}/init.d/rc.pvr ${D}${bindir}
39} 52}
40 53
41FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules" 54FILES_${PN} += "\
55 ${base_libdir}/udev/rules.d/*.rules \
56 ${systemd_unitdir}/system/pvr.service \
57 "
42 58
43RRECOMMENDS_${PN} += "ti-sgx-ddk-km" 59RRECOMMENDS_${PN} += "ti-sgx-ddk-km"
44 60
diff --git a/recipes-qt/b2qt-addons/qdbd/qdbd.service b/recipes-qt/b2qt-addons/qdbd/qdbd.service
index 6c1b8e8..be8e701 100644
--- a/recipes-qt/b2qt-addons/qdbd/qdbd.service
+++ b/recipes-qt/b2qt-addons/qdbd/qdbd.service
@@ -1,8 +1,6 @@
1[Unit] 1[Unit]
2Description=Qt Debug Bridge Daemon 2Description=Qt Debug Bridge Daemon
3After=basic.target 3After=basic.target
4Before=adbd.service
5Conflicts=adbd.service
6 4
7[Service] 5[Service]
8Type=forking 6Type=forking
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
deleted file mode 100644
index 7bada5d..0000000
--- a/recipes/adbd/adbd.bb
+++ /dev/null
@@ -1,87 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Android Debug Bridge Daemon"
31HOMEPAGE = "http://developer.android.com/tools/help/adb.html"
32SECTION = "devel"
33LICENSE = "Apache-2.0"
34LIC_FILES_CHKSUM = "file://adb/NOTICE;md5=2ddb23e63b1f9c3c46aaa4195f819a6d"
35
36PV = "android-5.0.1_r1"
37PR = "r0"
38SRCREV = "${PV}"
39
40RRECOMMENDS_${PN} += "kernel-module-g-ffs"
41DEPENDS = "openssl libcap"
42
43SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https;branch=lollipop-release;name=core \
44 file://adbd.patch \
45 file://Makefile.adbd \
46 file://adb-init \
47 file://defaults \
48 file://adbd.service \
49 "
50
51S = "${WORKDIR}/git"
52
53FILES_${PN} += "${bindir}/adbd"
54
55do_configure() {
56 if [ -n "${ADB_PRODUCTID}" ]; then
57 sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/defaults
58 fi
59}
60
61do_compile() {
62 make -f ${WORKDIR}/Makefile.adbd -C adb
63}
64
65do_install() {
66 install -m 0755 -d ${D}${bindir}/
67 install -m 0755 ${WORKDIR}/git/adb/adbd ${D}${bindir}/
68 install -m 0755 ${WORKDIR}/adb-init ${D}${bindir}/
69
70 install -m 0755 -d ${D}${sysconfdir}/init.d
71 ln -s ${bindir}/adb-init ${D}${sysconfdir}/init.d/
72
73 install -m 0755 -d ${D}${systemd_unitdir}/system
74 install -m 0644 ${WORKDIR}/adbd.service ${D}${systemd_unitdir}/system/
75
76 install -m 0755 -d ${D}${sysconfdir}/default
77 install -m 0644 ${WORKDIR}/defaults ${D}${sysconfdir}/default/adbd
78}
79
80INITSCRIPT_NAME = "adb-init"
81INITSCRIPT_PARAMS = "defaults 96"
82
83SYSTEMD_SERVICE_${PN} = "adbd.service"
84# qdbd is started by default instead of adbd
85SYSTEMD_AUTO_ENABLE = "disable"
86
87inherit update-rc.d systemd
diff --git a/recipes/adbd/files/Makefile.adbd b/recipes/adbd/files/Makefile.adbd
deleted file mode 100644
index 753d2d7..0000000
--- a/recipes/adbd/files/Makefile.adbd
+++ /dev/null
@@ -1,34 +0,0 @@
1LOCAL_SRC_FILES := \
2 adb.c \
3 fdevent.c \
4 transport.c \
5 transport_local.c \
6 transport_usb.c \
7 adb_auth_client.c \
8 sockets.c \
9 services.c \
10 file_sync_service.c \
11 jdwp_service.c \
12 framebuffer_service.c \
13 remount_service.c \
14 usb_linux_client.c
15
16LOCAL_OBJ_FILES=$(LOCAL_SRC_FILES:%.c=%.o)
17
18LIBCUTILS_SRC_FILES := \
19 ../libcutils/socket_inaddr_any_server.c \
20 ../libcutils/socket_local_client.c \
21 ../libcutils/socket_local_server.c \
22 ../libcutils/socket_loopback_client.c \
23 ../libcutils/socket_loopback_server.c
24
25LIBCUTILS_OBJ_FILES=$(LIBCUTILS_SRC_FILES:%.c=%.o)
26
27adbd: $(LOCAL_OBJ_FILES) $(LIBCUTILS_OBJ_FILES)
28 $(CC) $(LDFLAGS) $^ -o $@ -lcrypto -Wl,--as-needed -ldl -lpthread -lresolv
29
30../libcutils/%.o: ../libcutils/%.c
31 $(CC) -O2 -g -DADB_HOST=1 -Wall -Wno-unused-parameter -D_XOPEN_SOURCE -D_GNU_SOURCE -c $^ -o $@ -I../include/ -DHAVE_TERMIO_H -DHAVE_FORKEXEC
32
33%.o: %.c
34 $(CC) -O2 -g -DADB_QEMU=0 -DADB_HOST=0 -Wall -Wno-unused-parameter -D_XOPEN_SOURCE -D_GNU_SOURCE -c $^ -o $@ -isystem . -I../include/ -DHAVE_TERMIO_H -DHAVE_FORKEXEC
diff --git a/recipes/adbd/files/adb-init b/recipes/adbd/files/adb-init
deleted file mode 100755
index 5f47fd0..0000000
--- a/recipes/adbd/files/adb-init
+++ /dev/null
@@ -1,40 +0,0 @@
1#!/bin/sh
2
3DAEMON=/usr/bin/adbd
4
5. /etc/default/adbd
6
7if [ -e /var/run/dbus/session_bus_address ]; then
8 . /var/run/dbus/session_bus_address
9fi
10
11case "$1" in
12start)
13 if [ "$USE_ETHERNET" = "no" ]; then
14 modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL:0:32}
15 mkdir -p /dev/usb-ffs
16 chmod 770 /dev/usb-ffs
17 mkdir -p /dev/usb-ffs/adb
18 chmod 770 /dev/usb-ffs/adb
19 mount -t functionfs adb /dev/usb-ffs/adb -o uid=0,gid=0
20 fi
21 start-stop-daemon --start --quiet --exec $DAEMON &
22 ;;
23stop)
24 start-stop-daemon --stop --quiet --exec $DAEMON
25 if [ "$USE_ETHERNET" = "no" ]; then
26 sleep 1
27 umount /dev/usb-ffs/adb
28 rmmod g_ffs
29 fi
30 ;;
31restart)
32 start-stop-daemon --stop --quiet --exec $DAEMON
33 sleep 1
34 start-stop-daemon --start --quiet --exec $DAEMON &
35 ;;
36*)
37 echo "Usage: $0 {start|stop|restart}"
38 exit 1
39esac
40exit 0
diff --git a/recipes/adbd/files/adbd.patch b/recipes/adbd/files/adbd.patch
deleted file mode 100644
index 479a049..0000000
--- a/recipes/adbd/files/adbd.patch
+++ /dev/null
@@ -1,265 +0,0 @@
1diff --git a/adb/adb.c b/adb/adb.c
2index 10a1e0d..99fca49 100644
3--- a/adb/adb.c
4+++ b/adb/adb.c
5@@ -35,12 +35,10 @@
6
7 #if !ADB_HOST
8 #include <cutils/properties.h>
9-#include <private/android_filesystem_config.h>
10 #include <sys/capability.h>
11 #include <sys/mount.h>
12 #include <sys/prctl.h>
13 #include <getopt.h>
14-#include <selinux/selinux.h>
15 #else
16 #include "usb_vendors.h"
17 #endif
18@@ -147,7 +145,7 @@ void adb_trace_init(void)
19 }
20 }
21
22-#if !ADB_HOST
23+#if !ADB_HOST && ADB_QEMU
24 /*
25 * Implements ADB tracing inside the emulator.
26 */
27@@ -288,6 +286,22 @@ static void send_close(unsigned local, unsigned remote, atransport *t)
28 send_packet(p, t);
29 }
30
31+int property_set(const char *key, const char *value)
32+{
33+ return 0;
34+}
35+
36+int property_get(const char *key, char *value, const char *fallback)
37+{
38+ if (fallback) {
39+ strncpy(value, fallback, PROPERTY_VALUE_MAX-1);
40+ return strlen(fallback);
41+ } else {
42+ value[0] = 0;
43+ return 0;
44+ }
45+}
46+
47 static size_t fill_connect_data(char *buf, size_t bufsize)
48 {
49 #if ADB_HOST
50@@ -1344,50 +1358,11 @@ int adb_main(int is_daemon, int server_port)
51 " unchanged.\n");
52 }
53
54- /* add extra groups:
55- ** AID_ADB to access the USB driver
56- ** AID_LOG to read system logs (adb logcat)
57- ** AID_INPUT to diagnose input issues (getevent)
58- ** AID_INET to diagnose network issues (netcfg, ping)
59- ** AID_GRAPHICS to access the frame buffer
60- ** AID_NET_BT and AID_NET_BT_ADMIN to diagnose bluetooth (hcidump)
61- ** AID_SDCARD_R to allow reading from the SD card
62- ** AID_SDCARD_RW to allow writing to the SD card
63- ** AID_NET_BW_STATS to read out qtaguid statistics
64- */
65- gid_t groups[] = { AID_ADB, AID_LOG, AID_INPUT, AID_INET, AID_GRAPHICS,
66- AID_NET_BT, AID_NET_BT_ADMIN, AID_SDCARD_R, AID_SDCARD_RW,
67- AID_NET_BW_STATS };
68- if (setgroups(sizeof(groups)/sizeof(groups[0]), groups) != 0) {
69- exit(1);
70- }
71-
72- /* don't listen on a port (default 5037) if running in secure mode */
73- /* don't run as root if we are running in secure mode */
74- if (should_drop_privileges()) {
75- drop_capabilities_bounding_set_if_needed();
76
77- /* then switch user and group to "shell" */
78- if (setgid(AID_SHELL) != 0) {
79- exit(1);
80- }
81- if (setuid(AID_SHELL) != 0) {
82- exit(1);
83- }
84-
85- D("Local port disabled\n");
86- } else {
87- char local_name[30];
88- if ((root_seclabel != NULL) && (is_selinux_enabled() > 0)) {
89- // b/12587913: fix setcon to allow const pointers
90- if (setcon((char *)root_seclabel) < 0) {
91- exit(1);
92- }
93- }
94- build_local_name(local_name, sizeof(local_name), server_port);
95- if(install_listener(local_name, "*smartsocket*", NULL, 0)) {
96- exit(1);
97- }
98+ char local_name[30];
99+ build_local_name(local_name, sizeof(local_name), server_port);
100+ if(install_listener(local_name, "*smartsocket*", NULL, 0)) {
101+ exit(1);
102 }
103
104 int usb = 0;
105@@ -1408,10 +1383,9 @@ int adb_main(int is_daemon, int server_port)
106 printf("using port=%d\n", port);
107 // listen on TCP port specified by service.adb.tcp.port property
108 local_init(port);
109- } else if (!usb) {
110- // listen on default port
111- local_init(DEFAULT_ADB_LOCAL_TRANSPORT_PORT);
112 }
113+ // listen on default port
114+ local_init(DEFAULT_ADB_LOCAL_TRANSPORT_PORT);
115
116 D("adb_main(): pre init_jdwp()\n");
117 init_jdwp();
118@@ -1695,7 +1669,6 @@ int main(int argc, char **argv)
119 #else
120 /* If adbd runs inside the emulator this will enable adb tracing via
121 * adb-debug qemud service in the emulator. */
122- adb_qemu_trace_init();
123 while(1) {
124 int c;
125 int option_index = 0;
126diff --git a/adb/adb_trace.h b/adb/adb_trace.h
127index 8a5d9f8..01c4c06 100644
128--- a/adb/adb_trace.h
129+++ b/adb/adb_trace.h
130@@ -22,7 +22,7 @@
131 #endif
132
133 /* define ADB_TRACE to 1 to enable tracing support, or 0 to disable it */
134-#define ADB_TRACE 1
135+#define ADB_TRACE 0
136
137 /* IMPORTANT: if you change the following list, don't
138 * forget to update the corresponding 'tags' table in
139diff --git a/adb/file_sync_service.c b/adb/file_sync_service.c
140index 7933858..3cbd0cd 100644
141--- a/adb/file_sync_service.c
142+++ b/adb/file_sync_service.c
143@@ -26,7 +26,6 @@
144
145 #include <errno.h>
146 #include <private/android_filesystem_config.h>
147-#include <selinux/android.h>
148 #include "sysdeps.h"
149
150 #define TRACE_TAG TRACE_SYNC
151@@ -73,7 +72,6 @@ static int mkdirs(char *name)
152 *x = '/';
153 return ret;
154 }
155- selinux_android_restorecon(name, 0);
156 }
157 *x++ = '/';
158 }
159@@ -251,7 +249,6 @@ static int handle_send_file(int s, char *path, uid_t uid,
160 if(fd >= 0) {
161 struct utimbuf u;
162 adb_close(fd);
163- selinux_android_restorecon(path, 0);
164 u.actime = timestamp;
165 u.modtime = timestamp;
166 utime(path, &u);
167diff --git a/adb/remount_service.c b/adb/remount_service.c
168index 72d15a1..df64799 100644
169--- a/adb/remount_service.c
170+++ b/adb/remount_service.c
171@@ -28,7 +28,7 @@
172 #include "adb.h"
173
174
175-static int system_ro = 1;
176+static int system_ro = 0;
177 static int vendor_ro = 1;
178
179 /* Returns the device used to mount a directory in /proc/mounts */
180@@ -84,7 +84,7 @@ static int remount(const char* dir, int* dir_ro)
181 int fd;
182 int OFF = 0;
183
184- if (dir_ro == 0) {
185+ if (*dir_ro == 0) {
186 return 0;
187 }
188
189@@ -132,7 +132,6 @@ void remount_service(int fd, void *cookie)
190 else {
191 write_string(fd, "remount failed\n");
192 }
193-
194 adb_close(fd);
195 }
196
197diff --git a/adb/services.c b/adb/services.c
198index e61371a..8d4e2b5 100644
199--- a/adb/services.c
200+++ b/adb/services.c
201@@ -34,7 +34,7 @@
202 # include <sys/ioctl.h>
203 # endif
204 #else
205-# include <cutils/android_reboot.h>
206+# include <sys/reboot.h>
207 # include <cutils/properties.h>
208 #endif
209
210@@ -127,7 +127,7 @@ void reboot_service(int fd, void *arg)
211 goto cleanup;
212 }
213
214- ret = property_set(ANDROID_RB_PROPERTY, property_val);
215+ ret = reboot(RB_AUTOBOOT);
216 if (ret < 0) {
217 snprintf(buf, sizeof(buf), "reboot failed: %d\n", ret);
218 writex(fd, buf, strlen(buf));
219@@ -302,7 +302,7 @@ static int create_subproc_raw(const char *cmd, const char *arg0, const char *arg
220 #if ADB_HOST
221 #define SHELL_COMMAND "/bin/sh"
222 #else
223-#define SHELL_COMMAND "/system/bin/sh"
224+#define SHELL_COMMAND "/bin/sh"
225 #endif
226
227 #if !ADB_HOST
228diff --git a/adb/transport_local.c b/adb/transport_local.c
229index 948cc15..d6d0a3a 100644
230--- a/adb/transport_local.c
231+++ b/adb/transport_local.c
232@@ -189,7 +189,7 @@ static void *server_socket_thread(void * arg)
233 }
234
235 /* This is relevant only for ADB daemon running inside the emulator. */
236-#if !ADB_HOST
237+#if !ADB_HOST && ADB_QEMU
238 /*
239 * Redefine open and write for qemu_pipe.h that contains inlined references
240 * to those routines. We will redifine them back after qemu_pipe.h inclusion.
241@@ -307,7 +307,7 @@ void local_init(int port)
242 if(HOST) {
243 func = client_socket_thread;
244 } else {
245-#if ADB_HOST
246+#if ADB_HOST || !ADB_QEMU
247 func = server_socket_thread;
248 #else
249 /* For the adbd daemon in the system image we need to distinguish
250diff --git a/include/cutils/properties.h b/include/cutils/properties.h
251index 798db8b..c86f312 100644
252--- a/include/cutils/properties.h
253+++ b/include/cutils/properties.h
254@@ -19,8 +19,9 @@
255
256 #include <sys/cdefs.h>
257 #include <stddef.h>
258-#include <sys/system_properties.h>
259-#include <stdint.h>
260+
261+#define PROP_NAME_MAX 32
262+#define PROP_VALUE_MAX 92
263
264 #ifdef __cplusplus
265 extern "C" {
diff --git a/recipes/adbd/files/adbd.service b/recipes/adbd/files/adbd.service
deleted file mode 100644
index d5005cf..0000000
--- a/recipes/adbd/files/adbd.service
+++ /dev/null
@@ -1,12 +0,0 @@
1[Unit]
2Description=ADB Server Daemon
3After=network.target
4
5[Service]
6Type=forking
7ExecStart=/usr/bin/adb-init start
8ExecStop=/usr/bin/adb-init stop
9Environment=HOME=/home/root
10
11[Install]
12WantedBy=multi-user.target
diff --git a/recipes/adbd/files/defaults b/recipes/adbd/files/defaults
deleted file mode 100644
index d2a3cc0..0000000
--- a/recipes/adbd/files/defaults
+++ /dev/null
@@ -1,4 +0,0 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=no
diff --git a/recipes/adbd/files/emulator/defaults b/recipes/adbd/files/emulator/defaults
deleted file mode 100644
index 0fbba4c..0000000
--- a/recipes/adbd/files/emulator/defaults
+++ /dev/null
@@ -1,4 +0,0 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=yes
diff --git a/recipes/adbd/files/imx53qsb/defaults b/recipes/adbd/files/imx53qsb/defaults
deleted file mode 100644
index 0fbba4c..0000000
--- a/recipes/adbd/files/imx53qsb/defaults
+++ /dev/null
@@ -1,4 +0,0 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=yes
diff --git a/recipes/adbd/files/intel-corei7-64/defaults b/recipes/adbd/files/intel-corei7-64/defaults
deleted file mode 100644
index 0fbba4c..0000000
--- a/recipes/adbd/files/intel-corei7-64/defaults
+++ /dev/null
@@ -1,4 +0,0 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=yes
diff --git a/recipes/adbd/files/nvidia-logan/adb-init b/recipes/adbd/files/nvidia-logan/adb-init
deleted file mode 100644
index 1be08c8..0000000
--- a/recipes/adbd/files/nvidia-logan/adb-init
+++ /dev/null
@@ -1,46 +0,0 @@
1#!/bin/sh
2
3DAEMON=/usr/bin/adbd
4
5. /etc/default/adbd
6
7case "$1" in
8start)
9 if [ "$USE_ETHERNET" = "no" ]; then
10 echo 0 > /sys/class/android_usb/android0/enable
11 sleep 1
12 echo ${SERIAL} > /sys/class/android_usb/android0/iSerial
13 echo ${VENDOR} > /sys/class/android_usb/android0/idVendor
14 echo ${PRODUCT} > /sys/class/android_usb/android0/idProduct
15 echo ffs > /sys/class/android_usb/android0/functions
16 echo adb >/sys/class/android_usb/android0/f_ffs/aliases
17 echo 1 > /sys/class/android_usb/android0/enable
18
19 if [ ! -d "/dev/usb-ffs" ]; then
20 mkdir /dev/usb-ffs
21 mkdir /dev/usb-ffs/adb
22 fi
23 mount -t functionfs adb /dev/usb-ffs/adb -o uid=2000,gid=2000
24 fi
25 start-stop-daemon --start --quiet --exec $DAEMON &
26 ;;
27stop)
28 start-stop-daemon --stop --quiet --exec $DAEMON
29 if [ "$USE_ETHERNET" = "no" ]; then
30 sleep 1
31 if mount | grep /dev/usb-ffs/adb > /dev/null; then
32 umount /dev/usb-ffs/adb
33 fi
34 fi
35 ;;
36restart)
37 start-stop-daemon --stop --quiet --exec $DAEMON
38 sleep 1
39 start-stop-daemon --start --quiet --exec $DAEMON &
40 ;;
41*)
42 echo "Usage: $0 {start|stop|restart}"
43 exit 1
44esac
45exit 0
46
diff --git a/recipes/adbd/files/nvidia-logan/defaults b/recipes/adbd/files/nvidia-logan/defaults
deleted file mode 100644
index 93bba63..0000000
--- a/recipes/adbd/files/nvidia-logan/defaults
+++ /dev/null
@@ -1,4 +0,0 @@
1VENDOR=0955
2PRODUCT=7940
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth1/address)
4USE_ETHERNET=no
diff --git a/recipes/adbd/files/raspberrypi/defaults b/recipes/adbd/files/raspberrypi/defaults
deleted file mode 100644
index 0fbba4c..0000000
--- a/recipes/adbd/files/raspberrypi/defaults
+++ /dev/null
@@ -1,4 +0,0 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=yes
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
index c6361c7..e8936e4 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -34,7 +34,6 @@ PR = "r0"
34inherit packagegroup 34inherit packagegroup
35 35
36RDEPENDS_${PN} = "\ 36RDEPENDS_${PN} = "\
37 adbd \
38 alsa-utils-amixer \ 37 alsa-utils-amixer \
39 binutils \ 38 binutils \
40 binutils-symlinks \ 39 binutils-symlinks \
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh
index 38260e6..e6d945f 100755
--- a/scripts/update-qt5-modules.sh
+++ b/scripts/update-qt5-modules.sh
@@ -47,6 +47,12 @@ for S in $SHA1S; do
47 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then 47 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then
48 sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* 48 sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb*
49 echo "qtwebengine (chromium) -> ${SHA1}" 49 echo "qtwebengine (chromium) -> ${SHA1}"
50 elif [ "${PROJECT}" = "qtlocation" ]; then
51 sed -i -e "/^SRCREV_qtlocation/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb*
52 echo "qtlocation -> ${SHA1}"
53 elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then
54 sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb*
55 echo "qtlocation (mapboxgl) -> ${SHA1}"
50 elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then 56 elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then
51 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb 57 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb
52 echo "qtquickcompiler -> ${SHA1}" 58 echo "qtquickcompiler -> ${SHA1}"