summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-30 16:44:12 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-10-31 14:51:50 +0000
commit9e428d2f631f68117e5aeb915a5fe7f09d81eab8 (patch)
treed4f9914e26a7e274aec75fccd93ce10cf71e0451
parent3af90cf837c14cac301d5f77ade2684e394bbca5 (diff)
downloadmeta-boot2qt-9e428d2f631f68117e5aeb915a5fe7f09d81eab8.tar.gz
qtdeclarative: fix inconsistent QML_COMPILE_HASH value
qtdeclarative and qtdeclarative-native may end up with different values for QML_COMPILE_HASH, which prevents running QML application when qtquickcompiler has been used. Change-Id: I9e3839b566996581bc40fa1472d7e7d07c82ce53 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch31
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend4
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch
new file mode 100644
index 0000000..a734f8a
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch
@@ -0,0 +1,31 @@
1From 260e165993fe15a1668cfd36caee18a95b2d2f59 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Mon, 2 Jul 2018 13:32:44 +0300
4Subject: [PATCH] Always use commit sha1 for QML_COMPILE_HASH
5
6git describe can produce different strings for the same sha1, depending
7on the version of git (length of short hash) and whether release tag was
8in place when build was done (v5.11.1-0- vs. v5.11.0-66-).
9
10Instead use rev-parse to get the unambiguous commit sha1 which is also
11what is used from the .tag file.
12
13Change-Id: If378f03eb764e2d858bda5b662106aa4402d6559
14Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
15---
16 src/qml/qml.pro | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/src/qml/qml.pro b/src/qml/qml.pro
20index 940ebb325..a76a87b15 100644
21--- a/src/qml/qml.pro
22+++ b/src/qml/qml.pro
23@@ -31,7 +31,7 @@ DEFINES += QT_NO_FOREACH
24 !equals(tag, "$${LITERAL_DOLLAR}Format:%H$${LITERAL_DOLLAR}") {
25 QML_COMPILE_HASH = $$tag
26 } else:exists($$PWD/../../.git) {
27- commit = $$system(git describe --tags --always --long --dirty)
28+ commit = $$system(git rev-parse HEAD)
29 QML_COMPILE_HASH = $$commit
30 }
31 compile_hash_contents = \
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend
index d9144a8..ec82d40 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend
@@ -27,6 +27,10 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI += "file://0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch"
33
30FILES_${PN}-plugins_mingw32 = " \ 34FILES_${PN}-plugins_mingw32 = " \
31 ${OE_QMAKE_PATH_PLUGINS}/*/*.dll \ 35 ${OE_QMAKE_PATH_PLUGINS}/*/*.dll \
32" 36"