diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-22 10:21:53 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-22 11:08:38 +0000 |
commit | 90bf1f50f69b9cbf0fcc709c53f617e8b68533d0 (patch) | |
tree | 651f56702756768a69ae2075b8a5637ecfe44aaa | |
parent | 0f967048d5bd99ffacfb9893b76818293aaaa8a0 (diff) | |
download | meta-boot2qt-90bf1f50f69b9cbf0fcc709c53f617e8b68533d0.tar.gz |
Remove automotive recipes
Automotive was released (and supported) in the jethro
Change-Id: Iab8560b4b0d530e872eef585c635b45274a4507b
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r-- | conf/distro/b2qt-auto.conf | 25 | ||||
-rw-r--r-- | recipes-qt/automotive/gammaray_git.bb | 29 | ||||
-rw-r--r-- | recipes-qt/automotive/neptune-ui/neptune.service | 11 | ||||
-rw-r--r-- | recipes-qt/automotive/neptune-ui_git.bb | 62 | ||||
-rw-r--r-- | recipes-qt/automotive/qtapplicationmanager_git.bb | 58 | ||||
-rw-r--r-- | recipes-qt/automotive/qtivi_git.bb | 37 | ||||
-rw-r--r-- | recipes-qt/automotive/qtwebbrowser_git.bb | 40 | ||||
-rw-r--r-- | recipes-qt/images/b2qt-automotive-qt5-image.bb | 50 | ||||
-rw-r--r-- | recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb | 31 |
9 files changed, 0 insertions, 343 deletions
diff --git a/conf/distro/b2qt-auto.conf b/conf/distro/b2qt-auto.conf deleted file mode 100644 index 46d41eb..0000000 --- a/conf/distro/b2qt-auto.conf +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | include conf/distro/b2qt.conf | ||
23 | |||
24 | PREFERRED_VERSION_qtwayland = "5.6%" | ||
25 | PREFERRED_VERSION_qtwayland-native = "5.6%" | ||
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb deleted file mode 100644 index 033e534..0000000 --- a/recipes-qt/automotive/gammaray_git.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "GammaRay Qt introspection probe" | ||
2 | HOMEPAGE = "http://www.kdab.com/gammaray" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=5996517d53e3c2722d457fb633e970ed" | ||
6 | |||
7 | inherit cmake_qt5 | ||
8 | |||
9 | SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" | ||
10 | |||
11 | BRANCH = "2.4" | ||
12 | SRCREV = "4995051c9d6733ce3eabb486283160bf31c87c10" | ||
13 | PV = "2.5.50+git${SRCPV}" | ||
14 | |||
15 | DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | EXTRA_OECMAKE += " -DGAMMARAY_BUILD_UI=OFF" | ||
20 | |||
21 | FILES_${PN}-dev += " \ | ||
22 | /usr/lib/cmake/* \ | ||
23 | /usr/mkspecs/modules/* \ | ||
24 | " | ||
25 | FILES_${PN}-dbg += " \ | ||
26 | /usr/lib/.debug/* \ | ||
27 | /usr/lib/gammaray/*/*/.debug \ | ||
28 | /usr/lib/gammaray/*/*/styles/.debug \ | ||
29 | " | ||
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service deleted file mode 100644 index 9d7881c..0000000 --- a/recipes-qt/automotive/neptune-ui/neptune.service +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Neptune | ||
3 | After=systemd-user-sessions.service | ||
4 | |||
5 | [Service] | ||
6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r -c /opt/am/config.yaml -c am-config.yaml --dbus none Main1280x800.qml | ||
7 | Restart=on-failure | ||
8 | WorkingDirectory=/opt/neptune | ||
9 | |||
10 | [Install] | ||
11 | WantedBy=multi-user.target | ||
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb deleted file mode 100644 index 7987958..0000000 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Neptune IVI UI" | ||
23 | LICENSE = "GPLv3" | ||
24 | LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=024d61f4545fb889faa57982553ce094" | ||
25 | |||
26 | inherit qt5-module systemd | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=http \ | ||
30 | file://neptune.service \ | ||
31 | " | ||
32 | |||
33 | SRCREV = "b3f10d156349727310ec30b27d01e639cce4f570" | ||
34 | BRANCH = "master" | ||
35 | |||
36 | S = "${WORKDIR}/git" | ||
37 | |||
38 | DEPENDS = "qtbase qtdeclarative" | ||
39 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ | ||
40 | ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" | ||
41 | |||
42 | do_configure_prepend() { | ||
43 | echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro | ||
44 | } | ||
45 | |||
46 | do_install_append() { | ||
47 | install -m 0755 -d ${D}${systemd_unitdir}/system | ||
48 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ | ||
49 | |||
50 | install -m 0644 ${S}/Main*.qml ${D}/opt/neptune | ||
51 | install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune | ||
52 | } | ||
53 | |||
54 | PACKAGES =+ "${PN}-apps" | ||
55 | RRECOMMENDS_${PN} += "${PN}-apps" | ||
56 | |||
57 | FILES_${PN}-apps += "/opt/neptune/apps" | ||
58 | FILES_${PN} += "\ | ||
59 | /opt/neptune \ | ||
60 | " | ||
61 | |||
62 | SYSTEMD_SERVICE_${PN} = "neptune.service" | ||
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb deleted file mode 100644 index 502dd06..0000000 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Qt component for application lifecycle management" | ||
23 | LICENSE = "GPLv3" | ||
24 | LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=311507adb75495acc0b61d69109485ce" | ||
25 | |||
26 | inherit qmake5 | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \ | ||
30 | " | ||
31 | |||
32 | SRCREV = "b7578378b578788c2ae9c60708a2908d3b090c16" | ||
33 | BRANCH = "dev" | ||
34 | |||
35 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ | ||
36 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | ||
37 | |||
38 | S = "${WORKDIR}/git" | ||
39 | |||
40 | EXTRA_QMAKEVARS_PRE += "\ | ||
41 | -config force-singleprocess \ | ||
42 | -config enable-dummydata \ | ||
43 | -config enable-ivi-logging \ | ||
44 | -config install-prefix=/usr \ | ||
45 | -config systemd-workaround \ | ||
46 | " | ||
47 | |||
48 | do_install_append() { | ||
49 | install -m 0755 -d ${D}/opt/am/ | ||
50 | install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/ | ||
51 | } | ||
52 | |||
53 | FILES_${PN} += "\ | ||
54 | /opt/am \ | ||
55 | ${libdir}/appman \ | ||
56 | ${datadir}/dbus-1" | ||
57 | FILES_${PN}-dbg += "${libdir}/appman/.debug" | ||
58 | FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/*.prl" | ||
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb deleted file mode 100644 index 038a0c4..0000000 --- a/recipes-qt/automotive/qtivi_git.bb +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Qt IVI" | ||
23 | LICENSE = "LGPL-3.0" | ||
24 | LIC_FILES_CHKSUM = "file://header.LGPL3-PELAGICORE;md5=0f5beb4df202cb6ef5cbc5296f3a3fa4" | ||
25 | |||
26 | inherit qt5-module | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \ | ||
30 | " | ||
31 | |||
32 | SRCREV = "2d378320dc07b8b3ac9a9ce89b7f7a99caa72f8a" | ||
33 | BRANCH = "dev" | ||
34 | |||
35 | S = "${WORKDIR}/git" | ||
36 | |||
37 | DEPENDS = "qtbase qtdeclarative" | ||
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb deleted file mode 100644 index 25494bf..0000000 --- a/recipes-qt/automotive/qtwebbrowser_git.bb +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Qt Web Browser" | ||
23 | LICENSE = "GPLv3" | ||
24 | LIC_FILES_CHKSUM = "file://src/main.cpp;md5=e78c6c33aa5ec2464456b72daf61ef9c;beginline=1;endline=36" | ||
25 | |||
26 | inherit qmake5 sdk-sources | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | git://codereview.qt-project.org/qt-apps/tqtc-qtwebbrowser;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/qtwebbrowser \ | ||
30 | " | ||
31 | |||
32 | SRCREV = "2e18b419a7084b1e39bf8749855768a1002e34de" | ||
33 | BRANCH = "dev" | ||
34 | |||
35 | S = "${WORKDIR}/git" | ||
36 | |||
37 | DEPENDS = "qtbase qtdeclarative qtwebengine" | ||
38 | |||
39 | FILES_${PN} += "/data/user/qt/qtwebbrowser" | ||
40 | FILES_${PN}-dbg += "/data/user/qt/qtwebbrowser/.debug" | ||
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb deleted file mode 100644 index 004c2e8..0000000 --- a/recipes-qt/images/b2qt-automotive-qt5-image.bb +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "B2Qt Automotive Qt5 image" | ||
23 | LICENSE = "QtEnterprise" | ||
24 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | ||
25 | PR = "r0" | ||
26 | |||
27 | DEPLOY_CONF_TYPE = "Automotive" | ||
28 | |||
29 | IMAGE_FEATURES += "\ | ||
30 | package-management \ | ||
31 | ssh-server-dropbear \ | ||
32 | tools-debug \ | ||
33 | debug-tweaks \ | ||
34 | hwcodecs \ | ||
35 | " | ||
36 | |||
37 | inherit core-image | ||
38 | inherit bootfs-image | ||
39 | |||
40 | MACHINE_EXTRA_INSTALL_QT ?= "" | ||
41 | |||
42 | IMAGE_INSTALL += "\ | ||
43 | ${MACHINE_EXTRA_INSTALL_QT} \ | ||
44 | packagegroup-b2qt-embedded-base \ | ||
45 | packagegroup-b2qt-embedded-tools \ | ||
46 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \ | ||
47 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \ | ||
48 | packagegroup-b2qt-qt5-modules \ | ||
49 | packagegroup-b2qt-automotive-addons \ | ||
50 | " | ||
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb deleted file mode 100644 index 945a330..0000000 --- a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" | ||
23 | |||
24 | LICENSE = "QtEnterprise" | ||
25 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | ||
26 | |||
27 | inherit populate_b2qt_qt5_sdk | ||
28 | |||
29 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" | ||
30 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ | ||
31 | packagegroup-b2qt-automotive-qt5-toolchain-target" | ||