summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-06-01 17:58:41 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-06-03 11:19:23 +0300
commit623fe39f70996687f07888d6cea1f706c300986a (patch)
tree66da3e82041cb1b22390f14dd92c0ba4ba45b2f6
parent4f2523addd2a4decbe82bb5dd66e5ba55d77626c (diff)
downloadmeta-boot2qt-623fe39f70996687f07888d6cea1f706c300986a.tar.gz
Add QtSimulator support
QtSimulator is added as dependency to Qt modules that support it, and some helper components are installed to emulator target. Change-Id: I878ffcfc6a8d9a579cb4a5a4e823fa7f0fa5a3cd Reviewed-by: Rainer Keller <rainer.keller@theqtcompany.com>
-rw-r--r--conf/distro/include/emulator.conf2
-rw-r--r--recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb49
-rwxr-xr-xrecipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh42
-rw-r--r--recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb40
-rw-r--r--recipes-qt/qt5-addons/qtsimulator_1.0.bb39
-rw-r--r--recipes-qt/qt5/qtlocation_%.bbappend3
-rw-r--r--recipes-qt/qt5/qtsensors_%.bbappend24
-rw-r--r--recipes-qt/qt5/qtsystems_%.bbappend24
8 files changed, 223 insertions, 0 deletions
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf
index d7afc52..79ebd07 100644
--- a/conf/distro/include/emulator.conf
+++ b/conf/distro/include/emulator.conf
@@ -44,6 +44,8 @@ MACHINE_EXTRA_INSTALL_SDK = "\
44 " 44 "
45MACHINE_EXTRA_INSTALL_QT = "\ 45MACHINE_EXTRA_INSTALL_QT = "\
46 qtglesstream \ 46 qtglesstream \
47 b2qt-emulator-proxy \
48 b2qt-emulator-vinput \
47 " 49 "
48MACHINE_EXTRA_INSTALL_QT_SDK = "\ 50MACHINE_EXTRA_INSTALL_QT_SDK = "\
49 qtglesstream-dev \ 51 qtglesstream-dev \
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb b/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb
new file mode 100644
index 0000000..da6d7bd
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Proxy daemon for QtSimulator"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://proxy.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://qt-gerrit.ci.local/QtRD-15810/b2qt-emulator.git;branch=${BRANCH};protocol=ssh \
31 file://emulatorproxyd.sh \
32 "
33
34SRCREV = "1d001910d45349ae2a44fa01516baaa7ff4c9eda"
35BRANCH = "master"
36
37S = "${WORKDIR}/git/src/helperlibs/proxy"
38
39DEPENDS = "qtbase qtsimulator"
40
41do_install_append() {
42 install -m 0755 -d ${D}${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/emulatorproxyd.sh ${D}${sysconfdir}/init.d/
44}
45
46INITSCRIPT_NAME = "emulatorproxyd.sh"
47INITSCRIPT_PARAMS = "defaults 97 10"
48
49inherit update-rc.d
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh b/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh
new file mode 100755
index 0000000..48177fa
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh
@@ -0,0 +1,42 @@
1#!/bin/sh
2#############################################################################
3##
4## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
5##
6## This file is part of the Qt Enterprise Embedded Scripts of the Qt
7## framework.
8##
9## $QT_BEGIN_LICENSE$
10## Commercial License Usage Only
11## Licensees holding valid commercial Qt license agreements with Digia
12## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
13## may use this file in accordance with the terms contained in said license
14## agreement.
15##
16## For further information use the contact form at
17## http://www.qt.io/contact-us.
18##
19##
20## $QT_END_LICENSE$
21##
22#############################################################################
23
24DAEMON=/usr/bin/emulatorproxyd
25
26case "$1" in
27start)
28 start-stop-daemon --start --quiet --exec $DAEMON &
29 ;;
30stop)
31 start-stop-daemon --stop --quiet --exec $DAEMON
32 ;;
33restart)
34 start-stop-daemon --stop --quiet --exec $DAEMON
35 sleep 1
36 start-stop-daemon --start --quiet --exec $DAEMON &
37 ;;
38*)
39 echo "Usage: $0 {start|stop|restart}"
40 exit 1
41esac
42exit 0
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb b/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb
new file mode 100644
index 0000000..b344395
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb
@@ -0,0 +1,40 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Virtual input plugin for QtSimulator"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://qvinput.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://qt-gerrit.ci.local/QtRD-15810/b2qt-emulator.git;branch=${BRANCH};protocol=ssh \
31 "
32
33SRCREV = "1d001910d45349ae2a44fa01516baaa7ff4c9eda"
34BRANCH = "master"
35
36EXTRA_QMAKEVARS_PRE += "CONFIG+=force_independent"
37
38S = "${WORKDIR}/git/src/helperlibs/vinput"
39
40DEPENDS = "qtbase qtsimulator"
diff --git a/recipes-qt/qt5-addons/qtsimulator_1.0.bb b/recipes-qt/qt5-addons/qtsimulator_1.0.bb
new file mode 100644
index 0000000..5f0c761
--- /dev/null
+++ b/recipes-qt/qt5-addons/qtsimulator_1.0.bb
@@ -0,0 +1,39 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "QtSimulator"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://src/simulator/version.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://qt-gerrit.ci.local/QtRD-15810/b2qt-qtsimulator.git;branch=${BRANCH};protocol=ssh \
31 "
32
33# v1.0.8
34SRCREV = "faf8ea5cee8a4105b97c3f2ba4a4c828f03a70ab"
35BRANCH = "master"
36
37S = "${WORKDIR}/git"
38
39DEPENDS = "qtbase"
diff --git a/recipes-qt/qt5/qtlocation_%.bbappend b/recipes-qt/qt5/qtlocation_%.bbappend
index c068600..facd006 100644
--- a/recipes-qt/qt5/qtlocation_%.bbappend
+++ b/recipes-qt/qt5/qtlocation_%.bbappend
@@ -21,3 +21,6 @@
21############################################################################# 21#############################################################################
22 22
23PACKAGECONFIG += "gypsy" 23PACKAGECONFIG += "gypsy"
24
25EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator"
26DEPENDS_emulator += "qtsimulator"
diff --git a/recipes-qt/qt5/qtsensors_%.bbappend b/recipes-qt/qt5/qtsensors_%.bbappend
new file mode 100644
index 0000000..a388c6f
--- /dev/null
+++ b/recipes-qt/qt5/qtsensors_%.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23EXTRA_QMAKEVARS_PRE_emulator += "SENSORS_PLUGINS=simulator"
24DEPENDS_emulator += "qtsimulator"
diff --git a/recipes-qt/qt5/qtsystems_%.bbappend b/recipes-qt/qt5/qtsystems_%.bbappend
new file mode 100644
index 0000000..af270e5
--- /dev/null
+++ b/recipes-qt/qt5/qtsystems_%.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator"
24DEPENDS_emulator += "qtsimulator"