summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-20 13:48:43 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-08-24 09:22:19 +0000
commit5708d0d71679fc85c0efd4de234a8f1f030d63dd (patch)
tree4c0bbdf5a09914428c5fdbc1c7af9e8941dd4b22
parentfeac3edc2ab20b106e1f50f3401d60a2355f5178 (diff)
downloadmeta-boot2qt-5708d0d71679fc85c0efd4de234a8f1f030d63dd.tar.gz
qtquicktimeline: fetch from public repository
Repository is now public, so we can treat it as a regular qt5 module. Remove qmlpreview recipe as that's part of qtdeclarative in 5.12. Task-number: QTPM-1153 Change-Id: I9bf608136c956124c83c23d50b52f4050bde10c5 Reviewed-by: Tim Jenssen <tim.jenssen@qt.io> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb5
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb5
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb44
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb17
4 files changed, 11 insertions, 60 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index 646239f..c1d7f26 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -62,6 +62,7 @@ RDEPENDS_${PN} += " \
62 qtotaupdate-dev \ 62 qtotaupdate-dev \
63 qtquickcontrols-dev \ 63 qtquickcontrols-dev \
64 qtquickcontrols2-dev \ 64 qtquickcontrols2-dev \
65 qtquicktimeline-dev \
65 qtremoteobjects-dev \ 66 qtremoteobjects-dev \
66 qtscxml-dev \ 67 qtscxml-dev \
67 qtsensors-dev \ 68 qtsensors-dev \
@@ -77,7 +78,3 @@ RDEPENDS_${PN} += " \
77 qtwebchannel-dev \ 78 qtwebchannel-dev \
78 qtxmlpatterns-dev \ 79 qtxmlpatterns-dev \
79 " 80 "
80
81RDEPENDS_${PN} += "\
82 ${@ "qtquicktimeline-dev" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \
83 "
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index cd5f35f..38bddaa 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -54,6 +54,7 @@ RDEPENDS_${PN} += " \
54 qtotaupdate \ 54 qtotaupdate \
55 qtquickcontrols \ 55 qtquickcontrols \
56 qtquickcontrols2 \ 56 qtquickcontrols2 \
57 qtquicktimeline \
57 qtremoteobjects \ 58 qtremoteobjects \
58 qtscxml \ 59 qtscxml \
59 qtsensors \ 60 qtsensors \
@@ -79,7 +80,3 @@ RDEPENDS_${PN} += " \
79 qtxmlpatterns \ 80 qtxmlpatterns \
80 qtvirtualkeyboard \ 81 qtvirtualkeyboard \
81 " 82 "
82
83RDEPENDS_${PN} += "\
84 ${@ "qtquicktimeline qmlpreview" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \
85 "
diff --git a/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb b/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb
deleted file mode 100644
index 1de4199..0000000
--- a/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QML Live Preview debug service"
31LICENSE = "The-Qt-Company-Commercial"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
33
34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc
36
37SRCREV = "6ae4a9da17e53bbb7c1729c24f58141a33bbcb9b"
38BRANCH = "master"
39
40SRC_URI = " \
41 git://codereview.qt-project.org/qt/tqtc-qmlpreview;branch=${BRANCH};protocol=ssh \
42 "
43
44DEPENDS = "qtbase qtdeclarative"
diff --git a/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb b/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb
index 74a66c0..a28022d 100644
--- a/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb
+++ b/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb
@@ -28,17 +28,18 @@
28############################################################################ 28############################################################################
29 29
30DESCRIPTION = "Qt Quick Timeline" 30DESCRIPTION = "Qt Quick Timeline"
31LICENSE = "The-Qt-Company-Commercial" 31LICENSE = "( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625" 32LIC_FILES_CHKSUM = " \
33 file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
34 file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
35 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
36 "
33 37
34inherit qt5-module 38inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 39require recipes-qt/qt5/qt5-git.inc
36 40
37SRCREV = "7ee1adca536b422623de1fe8da44135aeee6e9cf" 41DEPENDS = "qtbase qtdeclarative"
38BRANCH = "dev"
39 42
40SRC_URI = " \ 43QT_MODULE_BRANCH = "dev"
41 git://codereview.qt-project.org/qt/tqtc-qtquicktimeline;branch=${BRANCH};protocol=ssh \
42 "
43 44
44DEPENDS = "qtbase qtdeclarative" 45SRCREV = "42415a5b7a13b92701ccc7be70f9cdb7e522a3ea"