diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-10-23 12:09:02 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-10-30 09:15:57 +0000 |
commit | 211695b46a2e1b86f01f3d150e1502c3e473aaab (patch) | |
tree | 1c81f44020e056fc6a85993855b409b765f7b902 | |
parent | 1dc3bc0bbbc76297803ab4407a6d7183e085668e (diff) | |
download | meta-boot2qt-211695b46a2e1b86f01f3d150e1502c3e473aaab.tar.gz |
emulator: update recipes & configs for emulator3
* Remove emulator helperlib recipes as those are now included in
qtsimulator
* Move emulator proxy daemon launcher scripts under qtsimulator
recipe
* Update qtsimulator, qtsystems & qtglesstream to match with emulator3
* Remove qtsimulator dependencies from qtsensors and qtlocation as the
the modules do not build against more recent refactored qtsimulator.
Task-number: QTBUG-64006
Change-Id: Ib2374e702f2862b168ac2f1f2d6190f84823137c
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r-- | conf/distro/include/emulator.conf | 4 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb | 63 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb | 48 | ||||
-rw-r--r-- | recipes-qt/qt5-addons/qtglesstream.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5-addons/qtsimulator/emulatorproxy.service (renamed from recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxy.service) | 0 | ||||
-rwxr-xr-x | recipes-qt/qt5-addons/qtsimulator/emulatorproxyd.sh (renamed from recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh) | 0 | ||||
-rw-r--r-- | recipes-qt/qt5-addons/qtsimulator_1.0.bb | 24 | ||||
-rw-r--r-- | recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch | 23 | ||||
-rw-r--r-- | recipes-qt/qt5/qtlocation_git.bbappend | 6 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsensors_git.bbappend | 31 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsystems_git.bbappend | 2 |
11 files changed, 50 insertions, 153 deletions
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf index a749086..b6125ae 100644 --- a/conf/distro/include/emulator.conf +++ b/conf/distro/include/emulator.conf | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -49,6 +49,4 @@ MACHINE_EXTRA_INSTALL += "\ | |||
49 | mount-vboxsf \ | 49 | mount-vboxsf \ |
50 | qtsystems \ | 50 | qtsystems \ |
51 | qtglesstream \ | 51 | qtglesstream \ |
52 | b2qt-emulator-proxy \ | ||
53 | b2qt-emulator-vinput \ | ||
54 | " | 52 | " |
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb b/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb deleted file mode 100644 index 0692fc0..0000000 --- a/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb +++ /dev/null | |||
@@ -1,63 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Proxy daemon for QtSimulator" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://proxy.h;md5=709ec9e3c40137fa6068a903c57acdc1;beginline=1;endline=17" | ||
33 | |||
34 | inherit qmake5 | ||
35 | |||
36 | SRC_URI = " \ | ||
37 | git://codereview.qt-project.org/tqtc-boot2qt/emulator;branch=${BRANCH};protocol=ssh \ | ||
38 | file://emulatorproxyd.sh \ | ||
39 | file://emulatorproxy.service \ | ||
40 | " | ||
41 | |||
42 | SRCREV = "ab4a9f13831f44f3dcd375fa17ed7e102647febe" | ||
43 | BRANCH = "master" | ||
44 | PV = "1.0+git${SRCPV}" | ||
45 | |||
46 | S = "${WORKDIR}/git/src/helperlibs/proxy" | ||
47 | |||
48 | DEPENDS = "qtbase qtsimulator" | ||
49 | |||
50 | do_install_append() { | ||
51 | install -m 0755 -d ${D}${sysconfdir}/init.d | ||
52 | install -m 0755 ${WORKDIR}/emulatorproxyd.sh ${D}${sysconfdir}/init.d/ | ||
53 | |||
54 | install -m 0755 -d ${D}${systemd_unitdir}/system | ||
55 | install -m 0644 ${WORKDIR}/emulatorproxy.service ${D}${systemd_unitdir}/system/ | ||
56 | } | ||
57 | |||
58 | INITSCRIPT_NAME = "emulatorproxyd.sh" | ||
59 | INITSCRIPT_PARAMS = "defaults 97 10" | ||
60 | |||
61 | SYSTEMD_SERVICE_${PN} = "emulatorproxy.service" | ||
62 | |||
63 | inherit update-rc.d systemd | ||
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb b/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb deleted file mode 100644 index 2fb3f8c..0000000 --- a/recipes-qt/b2qt-addons/b2qt-emulator-vinput.bb +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Virtual input plugin for QtSimulator" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://qvinput.h;md5=f25c7436dbc72d4719a5684b28dbcf4b;beginline=1;endline=17" | ||
33 | |||
34 | inherit qt5-module | ||
35 | |||
36 | SRC_URI = " \ | ||
37 | git://codereview.qt-project.org/tqtc-boot2qt/emulator;branch=${BRANCH};protocol=ssh \ | ||
38 | " | ||
39 | |||
40 | SRCREV = "011e1c40716c8323f247e927de6640653d6811c4" | ||
41 | BRANCH = "master" | ||
42 | PV = "1.0+git${SRCPV}" | ||
43 | |||
44 | EXTRA_QMAKEVARS_PRE += "CONFIG+=force_independent" | ||
45 | |||
46 | S = "${WORKDIR}/git/src/helperlibs/vinput" | ||
47 | |||
48 | DEPENDS = "qtbase qtsimulator" | ||
diff --git a/recipes-qt/qt5-addons/qtglesstream.bb b/recipes-qt/qt5-addons/qtglesstream.bb index 7443724..0f942e7 100644 --- a/recipes-qt/qt5-addons/qtglesstream.bb +++ b/recipes-qt/qt5-addons/qtglesstream.bb | |||
@@ -38,7 +38,7 @@ SRC_URI = " \ | |||
38 | " | 38 | " |
39 | 39 | ||
40 | PV = "1.0.0" | 40 | PV = "1.0.0" |
41 | SRCREV = "17f5dc862f6669261cd08e948b2083bb7dca2b28" | 41 | SRCREV = "37f98d4b7123378d1ade7beedf5c5150cd26e178" |
42 | BRANCH = "dev" | 42 | BRANCH = "dev" |
43 | 43 | ||
44 | S = "${WORKDIR}/git" | 44 | S = "${WORKDIR}/git" |
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxy.service b/recipes-qt/qt5-addons/qtsimulator/emulatorproxy.service index 7a709fd..7a709fd 100644 --- a/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxy.service +++ b/recipes-qt/qt5-addons/qtsimulator/emulatorproxy.service | |||
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh b/recipes-qt/qt5-addons/qtsimulator/emulatorproxyd.sh index d73f1e7..d73f1e7 100755 --- a/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxyd.sh +++ b/recipes-qt/qt5-addons/qtsimulator/emulatorproxyd.sh | |||
diff --git a/recipes-qt/qt5-addons/qtsimulator_1.0.bb b/recipes-qt/qt5-addons/qtsimulator_1.0.bb index 4d46679..1dc3a70 100644 --- a/recipes-qt/qt5-addons/qtsimulator_1.0.bb +++ b/recipes-qt/qt5-addons/qtsimulator_1.0.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -29,17 +29,35 @@ | |||
29 | 29 | ||
30 | DESCRIPTION = "QtSimulator" | 30 | DESCRIPTION = "QtSimulator" |
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://src/simulator/version.h;md5=eb588a9fa3a2a45f725e9eb9f864e74b;beginline=1;endline=17" | 32 | LIC_FILES_CHKSUM = "file://src/simulator/simulatorglobal.h;md5=3daa1a609195439d0292259a74c7d615;beginline=1;endline=20" |
33 | 33 | ||
34 | inherit qt5-module | 34 | inherit qt5-module |
35 | 35 | ||
36 | SRC_URI = " \ | 36 | SRC_URI = " \ |
37 | git://codereview.qt-project.org/tqtc-boot2qt/qtsimulator;branch=${BRANCH};protocol=ssh \ | 37 | git://codereview.qt-project.org/tqtc-boot2qt/qtsimulator;branch=${BRANCH};protocol=ssh \ |
38 | file://emulatorproxyd.sh \ | ||
39 | file://emulatorproxy.service \ | ||
38 | " | 40 | " |
39 | 41 | ||
40 | SRCREV = "0307e85a8d3a8b83a346aa3910e88aabb7b7b2ac" | 42 | SRCREV = "f98633ebee7dbce79c00fbfec86537c6330e2b5f" |
41 | BRANCH = "master" | 43 | BRANCH = "master" |
42 | 44 | ||
43 | S = "${WORKDIR}/git" | 45 | S = "${WORKDIR}/git" |
44 | 46 | ||
45 | DEPENDS = "qtbase" | 47 | DEPENDS = "qtbase" |
48 | |||
49 | # Proxy daemon for QtSimulator | ||
50 | do_install_append() { | ||
51 | install -m 0755 -d ${D}${sysconfdir}/init.d | ||
52 | install -m 0755 ${WORKDIR}/emulatorproxyd.sh ${D}${sysconfdir}/init.d/ | ||
53 | |||
54 | install -m 0755 -d ${D}${systemd_unitdir}/system | ||
55 | install -m 0644 ${WORKDIR}/emulatorproxy.service ${D}${systemd_unitdir}/system/ | ||
56 | } | ||
57 | |||
58 | INITSCRIPT_NAME = "emulatorproxyd.sh" | ||
59 | INITSCRIPT_PARAMS = "defaults 97 10" | ||
60 | |||
61 | SYSTEMD_SERVICE_${PN} = "emulatorproxy.service" | ||
62 | |||
63 | inherit update-rc.d systemd | ||
diff --git a/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch b/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch new file mode 100644 index 0000000..ad4c7b8 --- /dev/null +++ b/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | From a7af02fe34bd8e067c7654ac366e19783b89e990 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mikko Gronoff <mikko.gronoff@qt.io> | ||
3 | Date: Wed, 25 Oct 2017 13:22:16 +0300 | ||
4 | Subject: [PATCH] location: disable simulator content under plugins | ||
5 | |||
6 | Does not build against more recent simulator | ||
7 | --- | ||
8 | src/plugins/position/position.pro | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/src/plugins/position/position.pro b/src/plugins/position/position.pro | ||
12 | index 1687a9d..347963f 100644 | ||
13 | --- a/src/plugins/position/position.pro | ||
14 | +++ b/src/plugins/position/position.pro | ||
15 | @@ -5,7 +5,7 @@ QT_FOR_CONFIG += positioning-private | ||
16 | qtHaveModule(dbus):SUBDIRS += geoclue | ||
17 | qtConfig(gypsy):SUBDIRS += gypsy | ||
18 | qtConfig(winrt_geolocation):SUBDIRS += winrt | ||
19 | -qtHaveModule(simulator):SUBDIRS += simulator | ||
20 | +#qtHaveModule(simulator):SUBDIRS += simulator | ||
21 | osx|ios|tvos:SUBDIRS += corelocation | ||
22 | android:SUBDIRS += android | ||
23 | win32:qtHaveModule(serialport):SUBDIRS += serialnmea | ||
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend index a81e16c..d6ee6a1 100644 --- a/recipes-qt/qt5/qtlocation_git.bbappend +++ b/recipes-qt/qt5/qtlocation_git.bbappend | |||
@@ -28,5 +28,7 @@ | |||
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | PACKAGECONFIG += "geoservices_mapboxgl" | 30 | PACKAGECONFIG += "geoservices_mapboxgl" |
31 | EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator" | 31 | |
32 | DEPENDS_append_emulator = " qtsimulator" | 32 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
33 | |||
34 | SRC_URI += "file://0001-location-disable-simulator-content-under-plugins.patch" | ||
diff --git a/recipes-qt/qt5/qtsensors_git.bbappend b/recipes-qt/qt5/qtsensors_git.bbappend deleted file mode 100644 index 655364b..0000000 --- a/recipes-qt/qt5/qtsensors_git.bbappend +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | EXTRA_QMAKEVARS_PRE_append_emulator = " SENSORS_PLUGINS=simulator" | ||
31 | DEPENDS_append_emulator = " qtsimulator" | ||
diff --git a/recipes-qt/qt5/qtsystems_git.bbappend b/recipes-qt/qt5/qtsystems_git.bbappend index 57c8285..83bead3 100644 --- a/recipes-qt/qt5/qtsystems_git.bbappend +++ b/recipes-qt/qt5/qtsystems_git.bbappend | |||
@@ -29,5 +29,3 @@ | |||
29 | 29 | ||
30 | EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator" | 30 | EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator" |
31 | DEPENDS_append_emulator = " qtsimulator" | 31 | DEPENDS_append_emulator = " qtsimulator" |
32 | |||
33 | SRCREV = "434af789f0d56ca7a521ca2d9ec8cf3b1057fd37" | ||