diff options
author | Teemu Holappa <teemu.holappa@theqtcompany.com> | 2015-10-23 13:37:47 +0300 |
---|---|---|
committer | Teemu Holappa <teemu.holappa@theqtcompany.com> | 2015-11-02 14:49:53 +0000 |
commit | a2f8538312a7a213950685d9560105c7503df6cc (patch) | |
tree | 4e2b25c18310174580391b2a0a32e0a732349363 | |
parent | ab25a352a48a3d3849c2ca62bda2f7ccb65207a3 (diff) | |
download | meta-boot2qt-a2f8538312a7a213950685d9560105c7503df6cc.tar.gz |
Added support for DC3217IYE (nuc) device.
Removed imx6 specific wayland configurations from packagegroup-b2qt-embedded-toolchain-target.bb to imx6.inc.
Change-Id: I2b700b21bbf23fbaf59dcb8558b0b96b11bb81ec
Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rwxr-xr-x | b2qt-init-build-env | 3 | ||||
-rw-r--r-- | conf/bblayers.conf.nuc.sample | 47 | ||||
-rw-r--r-- | conf/distro/include/apalis-imx6.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/colibri-imx6.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/imx6.inc | 5 | ||||
-rw-r--r-- | conf/distro/include/imx6qsabresd.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/nitrogen6x.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/nuc.conf | 37 | ||||
-rw-r--r-- | conf/distro/include/smarc-samx6i.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/tibidabo.conf | 2 | ||||
-rw-r--r-- | recipes/adbd/files/nuc/defaults | 5 | ||||
-rw-r--r-- | recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb | 2 | ||||
-rw-r--r-- | scripts/manifest.xml | 6 | ||||
-rw-r--r-- | scripts/manifest_fido.xml | 6 | ||||
-rwxr-xr-x | scripts/setup-environment.sh | 3 |
15 files changed, 119 insertions, 7 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env index a367d31..9c67a64 100755 --- a/b2qt-init-build-env +++ b/b2qt-init-build-env | |||
@@ -111,6 +111,9 @@ get_groups() { | |||
111 | raspberrypi|raspberrypi2) | 111 | raspberrypi|raspberrypi2) |
112 | PROJECT_GROUPS="rpi" | 112 | PROJECT_GROUPS="rpi" |
113 | ;; | 113 | ;; |
114 | nuc) | ||
115 | PROJECT_GROUPS="nuc" | ||
116 | ;; | ||
114 | emulator) | 117 | emulator) |
115 | PROJECT_GROUPS="emulator" | 118 | PROJECT_GROUPS="emulator" |
116 | ;; | 119 | ;; |
diff --git a/conf/bblayers.conf.nuc.sample b/conf/bblayers.conf.nuc.sample new file mode 100644 index 0000000..9a57e81 --- /dev/null +++ b/conf/bblayers.conf.nuc.sample | |||
@@ -0,0 +1,47 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | # LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf | ||
24 | # changes incompatibly | ||
25 | LCONF_VERSION = "6" | ||
26 | |||
27 | BBPATH = "${TOPDIR}" | ||
28 | BBFILES ?= "" | ||
29 | BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}" | ||
30 | |||
31 | BBLAYERS ?= " \ | ||
32 | ${BSPDIR}/sources/poky/meta \ | ||
33 | ${BSPDIR}/sources/poky/meta-yocto \ | ||
34 | ${BSPDIR}/sources/meta-intel \ | ||
35 | ${BSPDIR}/sources/meta-intel/meta-nuc \ | ||
36 | ${BSPDIR}/sources/meta-openembedded/meta-oe \ | ||
37 | ${BSPDIR}/sources/meta-openembedded/meta-python \ | ||
38 | ${BSPDIR}/sources/meta-openembedded/meta-networking \ | ||
39 | ${BSPDIR}/sources/meta-openembedded/meta-initramfs \ | ||
40 | ${BSPDIR}/sources/meta-qt5 \ | ||
41 | ${BSPDIR}/sources/meta-openembedded/meta-ruby \ | ||
42 | ${BSPDIR}/sources/meta-b2qt \ | ||
43 | " | ||
44 | BBLAYERS_NON_REMOVABLE ?= " \ | ||
45 | ${BSPDIR}/sources/poky/meta \ | ||
46 | ${BSPDIR}/sources/poky/meta-yocto \ | ||
47 | " | ||
diff --git a/conf/distro/include/apalis-imx6.conf b/conf/distro/include/apalis-imx6.conf index 2ceb4fe..119161e 100644 --- a/conf/distro/include/apalis-imx6.conf +++ b/conf/distro/include/apalis-imx6.conf | |||
@@ -43,7 +43,7 @@ MACHINE_EXTRA_INSTALL = "\ | |||
43 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | 43 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ |
44 | " | 44 | " |
45 | 45 | ||
46 | MACHINE_EXTRA_INSTALL_SDK = " \ | 46 | MACHINE_EXTRA_INSTALL_SDK += " \ |
47 | libgal-mx6 \ | 47 | libgal-mx6 \ |
48 | libegl-mx6 \ | 48 | libegl-mx6 \ |
49 | libegl-mx6-dev \ | 49 | libegl-mx6-dev \ |
diff --git a/conf/distro/include/colibri-imx6.conf b/conf/distro/include/colibri-imx6.conf index fcf716a..6b8399a 100644 --- a/conf/distro/include/colibri-imx6.conf +++ b/conf/distro/include/colibri-imx6.conf | |||
@@ -42,7 +42,7 @@ MACHINE_EXTRA_INSTALL = "\ | |||
42 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | 42 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ |
43 | " | 43 | " |
44 | 44 | ||
45 | MACHINE_EXTRA_INSTALL_SDK = " \ | 45 | MACHINE_EXTRA_INSTALL_SDK += " \ |
46 | libgal-mx6 \ | 46 | libgal-mx6 \ |
47 | libegl-mx6 \ | 47 | libegl-mx6 \ |
48 | libegl-mx6-dev \ | 48 | libegl-mx6-dev \ |
diff --git a/conf/distro/include/imx6.inc b/conf/distro/include/imx6.inc index 5cb3814..4b4f280 100644 --- a/conf/distro/include/imx6.inc +++ b/conf/distro/include/imx6.inc | |||
@@ -1,2 +1,7 @@ | |||
1 | BBMASK ?= " " | 1 | BBMASK ?= " " |
2 | BBMASK .= "|meta-fsl-arm/qt5-layer/recipes-qt/qt5" | 2 | BBMASK .= "|meta-fsl-arm/qt5-layer/recipes-qt/qt5" |
3 | |||
4 | MACHINE_EXTRA_INSTALL_SDK = " \ | ||
5 | ${@base_contains("DISTRO_FEATURES", "wayland", "libwayland-egl-mx6-dev", "", d)} \ | ||
6 | " | ||
7 | |||
diff --git a/conf/distro/include/imx6qsabresd.conf b/conf/distro/include/imx6qsabresd.conf index c677500..82c98a4 100644 --- a/conf/distro/include/imx6qsabresd.conf +++ b/conf/distro/include/imx6qsabresd.conf | |||
@@ -47,7 +47,7 @@ MACHINE_EXTRA_INSTALL = "\ | |||
47 | libopencv-objdetect \ | 47 | libopencv-objdetect \ |
48 | " | 48 | " |
49 | 49 | ||
50 | MACHINE_EXTRA_INSTALL_SDK = " \ | 50 | MACHINE_EXTRA_INSTALL_SDK += " \ |
51 | libgal-mx6 \ | 51 | libgal-mx6 \ |
52 | libegl-mx6 \ | 52 | libegl-mx6 \ |
53 | libegl-mx6-dev \ | 53 | libegl-mx6-dev \ |
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf index 0b41513..0abf640 100644 --- a/conf/distro/include/nitrogen6x.conf +++ b/conf/distro/include/nitrogen6x.conf | |||
@@ -60,7 +60,7 @@ MACHINE_EXTRA_INSTALL = "\ | |||
60 | libopencv-objdetect \ | 60 | libopencv-objdetect \ |
61 | " | 61 | " |
62 | 62 | ||
63 | MACHINE_EXTRA_INSTALL_SDK = " \ | 63 | MACHINE_EXTRA_INSTALL_SDK += " \ |
64 | libgal-mx6 \ | 64 | libgal-mx6 \ |
65 | libegl-mx6 \ | 65 | libegl-mx6 \ |
66 | libegl-mx6-dev \ | 66 | libegl-mx6-dev \ |
diff --git a/conf/distro/include/nuc.conf b/conf/distro/include/nuc.conf new file mode 100644 index 0000000..ad2a097 --- /dev/null +++ b/conf/distro/include/nuc.conf | |||
@@ -0,0 +1,37 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DISTRO_FEATURES_DEFAULT += "wayland weston" | ||
24 | |||
25 | DISTRO_FEATURES_remove = "usbgadget" | ||
26 | |||
27 | IMAGE_FSTYPES += " hddimg" | ||
28 | |||
29 | MACHINE_EXTRA_INSTALL = "\ | ||
30 | wayland \ | ||
31 | mesa-megadriver \ | ||
32 | " | ||
33 | |||
34 | MACHINE_EXTRA_INSTALL_SDK = " \ | ||
35 | mesa-dev \ | ||
36 | " | ||
37 | |||
diff --git a/conf/distro/include/smarc-samx6i.conf b/conf/distro/include/smarc-samx6i.conf index 8e69ac8..ff8bdd5 100644 --- a/conf/distro/include/smarc-samx6i.conf +++ b/conf/distro/include/smarc-samx6i.conf | |||
@@ -35,7 +35,7 @@ MACHINE_EXTRA_INSTALL = "\ | |||
35 | kernel-devicetree \ | 35 | kernel-devicetree \ |
36 | " | 36 | " |
37 | 37 | ||
38 | MACHINE_EXTRA_INSTALL_SDK = " \ | 38 | MACHINE_EXTRA_INSTALL_SDK += " \ |
39 | libgal-mx6 \ | 39 | libgal-mx6 \ |
40 | libegl-mx6 \ | 40 | libegl-mx6 \ |
41 | libegl-mx6-dev \ | 41 | libegl-mx6-dev \ |
diff --git a/conf/distro/include/tibidabo.conf b/conf/distro/include/tibidabo.conf index cec9fd5..b50338d 100644 --- a/conf/distro/include/tibidabo.conf +++ b/conf/distro/include/tibidabo.conf | |||
@@ -38,7 +38,7 @@ MACHINE_EXTRA_INSTALL = "\ | |||
38 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | 38 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ |
39 | " | 39 | " |
40 | 40 | ||
41 | MACHINE_EXTRA_INSTALL_SDK = " \ | 41 | MACHINE_EXTRA_INSTALL_SDK += " \ |
42 | libgal-mx6 \ | 42 | libgal-mx6 \ |
43 | libegl-mx6 \ | 43 | libegl-mx6 \ |
44 | libegl-mx6-dev \ | 44 | libegl-mx6-dev \ |
diff --git a/recipes/adbd/files/nuc/defaults b/recipes/adbd/files/nuc/defaults new file mode 100644 index 0000000..9b7edf5 --- /dev/null +++ b/recipes/adbd/files/nuc/defaults | |||
@@ -0,0 +1,5 @@ | |||
1 | VENDOR=0x18d1 | ||
2 | PRODUCT=0x0000 | ||
3 | SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address) | ||
4 | USE_ETHERNET=yes | ||
5 | HOME=/data | ||
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb index 59fa843..9aad8df 100644 --- a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb +++ b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb | |||
@@ -51,7 +51,7 @@ RDEPENDS_${PN} += "\ | |||
51 | atk-dev \ | 51 | atk-dev \ |
52 | libevent-dev \ | 52 | libevent-dev \ |
53 | ostree-dev \ | 53 | ostree-dev \ |
54 | ${@base_contains("DISTRO_FEATURES", "wayland", "libwayland-egl-mx6-dev libxkbcommon-dev libgbm-dev libdrm-dev", "", d)} \ | 54 | ${@base_contains("DISTRO_FEATURES", "wayland", "libxkbcommon-dev libgbm-dev libdrm-dev", "", d)} \ |
55 | ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \ | 55 | ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \ |
56 | ${MACHINE_EXTRA_INSTALL_SDK} \ | 56 | ${MACHINE_EXTRA_INSTALL_SDK} \ |
57 | " | 57 | " |
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 8471c30..5f0c16c 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -10,6 +10,7 @@ | |||
10 | <remote fetch="git://git.toradex.com" name="toradex"/> | 10 | <remote fetch="git://git.toradex.com" name="toradex"/> |
11 | <remote fetch="git://github.com/architech-boards" name="architech"/> | 11 | <remote fetch="git://github.com/architech-boards" name="architech"/> |
12 | <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/> | 12 | <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/> |
13 | <remote fetch="git://git.yoctoproject.org" name="intel"/> | ||
13 | 14 | ||
14 | <project name="poky" | 15 | <project name="poky" |
15 | remote="yocto" | 16 | remote="yocto" |
@@ -59,6 +60,11 @@ | |||
59 | revision="06c6b09e0776507e1230aa98b5ca10d9d3968286" | 60 | revision="06c6b09e0776507e1230aa98b5ca10d9d3968286" |
60 | path="sources/meta-tibidabo" | 61 | path="sources/meta-tibidabo" |
61 | groups="notdefault,architech"/> | 62 | groups="notdefault,architech"/> |
63 | <project name="meta-intel" | ||
64 | remote="intel" | ||
65 | revision="ead0a5c115e632015d8358f4f304ec8908732f5f" | ||
66 | path="sources/meta-intel" | ||
67 | groups="notdefault,nuc"/> | ||
62 | 68 | ||
63 | </manifest> | 69 | </manifest> |
64 | 70 | ||
diff --git a/scripts/manifest_fido.xml b/scripts/manifest_fido.xml index f146b2b..720d7d1 100644 --- a/scripts/manifest_fido.xml +++ b/scripts/manifest_fido.xml | |||
@@ -10,6 +10,7 @@ | |||
10 | <remote fetch="git://git.toradex.com" name="toradex"/> | 10 | <remote fetch="git://git.toradex.com" name="toradex"/> |
11 | <remote fetch="git://github.com/architech-boards" name="architech"/> | 11 | <remote fetch="git://github.com/architech-boards" name="architech"/> |
12 | <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/> | 12 | <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/> |
13 | <remote fetch="git://git.yoctoproject.org" name="intel"/> | ||
13 | 14 | ||
14 | <project name="poky" | 15 | <project name="poky" |
15 | remote="yocto" | 16 | remote="yocto" |
@@ -59,6 +60,11 @@ | |||
59 | revision="dora" | 60 | revision="dora" |
60 | path="sources/meta-tibidabo" | 61 | path="sources/meta-tibidabo" |
61 | groups="notdefault,architech"/> | 62 | groups="notdefault,architech"/> |
63 | <project name="meta-intel" | ||
64 | remote="intel" | ||
65 | revision="fido" | ||
66 | path="sources/meta-intel" | ||
67 | groups="notdefault,nuc"/> | ||
62 | 68 | ||
63 | </manifest> | 69 | </manifest> |
64 | 70 | ||
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index 683f19f..da7ec69 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -67,6 +67,9 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | |||
67 | raspberrypi|raspberrypi2) | 67 | raspberrypi|raspberrypi2) |
68 | LAYERSCONF="bblayers.conf.rpi.sample" | 68 | LAYERSCONF="bblayers.conf.rpi.sample" |
69 | ;; | 69 | ;; |
70 | nuc) | ||
71 | LAYERSCONF="bblayers.conf.nuc.sample" | ||
72 | ;; | ||
70 | emulator) | 73 | emulator) |
71 | LAYERSCONF="bblayers.conf.emulator.sample" | 74 | LAYERSCONF="bblayers.conf.emulator.sample" |
72 | ;; | 75 | ;; |