summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-07 15:14:49 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-08 10:41:34 +0000
commitff1cb4f603822798b052b9a781bd11b74a6a80f6 (patch)
tree2c60687dc523700399ac3f184b50131870d4d1ed
parent7636bdfa10759d1581d1e7284914b2d285e64f4b (diff)
downloadmeta-boot2qt-ff1cb4f603822798b052b9a781bd11b74a6a80f6.tar.gz
Add recipe for Qt Web Browser
Change-Id: I2927568f49aeecef5d0622a90ea4fd75a66653e0 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--recipes-qt/automotive/qtwebbrowser_git.bb41
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb1
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb
new file mode 100644
index 0000000..036e2e6
--- /dev/null
+++ b/recipes-qt/automotive/qtwebbrowser_git.bb
@@ -0,0 +1,41 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Qt Web Browser"
24LICENSE = "GPLv3"
25LIC_FILES_CHKSUM = "file://src/main.cpp;md5=e78c6c33aa5ec2464456b72daf61ef9c;beginline=1;endline=36"
26
27inherit qmake5 sdk-sources
28
29SRC_URI = " \
30 git://codereview.qt-project.org/qt-apps/tqtc-qtwebbrowser;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/qtwebbrowser \
31 "
32
33SRCREV = "2e18b419a7084b1e39bf8749855768a1002e34de"
34BRANCH = "dev"
35
36S = "${WORKDIR}/git"
37
38DEPENDS = "qtbase qtdeclarative qtwebengine"
39
40FILES_${PN} += "/data/user/qt/qtwebbrowser"
41FILES_${PN}-dbg += "/data/user/qt/qtwebbrowser/.debug"
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
index b680b1e..a4b2d10 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -30,4 +30,5 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
30RDEPENDS_${PN} += " \ 30RDEPENDS_${PN} += " \
31 b2qt-appcontroller \ 31 b2qt-appcontroller \
32 qtivi \ 32 qtivi \
33 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \
33 " 34 "