summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeemu Holappa <teemu.holappa@theqtcompany.com>2016-01-26 16:50:00 +0200
committerTeemu Holappa <teemu.holappa@theqtcompany.com>2016-01-28 08:23:45 +0000
commitdb1796ccd57e11236b1a9b0c7b0f639f6b657831 (patch)
tree330126a696be65cd598b228ecf5163e2a1cdad4a
parentd9c6a8312012d6b460fa13b52b238ab44b65c9c5 (diff)
downloadmeta-boot2qt-db1796ccd57e11236b1a9b0c7b0f639f6b657831.tar.gz
Changed eglfs kms as default platform plugin for NUC device.
Change-Id: I0f6a4ad478ff786940d9f680d3fd546af950082d Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r--meta-nuc-extras/recipes/recipes-qt/qtbase_git.bbappend23
-rw-r--r--recipes-qt/qt5/qtbase/nuc/oe-device-extra.pri10
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-nuc-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-nuc-extras/recipes/recipes-qt/qtbase_git.bbappend
new file mode 100644
index 0000000..c8a81a2
--- /dev/null
+++ b/meta-nuc-extras/recipes/recipes-qt/qtbase_git.bbappend
@@ -0,0 +1,23 @@
1#############################################################################
2##
3## Copyright (C) 2016 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23PACKAGECONFIG += "kms"
diff --git a/recipes-qt/qt5/qtbase/nuc/oe-device-extra.pri b/recipes-qt/qt5/qtbase/nuc/oe-device-extra.pri
new file mode 100644
index 0000000..cdb6204
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/nuc/oe-device-extra.pri
@@ -0,0 +1,10 @@
1NUC_CFLAGS = -m64
2QMAKE_LIBS_EGL += -lEGL
3QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL
4QMAKE_CFLAGS += $$NUC_CFLAGS
5QMAKE_CXXFLAGS += $$NUC_CFLAGS
6
7QMAKE_PLATFORM += boot2qt
8
9QT_QPA_DEFAULT_PLATFORM = eglfs
10EGLFS_DEVICE_INTEGRATION = eglfs_kms