summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-03-06 14:45:57 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-03-07 07:07:31 +0000
commitc2f620c0dafbefe821e484ce44348ff41f660e6f (patch)
tree7c4d55b10c069d12bab05d55be3bb63423b5bfc2
parent09f8c75cfeb0ea6d6b77dbd25cfbf779aa395b45 (diff)
downloadmeta-boot2qt-c2f620c0dafbefe821e484ce44348ff41f660e6f.tar.gz
emulator: correctly append qtsimulator configuration
Append configuration without overriding the defaults. Change-Id: Id8ceefb1a04f0ad825349cab549ac77b68c0de94 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/qtlocation_git.bbappend4
-rw-r--r--recipes-qt/qt5/qtsensors_git.bbappend4
-rw-r--r--recipes-qt/qt5/qtsystems_git.bbappend4
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend
index 2fed196..7ee2382 100644
--- a/recipes-qt/qt5/qtlocation_git.bbappend
+++ b/recipes-qt/qt5/qtlocation_git.bbappend
@@ -29,5 +29,5 @@
29 29
30PACKAGECONFIG += "gypsy" 30PACKAGECONFIG += "gypsy"
31 31
32EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" 32EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator"
33DEPENDS_emulator += "qtsimulator" 33DEPENDS_append_emulator = " qtsimulator"
diff --git a/recipes-qt/qt5/qtsensors_git.bbappend b/recipes-qt/qt5/qtsensors_git.bbappend
index 890656c..655364b 100644
--- a/recipes-qt/qt5/qtsensors_git.bbappend
+++ b/recipes-qt/qt5/qtsensors_git.bbappend
@@ -27,5 +27,5 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30EXTRA_QMAKEVARS_PRE_emulator += "SENSORS_PLUGINS=simulator" 30EXTRA_QMAKEVARS_PRE_append_emulator = " SENSORS_PLUGINS=simulator"
31DEPENDS_emulator += "qtsimulator" 31DEPENDS_append_emulator = " qtsimulator"
diff --git a/recipes-qt/qt5/qtsystems_git.bbappend b/recipes-qt/qt5/qtsystems_git.bbappend
index f199937..2a949eb 100644
--- a/recipes-qt/qt5/qtsystems_git.bbappend
+++ b/recipes-qt/qt5/qtsystems_git.bbappend
@@ -27,5 +27,5 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" 30EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator"
31DEPENDS_emulator += "qtsimulator" 31DEPENDS_append_emulator = " qtsimulator"