summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-01-04 09:26:32 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-01-10 08:10:38 +0000
commit9585a16c9668f8aacba7ce72d5061fc38c4745e0 (patch)
tree980cc6a8385cc0d9eeb195455f02933eac309caf
parent65dbb94f62fd29143c5f6854e5a0e54691ee549d (diff)
downloadmeta-boot2qt-9585a16c9668f8aacba7ce72d5061fc38c4745e0.tar.gz
libgbm: make possible to use other libgbm provides than mesa
Mesa is the default libgbm provider, but does not yet have virtual/libgbm in the PROVIDES list. This makes it difficult the change the dependency to another recipes that provide only libgbm. Add virtual/libgbm to mesa and TI's libgbm recipe, and change the dependency in qtbase. Add gbm to qtbase PACKAGECONFIG on intel devices. Task-number: QTBUG-57896 Change-Id: I491df7057e52f9e74dd87abf65e542eab2cd3f9e Reviewed-by: Gatis Paeglis <gatis.paeglis@qt.io> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend2
-rw-r--r--meta-ti-extras/recipes/gbm/libgbm_%.bbappend30
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend3
-rw-r--r--recipes/mesa/mesa_%.bbappend1
4 files changed, 35 insertions, 1 deletions
diff --git a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
index 8770c65..602782e 100644
--- a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
+++ b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
@@ -27,4 +27,4 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30PACKAGECONFIG += "kms" 30PACKAGECONFIG += "gbm kms"
diff --git a/meta-ti-extras/recipes/gbm/libgbm_%.bbappend b/meta-ti-extras/recipes/gbm/libgbm_%.bbappend
new file mode 100644
index 0000000..fd11a50
--- /dev/null
+++ b/meta-ti-extras/recipes/gbm/libgbm_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PROVIDES += "virtual/libgbm"
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
index 585e1b5..e997936 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -58,3 +58,6 @@ do_configure_prepend() {
58} 58}
59 59
60SRCREV = "179045f36a16ce2f6cfaad1dbd9443b52b1bf8d3" 60SRCREV = "179045f36a16ce2f6cfaad1dbd9443b52b1bf8d3"
61
62# make other libgbm providers possible
63PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/libgbm"
diff --git a/recipes/mesa/mesa_%.bbappend b/recipes/mesa/mesa_%.bbappend
index fc55a18..35f66f4 100644
--- a/recipes/mesa/mesa_%.bbappend
+++ b/recipes/mesa/mesa_%.bbappend
@@ -28,3 +28,4 @@
28############################################################################ 28############################################################################
29 29
30RDEPENDS_libgles2-mesa-dev += "libgles3-mesa-dev" 30RDEPENDS_libgles2-mesa-dev += "libgles3-mesa-dev"
31PROVIDES += "virtual/libgbm"