summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-02-14 15:08:50 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-03-16 14:27:29 +0000
commit8f88b218cab885bdbc67db77c876fc5a7dd4e790 (patch)
treec0aad1584e54506504bb2a734ae825a577b7ede7
parent7833bd3a6f9a5f737faa600c40c44b3b422a401d (diff)
downloadmeta-boot2qt-8f88b218cab885bdbc67db77c876fc5a7dd4e790.tar.gz
Add multiscreen automotive demo
Startup is disabled by default. Task-number: QTAUTO-275 Change-Id: I3c7cbca10dc3a0d0ca2cc512c34b02b6985fe0d9 Reviewed-by: Teemu Holappa <teemu.holappa@qt.io>
-rw-r--r--recipes-qt/automotive/multiscreen-demo_git.bb65
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb1
2 files changed, 66 insertions, 0 deletions
diff --git a/recipes-qt/automotive/multiscreen-demo_git.bb b/recipes-qt/automotive/multiscreen-demo_git.bb
new file mode 100644
index 0000000..1997bd5
--- /dev/null
+++ b/recipes-qt/automotive/multiscreen-demo_git.bb
@@ -0,0 +1,65 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Multiscreen Demo"
31LICENSE = "GPLv3 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073"
33
34inherit qt5-module systemd
35require recipes-qt/qt5/qt5-git.inc
36
37QT_GIT = "git://code.qt.io/qt-apps"
38QT_MODULE_BRANCH = "master"
39
40SRC_URI += "git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets"
41
42SRCREV_multiscreen = "77ecd7d03aeea3bb7d10ac8ef448920da11ae306"
43SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264"
44
45SRCREV_FORMAT = "multiscreen_assets"
46SRCREV = "${SRCREV_multiscreen}"
47
48DEPENDS = "qtbase qtdeclarative qt3d"
49RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard"
50
51EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt"
52
53do_install_append() {
54 install -m 0755 ${S}/start.sh ${D}/opt/automotivedemo/
55
56 install -d ${D}${systemd_system_unitdir}
57 install -m 0644 ${S}/scripts/automotivedemo.service ${D}${systemd_system_unitdir}/
58}
59
60FILES_${PN} += "\
61 /opt/automotivedemo \
62 "
63
64SYSTEMD_SERVICE_${PN} = "automotivedemo.service"
65SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
index 391224e..bd7f777 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -42,4 +42,5 @@ RDEPENDS_${PN} += " \
42 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \ 42 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \
43 gammaray \ 43 gammaray \
44 qmllive-target \ 44 qmllive-target \
45 multiscreen-demo \
45 " 46 "