summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKari Oikarinen <kari.oikarinen@qt.io>2017-01-19 09:23:39 +0200
committerKari Oikarinen <kari.oikarinen@qt.io>2017-01-19 08:02:46 +0000
commit689d7e5140cd1e88d57c17cb6301afa5570ad8cb (patch)
treed761142c62ff8dbfd1c40cd084351cd024424fe7
parentd8f60fdd7200971279a0d2417ddddf30603c99ba (diff)
downloadmeta-boot2qt-689d7e5140cd1e88d57c17cb6301afa5570ad8cb.tar.gz
Fix error in /etc/profile when run from a non-tty
The tty command can return "not a tty" and thus contain spaces. The test command invocation in /etc/profile did not take this into account. This led to an error message "/etc/profile: line 34: test: too many arguments" when running a process with Qt Creator RemoteLinux plugin. Change-Id: I892f8ed47a95f41977b7ef49f42c5c3a41cdf848 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
index 48ed6ee..1dc5501 100644
--- a/recipes/base-files/base-files_3.0.14.bbappend
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -38,4 +38,7 @@ do_install_append() {
38 38
39 install -m 0755 -d ${D}${sysconfdir}/modprobe.d 39 install -m 0755 -d ${D}${sysconfdir}/modprobe.d
40 install -m 0644 ${WORKDIR}/blacklist.conf ${D}${sysconfdir}/modprobe.d 40 install -m 0644 ${WORKDIR}/blacklist.conf ${D}${sysconfdir}/modprobe.d
41
42 # Add quotes around command expansion, since tty may return "not a tty"
43 sed -i 's#test `tty | cut -c1-8`#test "`tty | cut -c1-8`"#' ${D}${sysconfdir}/profile
41} 44}