summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-12-15 16:37:33 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-12-15 16:45:14 +0200
commit4969969259e361f6b0b4c1087e66f91846a401ad (patch)
tree5155010dddf3b8ca5d9e14c068e4b21f7ad19092
parentf0296da6afd374d10788d5dd1ade0fcd6e78ff7f (diff)
parent68b683a85571d76ccaf9e61e71325aacb74e4e7e (diff)
downloadmeta-boot2qt-4969969259e361f6b0b4c1087e66f91846a401ad.tar.gz
Merge remote-tracking branch 'origin/jethro' into krogoth
* origin/jethro: colibri-imx7: use opengldummy for egl and libgles2 qt5: update submodules gdb: correctly enable python for mingw sdk build mesa: make sure we get libgles3-dev package in toolchain qt5: update submodules beaglebone: start qtlauncher only after /dev/fb0 exists Update qtdeviceutilities module revision Conflicts: meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb recipes-qt/qt5/nativesdk-qtbase_git.bbappend recipes-qt/qt5/qtbase-native_git.bbappend recipes-qt/qt5/qtbase_git.bbappend recipes-qt/qt5/qtwebengine_git.bbappend scripts/manifest.xml Change-Id: I2f175980f16084c37c5d4032387579dab574952d
-rw-r--r--conf/distro/include/colibri-imx7.conf3
-rw-r--r--recipes/gdb/gdb-cross-canadian_7.%.bbappend1
-rw-r--r--recipes/mesa/mesa_%.bbappend30
3 files changed, 34 insertions, 0 deletions
diff --git a/conf/distro/include/colibri-imx7.conf b/conf/distro/include/colibri-imx7.conf
index 7a95f80..4a4d460 100644
--- a/conf/distro/include/colibri-imx7.conf
+++ b/conf/distro/include/colibri-imx7.conf
@@ -35,4 +35,7 @@ BOOT_SCRIPTS += " \
35 u-boot-nand.imx:${MACHINEDIR}/u-boot-nand.imx \ 35 u-boot-nand.imx:${MACHINEDIR}/u-boot-nand.imx \
36 " 36 "
37 37
38PREFERRED_PROVIDER_virtual/egl = "opengldummy"
39PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy"
40
38DISTRO_FEATURES_remove = "webengine" 41DISTRO_FEATURES_remove = "webengine"
diff --git a/recipes/gdb/gdb-cross-canadian_7.%.bbappend b/recipes/gdb/gdb-cross-canadian_7.%.bbappend
index b217805..34c14b7 100644
--- a/recipes/gdb/gdb-cross-canadian_7.%.bbappend
+++ b/recipes/gdb/gdb-cross-canadian_7.%.bbappend
@@ -29,6 +29,7 @@
29 29
30DEPENDS_${PN}_append_sdkmingw32 = " nativesdk-prebuild-python" 30DEPENDS_${PN}_append_sdkmingw32 = " nativesdk-prebuild-python"
31RDEPENDS_${PN}_append_sdkmingw32 = " nativesdk-prebuild-python" 31RDEPENDS_${PN}_append_sdkmingw32 = " nativesdk-prebuild-python"
32EXTRA_OECONF_remove_sdkmingw32 = " --with-python=no"
32EXTRA_OECONF_append_sdkmingw32 = " --with-python" 33EXTRA_OECONF_append_sdkmingw32 = " --with-python"
33 34
34do_install_append_sdkmingw32() { 35do_install_append_sdkmingw32() {
diff --git a/recipes/mesa/mesa_%.bbappend b/recipes/mesa/mesa_%.bbappend
new file mode 100644
index 0000000..fc55a18
--- /dev/null
+++ b/recipes/mesa/mesa_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30RDEPENDS_libgles2-mesa-dev += "libgles3-mesa-dev"