summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-11-02 09:56:53 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-11-03 14:11:24 +0000
commit464002ea626da5febafcae705773077eba7f7b8a (patch)
tree1d5179fdc6ab03b21d949fda201dd8b87c514ad6
parent3fe43d008f771ba79f8a0fdf79142163d5211bdc (diff)
downloadmeta-boot2qt-464002ea626da5febafcae705773077eba7f7b8a.tar.gz
qtbase: add option to build without opengl
Change-Id: I2a04a21feb476de93d2a8d641f66cfc1d2b91ef8 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Risto Avila <risto.avila@qt.io>
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
index 773e2de..ae86903 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -27,7 +27,11 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30PACKAGECONFIG_GL = "gles2 eglfs" 30PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 eglfs', 'no-opengl', d)}"
31
32# emulator is exception due to qtglesstream
33PACKAGECONFIG_GL_emulator = "gles2 eglfs"
34
31PACKAGECONFIG += " \ 35PACKAGECONFIG += " \
32 accessibility \ 36 accessibility \
33 alsa \ 37 alsa \
@@ -56,3 +60,6 @@ do_configure_prepend() {
56} 60}
57 61
58SRCREV = "016b5bc949b6dfb2f76db2e8b40a40e7eaee6828" 62SRCREV = "016b5bc949b6dfb2f76db2e8b40a40e7eaee6828"
63
64# temporarily here
65PACKAGECONFIG[no-opengl] = "-no-opengl"