summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-16 09:27:00 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-08 12:51:37 +0000
commit2f745904ddf909956d325594d99840891735556b (patch)
treeddbc3ce72247e2c09738d7c71ba2aed16f0f12a3
parent9a46c8174a1814a628b63b795b31cf4e181b72a3 (diff)
downloadmeta-boot2qt-2f745904ddf909956d325594d99840891735556b.tar.gz
NUC: use the common intel-corei7-64 BSP
meta-intel no longer has specific BSPs for each machine, but they share a common BSP based on the architecture. Change-Id: Ibbb7b8b2153103367168ea37d904ce23bc245108 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rwxr-xr-xb2qt-init-build-env4
-rw-r--r--conf/bblayers.conf.intel.sample (renamed from conf/bblayers.conf.nuc.sample)3
-rw-r--r--conf/distro/include/intel-corei7-64.conf (renamed from conf/distro/include/nuc.conf)0
-rw-r--r--meta-intel-extras/classes/image_dd_efi.bbclass (renamed from meta-nuc-extras/classes/image_dd_efi.bbclass)0
-rw-r--r--meta-intel-extras/conf/layer.conf (renamed from meta-nuc-extras/conf/layer.conf)6
-rw-r--r--meta-intel-extras/recipes/grub/grub-efi/grub.cfg (renamed from meta-nuc-extras/recipes/grub/grub-efi/grub.cfg)0
-rw-r--r--meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend (renamed from meta-nuc-extras/recipes/grub/grub-efi_2.00.bbappend)0
-rw-r--r--meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg (renamed from meta-nuc-extras/recipes/linux/linux-yocto/wlan-realtek.cfg)0
-rw-r--r--meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend (renamed from meta-nuc-extras/recipes/linux/linux-yocto_3.%.bbappend)0
-rw-r--r--meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend (renamed from meta-nuc-extras/recipes/recipes-qt/qtbase_git.bbappend)0
-rw-r--r--recipes-qt/qt5/qtbase/intel-corei7-64/oe-device-extra.pri (renamed from recipes-qt/qt5/qtbase/nuc/oe-device-extra.pri)0
-rw-r--r--recipes/adbd/files/intel-corei7-64/defaults (renamed from recipes/adbd/files/nuc/defaults)0
-rw-r--r--scripts/manifest.xml2
-rw-r--r--scripts/manifest_jethro.xml2
-rwxr-xr-xscripts/setup-environment.sh4
15 files changed, 10 insertions, 11 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index 8447700..8541c72 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -113,8 +113,8 @@ get_groups() {
113 raspberrypi|raspberrypi2|raspberrypi3) 113 raspberrypi|raspberrypi2|raspberrypi3)
114 PROJECT_GROUPS="rpi" 114 PROJECT_GROUPS="rpi"
115 ;; 115 ;;
116 nuc) 116 intel-corei7-64)
117 PROJECT_GROUPS="nuc" 117 PROJECT_GROUPS="intel"
118 ;; 118 ;;
119 nvidia-logan) 119 nvidia-logan)
120 PROJECT_GROUPS="nvidia-logan" 120 PROJECT_GROUPS="nvidia-logan"
diff --git a/conf/bblayers.conf.nuc.sample b/conf/bblayers.conf.intel.sample
index 90998fb..df1f544 100644
--- a/conf/bblayers.conf.nuc.sample
+++ b/conf/bblayers.conf.intel.sample
@@ -31,14 +31,13 @@ BBLAYERS ?= " \
31 ${BSPDIR}/sources/poky/meta \ 31 ${BSPDIR}/sources/poky/meta \
32 ${BSPDIR}/sources/poky/meta-yocto \ 32 ${BSPDIR}/sources/poky/meta-yocto \
33 ${BSPDIR}/sources/meta-intel \ 33 ${BSPDIR}/sources/meta-intel \
34 ${BSPDIR}/sources/meta-intel/meta-nuc \
35 ${BSPDIR}/sources/meta-openembedded/meta-oe \ 34 ${BSPDIR}/sources/meta-openembedded/meta-oe \
36 ${BSPDIR}/sources/meta-openembedded/meta-python \ 35 ${BSPDIR}/sources/meta-openembedded/meta-python \
37 ${BSPDIR}/sources/meta-openembedded/meta-networking \ 36 ${BSPDIR}/sources/meta-openembedded/meta-networking \
38 ${BSPDIR}/sources/meta-openembedded/meta-initramfs \ 37 ${BSPDIR}/sources/meta-openembedded/meta-initramfs \
39 ${BSPDIR}/sources/meta-openembedded/meta-multimedia \ 38 ${BSPDIR}/sources/meta-openembedded/meta-multimedia \
40 ${BSPDIR}/sources/meta-b2qt \ 39 ${BSPDIR}/sources/meta-b2qt \
41 ${BSPDIR}/sources/meta-b2qt/meta-nuc-extras \ 40 ${BSPDIR}/sources/meta-b2qt/meta-intel-extras \
42 ${BSPDIR}/sources/meta-mingw \ 41 ${BSPDIR}/sources/meta-mingw \
43 ${BSPDIR}/sources/meta-qt5 \ 42 ${BSPDIR}/sources/meta-qt5 \
44 " 43 "
diff --git a/conf/distro/include/nuc.conf b/conf/distro/include/intel-corei7-64.conf
index 8a41388..8a41388 100644
--- a/conf/distro/include/nuc.conf
+++ b/conf/distro/include/intel-corei7-64.conf
diff --git a/meta-nuc-extras/classes/image_dd_efi.bbclass b/meta-intel-extras/classes/image_dd_efi.bbclass
index 7bbff62..7bbff62 100644
--- a/meta-nuc-extras/classes/image_dd_efi.bbclass
+++ b/meta-intel-extras/classes/image_dd_efi.bbclass
diff --git a/meta-nuc-extras/conf/layer.conf b/meta-intel-extras/conf/layer.conf
index f0cb66f..3b7be9d 100644
--- a/meta-nuc-extras/conf/layer.conf
+++ b/meta-intel-extras/conf/layer.conf
@@ -27,6 +27,6 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \ 27 ${LAYERDIR}/recipes*/*/*.bbappend \
28 " 28 "
29 29
30BBFILE_COLLECTIONS += "b2qt_nuc" 30BBFILE_COLLECTIONS += "b2qt_intel"
31BBFILE_PATTERN_b2qt_nuc := "^${LAYERDIR}/" 31BBFILE_PATTERN_b2qt_intel := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_nuc = "20" 32BBFILE_PRIORITY_b2qt_intel = "20"
diff --git a/meta-nuc-extras/recipes/grub/grub-efi/grub.cfg b/meta-intel-extras/recipes/grub/grub-efi/grub.cfg
index ca53537..ca53537 100644
--- a/meta-nuc-extras/recipes/grub/grub-efi/grub.cfg
+++ b/meta-intel-extras/recipes/grub/grub-efi/grub.cfg
diff --git a/meta-nuc-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
index d002240..d002240 100644
--- a/meta-nuc-extras/recipes/grub/grub-efi_2.00.bbappend
+++ b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
diff --git a/meta-nuc-extras/recipes/linux/linux-yocto/wlan-realtek.cfg b/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg
index 65ac248..65ac248 100644
--- a/meta-nuc-extras/recipes/linux/linux-yocto/wlan-realtek.cfg
+++ b/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg
diff --git a/meta-nuc-extras/recipes/linux/linux-yocto_3.%.bbappend b/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend
index 55ac1a2..55ac1a2 100644
--- a/meta-nuc-extras/recipes/linux/linux-yocto_3.%.bbappend
+++ b/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend
diff --git a/meta-nuc-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
index 2346521..2346521 100644
--- a/meta-nuc-extras/recipes/recipes-qt/qtbase_git.bbappend
+++ b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
diff --git a/recipes-qt/qt5/qtbase/nuc/oe-device-extra.pri b/recipes-qt/qt5/qtbase/intel-corei7-64/oe-device-extra.pri
index cdb6204..cdb6204 100644
--- a/recipes-qt/qt5/qtbase/nuc/oe-device-extra.pri
+++ b/recipes-qt/qt5/qtbase/intel-corei7-64/oe-device-extra.pri
diff --git a/recipes/adbd/files/nuc/defaults b/recipes/adbd/files/intel-corei7-64/defaults
index 0fbba4c..0fbba4c 100644
--- a/recipes/adbd/files/nuc/defaults
+++ b/recipes/adbd/files/intel-corei7-64/defaults
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 7af1380..30ff5e7 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -72,7 +72,7 @@
72 remote="intel" 72 remote="intel"
73 revision="4e87c59bdedaa8c3e44fc02fd23be726c4d1dfb9" 73 revision="4e87c59bdedaa8c3e44fc02fd23be726c4d1dfb9"
74 path="sources/meta-intel" 74 path="sources/meta-intel"
75 groups="notdefault,nuc"/> 75 groups="notdefault,intel"/>
76 76
77 <project name="meta-tegra" 77 <project name="meta-tegra"
78 remote="playground" 78 remote="playground"
diff --git a/scripts/manifest_jethro.xml b/scripts/manifest_jethro.xml
index 3503552..95ed55e 100644
--- a/scripts/manifest_jethro.xml
+++ b/scripts/manifest_jethro.xml
@@ -72,7 +72,7 @@
72 remote="intel" 72 remote="intel"
73 revision="jethro" 73 revision="jethro"
74 path="sources/meta-intel" 74 path="sources/meta-intel"
75 groups="notdefault,nuc"/> 75 groups="notdefault,intel"/>
76 76
77 <project name="meta-tegra" 77 <project name="meta-tegra"
78 remote="playground" 78 remote="playground"
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index 0ddd4b8..9e8c4d1 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -69,8 +69,8 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
69 raspberrypi|raspberrypi2|raspberrypi3) 69 raspberrypi|raspberrypi2|raspberrypi3)
70 LAYERSCONF="bblayers.conf.rpi.sample" 70 LAYERSCONF="bblayers.conf.rpi.sample"
71 ;; 71 ;;
72 nuc) 72 intel-corei7-64)
73 LAYERSCONF="bblayers.conf.nuc.sample" 73 LAYERSCONF="bblayers.conf.intel.sample"
74 ;; 74 ;;
75 nvidia-logan|tegra-x1|tegra-t18x) 75 nvidia-logan|tegra-x1|tegra-t18x)
76 LAYERSCONF="bblayers.conf.nvidia.sample" 76 LAYERSCONF="bblayers.conf.nvidia.sample"