summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-03-16 12:39:22 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-03-16 14:27:43 +0000
commit1f8a5315f09ce8dfcab368af71c45e66caedf492 (patch)
tree4d7f58cd630846b3a71acfc13aa18ecb8acc44da
parent8f88b218cab885bdbc67db77c876fc5a7dd4e790 (diff)
downloadmeta-boot2qt-1f8a5315f09ce8dfcab368af71c45e66caedf492.tar.gz
fonts: add recipe for GNU FreeFonts
... and add FreeMono font to image. Task-number: AUTOSUITE-46 Change-Id: I22f519d09f600b6501fb7194199ad5dea831a76d Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com> Reviewed-by: Nedim Hadzic <nedim.hadzic@pelagicore.com>
-rw-r--r--recipes/fonts/ttf-freefont_20120503.bb49
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-freefont_20120503.bb b/recipes/fonts/ttf-freefont_20120503.bb
new file mode 100644
index 0000000..abf9562
--- /dev/null
+++ b/recipes/fonts/ttf-freefont_20120503.bb
@@ -0,0 +1,49 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "GNU FreeFont is a free family of scalable outline fonts"
31HOMEPAGE = "http://savannah.gnu.org/projects/freefont"
32LICENSE = "GPLv3"
33LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
34
35require recipes-graphics/ttf-fonts/ttf.inc
36
37inherit allarch fontcache
38
39S = "${WORKDIR}/freefont-${PV}"
40
41SRC_URI = "http://ftp.gnu.org/gnu/freefont/freefont-ttf-${PV}.zip"
42
43SRC_URI[md5sum] = "879b76d2e3c8003d567b555743f39154"
44SRC_URI[sha256sum] = "7c85baf1bf82a1a1845d1322112bc6ca982221b484e3b3925022e25b5cae89af"
45
46PACKAGES = "${PN}-sans ${PN}-mono ${PN}-serif"
47FILES_${PN}-sans = "${datadir}/fonts/truetype/FreeSans*.ttf"
48FILES_${PN}-mono = "${datadir}/fonts/truetype/FreeMono*.ttf"
49FILES_${PN}-serif = "${datadir}/fonts/truetype/FreeSerif*.ttf"
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 0309991..ecf77fc 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -44,6 +44,7 @@ RDEPENDS_${PN} = "\
44 ttf-opensans \ 44 ttf-opensans \
45 ttf-dejavu-common \ 45 ttf-dejavu-common \
46 ttf-dejavu-sans \ 46 ttf-dejavu-sans \
47 ttf-freefont-mono \
47 otf-noto \ 48 otf-noto \
48 dbus-session-init \ 49 dbus-session-init \
49 tzdata \ 50 tzdata \