summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-25 16:42:31 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-10-27 13:15:24 +0000
commit17bb365744a233dba7483be2c86b34a8c17f125a (patch)
treec0de8a1a21c99e3457ee6fa9333c529ad37b54d5
parent1abbc2925f8a43e52c6cb3071e1cdb9353c83071 (diff)
downloadmeta-boot2qt-17bb365744a233dba7483be2c86b34a8c17f125a.tar.gz
AM: update revision
Use qt5-module to get all files (mkspecs, examples) in correct sub-packages. Change-Id: I41b98c74c2764d45a08ab064c17d507eb1029f79 Reviewed-by: Risto Avila <risto.avila@qt.io>
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index 7aed616..d63526a 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -31,19 +31,17 @@ DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" 31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1"
33 33
34inherit qmake5 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37SRCREV = "39230c74667a70b66b19c541ae0ba4d0d9620ed0" 37SRCREV = "977c2d96b5114273b49b5dba5dcaf99bba7595d7"
38 38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
41RDEPENDS_${PN} = "libcrypto" 41RDEPENDS_${PN} = "libcrypto ${PN}-tools"
42 42
43EXTRA_QMAKEVARS_PRE += "\ 43EXTRA_QMAKEVARS_PRE += "\
44 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ 44 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
45 -config enable-dummydata \
46 -config enable-ivi-logging \
47 -config install-prefix=/usr \ 45 -config install-prefix=/usr \
48 -config systemd-workaround \ 46 -config systemd-workaround \
49 -config hardware-id=neptune \ 47 -config hardware-id=neptune \
@@ -56,7 +54,5 @@ do_install_append() {
56 54
57FILES_${PN} += "\ 55FILES_${PN} += "\
58 /opt/am \ 56 /opt/am \
59 ${libdir}/appman \ 57 ${datadir}/dbus-1 \
60 ${datadir}/dbus-1" 58 "
61FILES_${PN}-dbg += "${libdir}/appman/.debug"
62FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/*.prl"