summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-30 13:19:46 +0300
committerJędrzej Nowacki <jedrzej.nowacki@theqtcompany.com>2016-10-03 07:54:00 +0000
commit173cf50e88d53f9cf81c0ac5f2f186834ca3b81f (patch)
tree3e7c26898919b99cadf17694edddf93bb2967047
parent4d21fb7260721f5bb176d718ee08af74b46b6cf9 (diff)
downloadmeta-boot2qt-173cf50e88d53f9cf81c0ac5f2f186834ca3b81f.tar.gz
systemd: patch no longer needed
Change-Id: I49ee9f857992ae0e42394e356138e6cc06591914 Reviewed-by: Gatis Paeglis <gatis.paeglis@qt.io>
-rw-r--r--recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch27
-rw-r--r--recipes/systemd/systemd_%.bbappend9
2 files changed, 0 insertions, 36 deletions
diff --git a/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch b/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
deleted file mode 100644
index ed58b50..0000000
--- a/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From 6a7105e23d8be76094b90d814eab9135e2cc4b8a Mon Sep 17 00:00:00 2001
2From: Gatis Paeglis <gatis.paeglis@qt.io>
3Date: Tue, 21 Jun 2016 15:26:47 +0200
4Subject: [PATCH] Revert "core/mount: add dependencies to dynamically mounted
5 mounts too"
6
7This reverts commit 06e97888883e2cc12eb6514e80c7f0014295f59b.
8---
9 src/core/mount.c | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/core/mount.c b/src/core/mount.c
13index fda4d65..3944232 100644
14--- a/src/core/mount.c
15+++ b/src/core/mount.c
16@@ -337,7 +337,7 @@ static int mount_add_device_links(Mount *m) {
17
18 assert(m);
19
20- p = get_mount_parameters(m);
21+ p = get_mount_parameters_fragment(m);
22 if (!p)
23 return 0;
24
25--
262.7.4
27
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend
index 4dce1b2..1ba27fe 100644
--- a/recipes/systemd/systemd_%.bbappend
+++ b/recipes/systemd/systemd_%.bbappend
@@ -29,7 +29,6 @@
29 29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += " \ 31SRC_URI += " \
32 file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch \
33 file://usb-rndis.network \ 32 file://usb-rndis.network \
34" 33"
35 34
@@ -42,11 +41,3 @@ do_install_append() {
42 install -d ${D}${prefix}/lib/systemd/network/ 41 install -d ${D}${prefix}/lib/systemd/network/
43 install -m 0644 ${WORKDIR}/usb-rndis.network ${D}${prefix}/lib/systemd/network/ 42 install -m 0644 ${WORKDIR}/usb-rndis.network ${D}${prefix}/lib/systemd/network/
44} 43}
45
46do_verify_patch_required() {
47 if [ -n "$(cat ${S}/NEWS | grep "CHANGES WITH 229")" ]; then
48 bbwarn "systemd: The 0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch patch is not required anymore."
49 fi
50}
51
52addtask do_verify_patch_required after do_fetch before do_configure