summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-02-28 11:10:51 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-02-28 10:30:37 +0000
commit09f8c75cfeb0ea6d6b77dbd25cfbf779aa395b45 (patch)
tree2aa293ff56c2e9d303b2d5fc277b0a963f5ad130
parent0605ccb7bab4c787c68a623717e0eef7ebd7d26d (diff)
downloadmeta-boot2qt-09f8c75cfeb0ea6d6b77dbd25cfbf779aa395b45.tar.gz
Update automotive components
Use latest version of QtWayland from 5.8 branch, which is needed for qtapplicationmanager to work correctly. Change Drive CX to use basic rendering loop. Change-Id: If74255e982a676f1c556f2ef25975b675a484e05 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb7
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb2
-rw-r--r--recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bbappend30
4 files changed, 33 insertions, 8 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
index 7397c11..11b81db 100644
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -36,23 +36,18 @@ require recipes-qt/qt5/qt5-git.inc
36 36
37QT_GIT = "git://github.com/qtproject" 37QT_GIT = "git://github.com/qtproject"
38QT_MODULE = "qt-apps-neptune-ui" 38QT_MODULE = "qt-apps-neptune-ui"
39QT_MODULE_BRANCH = "master"
40 39
41SRC_URI += " \ 40SRC_URI += " \
42 file://neptune.service \ 41 file://neptune.service \
43 " 42 "
44 43
45SRCREV = "fd18dcbb9f53eb3948da890704530007327c476f" 44SRCREV = "7d865406d6ccc538f9fd658a0d2b557e115d6919"
46 45
47DEPENDS = "qtbase qtdeclarative" 46DEPENDS = "qtbase qtdeclarative"
48RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ 47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
49 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ 48 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \
50 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" 49 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
51 50
52do_configure_prepend() {
53 echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro
54}
55
56do_install_append() { 51do_install_append() {
57 install -m 0755 -d ${D}${systemd_unitdir}/system 52 install -m 0755 -d ${D}${systemd_unitdir}/system
58 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ 53 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index c4f1eb4..98d0042 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,7 +34,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=43a31c6abffdd61c938811959b3c1b71"
34inherit qt5-module 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37SRCREV = "74d8bb0c8590dec7d6106781b1aa460756425d8f" 37SRCREV = "23a0e5a929b5b03f91ae532a765e2b7a543c3a99"
38 38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
diff --git a/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf b/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf
index 64226cb..7236378 100644
--- a/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf
+++ b/recipes-qt/b2qt-addons/b2qt-appcontroller/tegra-t18x/appcontroller.conf
@@ -3,5 +3,5 @@ env=QT_IM_MODULE=qtvirtualkeyboard
3env=QT_QPA_EGLFS_FORCE888=0 3env=QT_QPA_EGLFS_FORCE888=0
4env=QT_QUICK_CONTROLS_STYLE=Flat 4env=QT_QUICK_CONTROLS_STYLE=Flat
5env=XDG_RUNTIME_DIR=/tmp 5env=XDG_RUNTIME_DIR=/tmp
6env=QSG_RENDER_LOOP=windows 6env=QSG_RENDER_LOOP=basic
7base=linux 7base=linux
diff --git a/recipes-qt/qt5/qtwayland_git.bbappend b/recipes-qt/qt5/qtwayland_git.bbappend
new file mode 100644
index 0000000..7ef6ed9
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland_git.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SRCREV = "7d527c1914710a511c06713bbda1572b767cea34"