summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-02 12:46:16 +0300
committerKalle Viironen <kalle.viironen@theqtcompany.com>2016-11-21 08:20:59 +0000
commitcbb9502193d49293e7cac62370d3649cdba9ba62 (patch)
treedb9d57cf236559b2e3a05b980589dfc32a155be6
parent8e102951ebcbdb8017226830e33a9354cf85b97e (diff)
downloadmeta-boot2qt-cbb9502193d49293e7cac62370d3649cdba9ba62.tar.gz
beaglebone: start qtlauncher only after /dev/fb0 exists
Beaglebone creates /dev/fb0 late in the boot process, which causes Qt applications to crash if started too early. Make systemd notice fb0 creation and bind application startup to it. (cherry picked from commit 300a9420bce2bcf4e0fffe30dae5cb0504e2cadb) Change-Id: I8875334407c5a01bd6597e2c4fc1af96e396c639 Reviewed-by: Kalle Viironen <kalle.viironen@theqtcompany.com>
-rw-r--r--meta-ti-extras/recipes/libgles/libgles-omap3/99-fb.rules1
-rw-r--r--meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb5
-rw-r--r--recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/b2qt.service11
-rw-r--r--recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/qtlauncher.service11
4 files changed, 28 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3/99-fb.rules b/meta-ti-extras/recipes/libgles/libgles-omap3/99-fb.rules
new file mode 100644
index 0000000..ca5ebc8
--- /dev/null
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3/99-fb.rules
@@ -0,0 +1 @@
KERNEL=="fb0", TAG+="systemd"
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb b/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
index 1b1bf22..fe484f5 100644
--- a/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
@@ -38,6 +38,7 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gf
38 file://cputype \ 38 file://cputype \
39 file://rc.pvr \ 39 file://rc.pvr \
40 file://99-bufferclass.rules \ 40 file://99-bufferclass.rules \
41 file://99-fb.rules \
41" 42"
42 43
43SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" 44SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}"
@@ -53,3 +54,7 @@ do_configure_append() {
53 sed -i -e s:\$\(PLAT_CC\):\$\(CC\):g $mak 54 sed -i -e s:\$\(PLAT_CC\):\$\(CC\):g $mak
54 done 55 done
55} 56}
57
58do_install_append() {
59 install -m 0644 ${WORKDIR}/99-fb.rules ${D}${sysconfdir}/udev/rules.d/
60}
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/b2qt.service b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/b2qt.service
new file mode 100644
index 0000000..cdf6480
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/b2qt.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=B2Qt user application
3BindsTo=dev-fb0.device
4After=dev-fb0.device
5ConditionPathExists=/usr/bin/b2qt
6
7[Service]
8ExecStart=-/usr/bin/appcontroller /usr/bin/b2qt
9
10[Install]
11WantedBy=multi-user.target
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/qtlauncher.service b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/qtlauncher.service
new file mode 100644
index 0000000..1094675
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-launcher/beaglebone/qtlauncher.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=B2Qt Launcher Demo
3BindsTo=dev-fb0.device
4After=dev-fb0.device
5ConditionPathExists=!/usr/bin/b2qt
6
7[Service]
8ExecStart=-/usr/bin/appcontroller /usr/bin/qtlauncher --applications-root /data/user/qt
9
10[Install]
11WantedBy=multi-user.target