summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2016-09-23 09:52:06 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2016-09-23 09:06:04 +0000
commit92c92eec83fd8c68de419decbe7743b0791dc38c (patch)
tree261529015016aea2fc9f9f870d27e2bbde18bcb9
parent2b115238356e2cfa963f004cb8469533d4d21305 (diff)
downloadmeta-boot2qt-92c92eec83fd8c68de419decbe7743b0791dc38c.tar.gz
Add connman patch to disable connman with boot over nfs
A workaround to avoid connman to bring the boot interface down then up during network boot. Task-number: QTBUG-56051 Change-Id: Ic22fac9cd7e9892439fb462f08313cda4d9da9aa Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes/connman/connman_%.bbappend24
-rw-r--r--recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch21
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/connman/connman_%.bbappend b/recipes/connman/connman_%.bbappend
new file mode 100644
index 0000000..0b03755
--- /dev/null
+++ b/recipes/connman/connman_%.bbappend
@@ -0,0 +1,24 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
23
24SRC_URI += "file://0001-disable-connman-when-booting-over-nfs.patch"
diff --git a/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch
new file mode 100644
index 0000000..d45ce18
--- /dev/null
+++ b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch
@@ -0,0 +1,21 @@
1From a934f6b3ef4c4ff5f36a79d11c9eed59b3ffa9ae Mon Sep 17 00:00:00 2001
2From: Mikko Gronoff <mikko.gronoff@qt.io>
3Date: Tue, 20 Sep 2016 11:02:50 +0300
4Subject: [PATCH] Disable connman when booting over NFS
5
6---
7 src/connman.service.in | 1 +
8 1 file changed, 1 insertion(+)
9
10diff --git a/src/connman.service.in b/src/connman.service.in
11index 7b6195e..3fc197a 100644
12--- a/src/connman.service.in
13+++ b/src/connman.service.in
14@@ -3,6 +3,7 @@ Description=Connection service
15 Requires=dbus.socket
16 After=dbus.socket
17 Before=remote-fs.target
18+ConditionKernelCommandLine=!root=/dev/nfs
19
20 [Service]
21 Type=dbus