summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-09-30 10:09:57 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-10-01 11:12:33 +0000
commit87a7f6539f6bd00087f6aaf3a2514054069bbd87 (patch)
tree8e177e869c3d901a88c1b2228b62ebc034338d98
parent7faffd0a1f4800c50547c1aefddeb5db006b267f (diff)
downloadmeta-boot2qt-87a7f6539f6bd00087f6aaf3a2514054069bbd87.tar.gz
gstreamer: default to gstreamer 1.0
Fix QA error with gstreamer plugins: ERROR: QA Issue: gstreamer1.0-plugins-ugly: Files/directories were installed but not shipped Emulator does not actually provide opengl, so remove it from DISTRO_FEATURES. gstreamer1.0-plugins-bad build would otherwise fail. Change-Id: I88e157f29ab1a29055fcbd4d2cd7850ca43efead Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com> Reviewed-by: Laszlo Agocs <laszlo.agocs@theqtcompany.com>
-rw-r--r--conf/distro/b2qt.conf4
-rw-r--r--conf/distro/include/emulator.conf2
-rw-r--r--recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend1
3 files changed, 4 insertions, 3 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index 5e38e3c..f31a9d7 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -41,8 +41,8 @@ DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost
41POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch" 41POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch"
42DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio" 42DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio"
43 43
44# use GStreamer 0.10, optionally change to "gstreamer" to use GStreamer 1.0 44# use GStreamer 1.0, optionally change to "gstreamer010" to use GStreamer 0.10
45DISTRO_FEATURES += "gstreamer010" 45DISTRO_FEATURES += "gstreamer"
46 46
47PREFERRED_PROVIDER_jpeg ?= "libjpeg-turbo" 47PREFERRED_PROVIDER_jpeg ?= "libjpeg-turbo"
48PREFERRED_PROVIDER_jpeg-native ?= "libjpeg-turbo-native" 48PREFERRED_PROVIDER_jpeg-native ?= "libjpeg-turbo-native"
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf
index 0457756..28be593 100644
--- a/conf/distro/include/emulator.conf
+++ b/conf/distro/include/emulator.conf
@@ -34,7 +34,7 @@ PREFERRED_PROVIDER_virtual/libgles2 = "qtglesstream-dummy-client"
34 34
35KERNEL_MODULE_AUTOLOAD += "snd-intel8x0 vboxguest" 35KERNEL_MODULE_AUTOLOAD += "snd-intel8x0 vboxguest"
36 36
37DISTRO_FEATURES_remove = "webengine" 37DISTRO_FEATURES_remove = "webengine opengl"
38 38
39MACHINE_EXTRA_INSTALL = "\ 39MACHINE_EXTRA_INSTALL = "\
40 mount-vboxsf \ 40 mount-vboxsf \
diff --git a/recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend b/recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
index eee313b..cff6298 100644
--- a/recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
+++ b/recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
@@ -1 +1,2 @@
1PACKAGECONFIG_append = " x264" 1PACKAGECONFIG_append = " x264"
2FILES_${PN}-x264 += "${datadir}/gstreamer-1.0/presets/*.prs"