summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 13:19:11 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:32 +0300
commit2395137acb37e56a85c1b78bad86a58d9c04e54d (patch)
tree2c0fb13cd3b737607271b5bd6a14a5bdaa5108eb
parent01603689e8dd2d3c5be0f41d41b3543452903f03 (diff)
downloadmeta-boot2qt-2395137acb37e56a85c1b78bad86a58d9c04e54d.tar.gz
Move meta-beagleboard specific files to separate layer
Create new layer for recipes and files that required only when meta-beagleboard layer is used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: I5e50067b8b6c7d480d3808a24e8acc2ace07b04b Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
-rw-r--r--conf/bblayers.conf.sample1
-rw-r--r--meta-beagleboard-extras/conf/layer.conf33
-rwxr-xr-xmeta-beagleboard-extras/recipes/linux/linux-mainline/0001-AM335x-Adding-SGX-DT-node.patch (renamed from recipes/linux/linux-mainline/0001-AM335x-Adding-SGX-DT-node.patch)0
-rwxr-xr-xmeta-beagleboard-extras/recipes/linux/linux-mainline/0002-AM33XX-Invoke-hwmod-deassert-for-SGX-graphics-device.patch (renamed from recipes/linux/linux-mainline/0002-AM33XX-Invoke-hwmod-deassert-for-SGX-graphics-device.patch)0
-rwxr-xr-xmeta-beagleboard-extras/recipes/linux/linux-mainline/0003-video-da8xx-fb-Add-API-to-register-wait-for-vsync-ca.patch (renamed from recipes/linux/linux-mainline/0003-video-da8xx-fb-Add-API-to-register-wait-for-vsync-ca.patch)0
-rw-r--r--meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend (renamed from recipes/linux/linux-mainline_3.8.bbappend)0
-rw-r--r--meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script.bb (renamed from recipes/u-boot/u-boot-uenv-script.bb)0
-rw-r--r--meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt (renamed from recipes/u-boot/u-boot-uenv-script/uEnv.txt)0
8 files changed, 34 insertions, 0 deletions
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index 9d5c3e5..2a6e8aa 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -40,6 +40,7 @@ BBLAYERS ?= " \
40 ##COREBASE##/meta-b2qt \ 40 ##COREBASE##/meta-b2qt \
41 ##COREBASE##/meta-b2qt/meta-ti-extras \ 41 ##COREBASE##/meta-b2qt/meta-ti-extras \
42 ##COREBASE##/meta-b2qt/meta-fsl-extras \ 42 ##COREBASE##/meta-b2qt/meta-fsl-extras \
43 ##COREBASE##/meta-b2qt/meta-beagleboard-extras \
43 " 44 "
44BBLAYERS_NON_REMOVABLE ?= " \ 45BBLAYERS_NON_REMOVABLE ?= " \
45 ##COREBASE##/meta \ 46 ##COREBASE##/meta \
diff --git a/meta-beagleboard-extras/conf/layer.conf b/meta-beagleboard-extras/conf/layer.conf
new file mode 100644
index 0000000..9cdf5ac
--- /dev/null
+++ b/meta-beagleboard-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29 "
30
31BBFILE_COLLECTIONS += "b2qt_bb"
32BBFILE_PATTERN_b2qt_bb := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_bb = "20"
diff --git a/recipes/linux/linux-mainline/0001-AM335x-Adding-SGX-DT-node.patch b/meta-beagleboard-extras/recipes/linux/linux-mainline/0001-AM335x-Adding-SGX-DT-node.patch
index 97ce000..97ce000 100755
--- a/recipes/linux/linux-mainline/0001-AM335x-Adding-SGX-DT-node.patch
+++ b/meta-beagleboard-extras/recipes/linux/linux-mainline/0001-AM335x-Adding-SGX-DT-node.patch
diff --git a/recipes/linux/linux-mainline/0002-AM33XX-Invoke-hwmod-deassert-for-SGX-graphics-device.patch b/meta-beagleboard-extras/recipes/linux/linux-mainline/0002-AM33XX-Invoke-hwmod-deassert-for-SGX-graphics-device.patch
index 05672d3..05672d3 100755
--- a/recipes/linux/linux-mainline/0002-AM33XX-Invoke-hwmod-deassert-for-SGX-graphics-device.patch
+++ b/meta-beagleboard-extras/recipes/linux/linux-mainline/0002-AM33XX-Invoke-hwmod-deassert-for-SGX-graphics-device.patch
diff --git a/recipes/linux/linux-mainline/0003-video-da8xx-fb-Add-API-to-register-wait-for-vsync-ca.patch b/meta-beagleboard-extras/recipes/linux/linux-mainline/0003-video-da8xx-fb-Add-API-to-register-wait-for-vsync-ca.patch
index c425982..c425982 100755
--- a/recipes/linux/linux-mainline/0003-video-da8xx-fb-Add-API-to-register-wait-for-vsync-ca.patch
+++ b/meta-beagleboard-extras/recipes/linux/linux-mainline/0003-video-da8xx-fb-Add-API-to-register-wait-for-vsync-ca.patch
diff --git a/recipes/linux/linux-mainline_3.8.bbappend b/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend
index e5518bc..e5518bc 100644
--- a/recipes/linux/linux-mainline_3.8.bbappend
+++ b/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend
diff --git a/recipes/u-boot/u-boot-uenv-script.bb b/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script.bb
index b15dd1f..b15dd1f 100644
--- a/recipes/u-boot/u-boot-uenv-script.bb
+++ b/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script.bb
diff --git a/recipes/u-boot/u-boot-uenv-script/uEnv.txt b/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt
index 6b23df1..6b23df1 100644
--- a/recipes/u-boot/u-boot-uenv-script/uEnv.txt
+++ b/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt