summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKalle Viironen <kalle.viironen@digia.com>2014-04-16 09:38:57 +0300
committerKalle Viironen <kalle.viironen@digia.com>2014-04-16 09:39:12 +0300
commitfa7c1238796da94fff794d865e501622301a5d85 (patch)
tree534bfaffc99f288f395297c625e284fea6e50401
parent06cd4b1567b7ad8b2b47b88bcc1f6f567ec53075 (diff)
parent03be9b83d45659d0d98fa1bf69853e0aa297ed32 (diff)
downloadmeta-boot2qt-fa7c1238796da94fff794d865e501622301a5d85.tar.gz
Merge branch 'stable' into dev
* stable: wpa-supplicant: include headers and sources for external usage bootfs: need to use fakeroot for tar'ing sdk: include bluez4-dev package to sdk Create boot.tar.gz as part of the image build image: include CA certificates to image adbd: use network connection in imx53qsb sdk: libcap is required for QtWebEngine Include licenses to the image adbd: make switching between usb and ethernet easier use package groups for image content Create only tar.gz image type Change from dylan to dora brach in README mkcard: remove recipe for mkcard Change-Id: Id3b36dc2f8e28c6e6932014d52f49c3e44f2a7f8
-rw-r--r--README12
-rw-r--r--classes/bootfs-image.bbclass51
-rw-r--r--conf/distro/b2qt.conf4
-rw-r--r--conf/distro/include/am335x-evm.conf6
-rw-r--r--conf/distro/include/beagleboard.conf14
-rw-r--r--conf/distro/include/beaglebone.conf9
-rw-r--r--conf/distro/include/imx53qsb.conf6
-rw-r--r--conf/distro/include/nitrogen6x.conf12
-rw-r--r--conf/distro/include/raspberrypi.conf8
-rw-r--r--recipes/adbd/adbd.bb6
-rwxr-xr-xrecipes/adbd/files/adb-init26
-rw-r--r--recipes/adbd/files/defaults4
-rwxr-xr-xrecipes/adbd/files/emulator/adb-init21
-rw-r--r--recipes/adbd/files/emulator/defaults4
-rw-r--r--recipes/adbd/files/imx53qsb/defaults4
-rw-r--r--recipes/adbd/files/raspberrypi/adb-init21
-rw-r--r--recipes/adbd/files/raspberrypi/defaults4
-rw-r--r--recipes/images/b2qt-embedded-image.bb51
-rwxr-xr-xrecipes/mkcard/files/mkcard.sh62
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb1
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb3
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb49
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb42
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb (renamed from recipes/mkcard/mkcard_0.5.bb)21
-rw-r--r--recipes/u-boot/u-boot-uenv-script.bb49
-rw-r--r--recipes/u-boot/u-boot-uenv-script/uEnv.txt3
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend18
27 files changed, 317 insertions, 194 deletions
diff --git a/README b/README
index ea8d774..a2aa884 100644
--- a/README
+++ b/README
@@ -29,26 +29,26 @@ OpenEmbedded and Yocto.
29This layer depends on: 29This layer depends on:
30 30
31URI: git://git.openembedded.org/openembedded-core 31URI: git://git.openembedded.org/openembedded-core
32branch: dylan 32branch: dora
33revision: HEAD 33revision: HEAD
34 34
35URI: git://git.openembedded.org/meta-openembedded 35URI: git://git.openembedded.org/meta-openembedded
36layer: meta-oe 36layer: meta-oe
37branch: dylan 37branch: dora
38revision: HEAD 38revision: HEAD
39 39
40URI: git://git.yoctoproject.org/meta-ti 40URI: git://git.yoctoproject.org/meta-ti
41branch: dylan 41branch: dora
42revision: HEAD 42revision: HEAD
43 43
44URI: git://git.yoctoproject.org/meta-fsl-arm 44URI: git://git.yoctoproject.org/meta-fsl-arm
45branch: dylan 45branch: dora
46revision: HEAD 46revision: HEAD
47 47
48URI: git://github.com/Freescale/meta-fsl-arm-extra.git 48URI: git://github.com/Freescale/meta-fsl-arm-extra.git
49branch: dylan 49branch: dora
50revision: HEAD 50revision: HEAD
51 51
52URI: git://git.yoctoproject.org/meta-raspberrypi 52URI: git://git.yoctoproject.org/meta-raspberrypi
53branch: dylan 53branch: dora
54revision: HEAD 54revision: HEAD
diff --git a/classes/bootfs-image.bbclass b/classes/bootfs-image.bbclass
new file mode 100644
index 0000000..5292965
--- /dev/null
+++ b/classes/bootfs-image.bbclass
@@ -0,0 +1,51 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23BOOTFS_NAME = "${IMAGE_BASENAME}-boot-${MACHINE}-${DATETIME}"
24BOOTFS_LINK_NAME = "${IMAGE_BASENAME}-boot-${MACHINE}"
25
26BOOTFS_DEPENDS ?= ""
27
28fakeroot do_bootfs () {
29 if [ -n ${BOOTFS_CONTENT} ]; then
30 exit 0
31 fi
32
33 mkdir -p ${S}/bootfs
34
35 for item in ${BOOTFS_CONTENT}; do
36 src=`echo $item | awk -F':' '{ print $1 }'`
37 dst=`echo $item | awk -F':' '{ print $2 }'`
38
39 install -m 0755 ${DEPLOY_DIR_IMAGE}/$src ${S}/bootfs/$dst
40 done
41
42 cd ${S}/bootfs
43 rm -f ${DEPLOY_DIR_IMAGE}/${BOOTFS_NAME}.tar.gz ${DEPLOY_DIR_IMAGE}/${BOOTFS_LINK_NAME}.tar.gz
44
45 tar czvf ${DEPLOY_DIR_IMAGE}/${BOOTFS_NAME}.tar.gz .
46 ln -s ${BOOTFS_NAME}.tar.gz ${DEPLOY_DIR_IMAGE}/${BOOTFS_LINK_NAME}.tar.gz
47}
48
49addtask bootfs before do_rootfs
50
51do_bootfs[depends] += "${BOOTFS_DEPENDS}"
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index cde0b02..66ddcf1 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -46,3 +46,7 @@ DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio"
46COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse" 46COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse"
47COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse" 47COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse"
48 48
49MACHINE_EXTRA_INSTALL ?= ""
50
51LICENSE_CREATE_PACKAGE = "1"
52COPY_LIC_MANIFEST = "1"
diff --git a/conf/distro/include/am335x-evm.conf b/conf/distro/include/am335x-evm.conf
index 5799db7..6772a2a 100644
--- a/conf/distro/include/am335x-evm.conf
+++ b/conf/distro/include/am335x-evm.conf
@@ -22,6 +22,12 @@
22 22
23IMAGE_FSTYPES = "tar.gz" 23IMAGE_FSTYPES = "tar.gz"
24 24
25BOOTFS_CONTENT = "\
26 u-boot-${MACHINE}.img:u-boot.img \
27 MLO-${MACHINE}:MLO \
28 "
29BOOTFS_DEPENDS = "u-boot:do_deploy"
30
25PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" 31PREFERRED_VERSION_libgles-omap3 = "4.09.00.01"
26PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" 32PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01"
27 33
diff --git a/conf/distro/include/beagleboard.conf b/conf/distro/include/beagleboard.conf
index dab0c5a..dab9c68 100644
--- a/conf/distro/include/beagleboard.conf
+++ b/conf/distro/include/beagleboard.conf
@@ -20,15 +20,13 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23IMAGE_CLASSES += "image_types_sdcard" 23IMAGE_FSTYPES = "tar.gz"
24IMAGE_FSTYPES = "tar.gz ext3 sdcard"
25 24
26BOOT_SCRIPTS = "\ 25BOOTFS_CONTENT = "\
27 u-boot-${MACHINE}.img:u-boot.img \ 26 u-boot-${MACHINE}.img:u-boot.img \
28 MLO-${MACHINE}:MLO \ 27 MLO-${MACHINE}:MLO \
29 " 28 "
30SDCARD_GENERATION_COMMAND = "generate_imx_sdcard" 29BOOTFS_DEPENDS = "u-boot:do_deploy"
31UBOOT_SUFFIX = "img"
32 30
33PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" 31PREFERRED_VERSION_libgles-omap3 = "4.09.00.01"
34PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" 32PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01"
diff --git a/conf/distro/include/beaglebone.conf b/conf/distro/include/beaglebone.conf
index ba13aaa..376e3c6 100644
--- a/conf/distro/include/beaglebone.conf
+++ b/conf/distro/include/beaglebone.conf
@@ -17,6 +17,15 @@
17############################################################################ 17############################################################################
18IMAGE_FSTYPES = "tar.gz" 18IMAGE_FSTYPES = "tar.gz"
19 19
20BOOTFS_CONTENT = "\
21 u-boot-${MACHINE}.img:u-boot.img \
22 MLO-${MACHINE}:MLO \
23 uEnv-${MACHINE}.txt:uEnv.txt \
24 "
25BOOTFS_DEPENDS = "u-boot:do_deploy u-boot-uenv-script:do_deploy"
26
27EXTRA_IMAGEDEPENDS += "u-boot-uenv-script"
28
20PREFERRED_VERSION_libgles-omap3 = "5.01.00.01" 29PREFERRED_VERSION_libgles-omap3 = "5.01.00.01"
21PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01" 30PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01"
22 31
diff --git a/conf/distro/include/imx53qsb.conf b/conf/distro/include/imx53qsb.conf
index d83f6b4..a7099a5 100644
--- a/conf/distro/include/imx53qsb.conf
+++ b/conf/distro/include/imx53qsb.conf
@@ -22,6 +22,12 @@
22 22
23IMAGE_FSTYPES = "tar.gz" 23IMAGE_FSTYPES = "tar.gz"
24 24
25BOOTFS_CONTENT = "\
26 u-boot-${MACHINE}.${UBOOT_SUFFIX}:u-boot.${UBOOT_SUFFIX} \
27 ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
28 "
29BOOTFS_DEPENDS = "u-boot:do_deploy"
30
25MACHINE_EXTRA_INSTALL = "\ 31MACHINE_EXTRA_INSTALL = "\
26 amd-gpu-bin-mx51 \ 32 amd-gpu-bin-mx51 \
27 " 33 "
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf
index b761ddd..2a64026 100644
--- a/conf/distro/include/nitrogen6x.conf
+++ b/conf/distro/include/nitrogen6x.conf
@@ -20,10 +20,16 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23IMAGE_CLASSES += "image_types_sdcard" 23IMAGE_FSTYPES = "tar.gz"
24IMAGE_FSTYPES = "tar.gz ext3 sdcard"
25 24
26BOOT_SCRIPTS = "6x_bootscript-${MACHINE}:6x_bootscript" 25BOOTFS_CONTENT = "\
26 ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
27 6x_bootscript-${MACHINE}:6x_bootscript \
28 6x_upgrade-${MACHINE}:6x_upgrade \
29 "
30BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy u-boot-script-boundary:do_deploy"
31
32EXTRA_IMAGEDEPENDS += "u-boot-script-boundary"
27 33
28MACHINE_EXTRA_INSTALL = "\ 34MACHINE_EXTRA_INSTALL = "\
29 libgal-mx6 \ 35 libgal-mx6 \
diff --git a/conf/distro/include/raspberrypi.conf b/conf/distro/include/raspberrypi.conf
index 97513a8..61cebb4 100644
--- a/conf/distro/include/raspberrypi.conf
+++ b/conf/distro/include/raspberrypi.conf
@@ -20,7 +20,13 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23IMAGE_FSTYPES = "tar.gz ext3 rpi-sdimg" 23IMAGE_FSTYPES = "tar.gz"
24
25BOOTFS_CONTENT = "\
26 bcm2835-bootfiles/*: \
27 ${KERNEL_IMAGETYPE}:kernel.img \
28 "
29BOOTFS_DEPENDS = "bcm2835-bootfiles:do_deploy virtual/kernel:do_deploy"
24 30
25PREFERRED_PROVIDER_virtual/libgles1 = "userland" 31PREFERRED_PROVIDER_virtual/libgles1 = "userland"
26 32
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
index 1feb7c3..9e3ed67 100644
--- a/recipes/adbd/adbd.bb
+++ b/recipes/adbd/adbd.bb
@@ -36,6 +36,7 @@ SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https \
36 file://adbd.patch;striplevel=2 \ 36 file://adbd.patch;striplevel=2 \
37 file://Makefile.adbd \ 37 file://Makefile.adbd \
38 file://adb-init \ 38 file://adb-init \
39 file://defaults \
39 " 40 "
40 41
41S = "${WORKDIR}/git/adb" 42S = "${WORKDIR}/git/adb"
@@ -44,7 +45,7 @@ FILES_${PN} += "${bindir}/adbd"
44 45
45do_configure() { 46do_configure() {
46 if [ -n "${ADB_PRODUCTID}" ]; then 47 if [ -n "${ADB_PRODUCTID}" ]; then
47 sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/adb-init 48 sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/defaults
48 fi 49 fi
49} 50}
50 51
@@ -58,6 +59,9 @@ do_install() {
58 59
59 install -m 0755 -d ${D}${sysconfdir}/init.d 60 install -m 0755 -d ${D}${sysconfdir}/init.d
60 install -m 0755 ${WORKDIR}/adb-init ${D}${sysconfdir}/init.d/ 61 install -m 0755 ${WORKDIR}/adb-init ${D}${sysconfdir}/init.d/
62
63 install -m 0755 -d ${D}${sysconfdir}/default
64 install -m 0755 ${WORKDIR}/defaults ${D}${sysconfdir}/default/adbd
61} 65}
62 66
63INITSCRIPT_NAME = "adb-init" 67INITSCRIPT_NAME = "adb-init"
diff --git a/recipes/adbd/files/adb-init b/recipes/adbd/files/adb-init
index 6faed60..92500d7 100755
--- a/recipes/adbd/files/adb-init
+++ b/recipes/adbd/files/adb-init
@@ -2,25 +2,27 @@
2 2
3DAEMON=/usr/bin/adbd 3DAEMON=/usr/bin/adbd
4 4
5VENDOR=0x18d1 5. /etc/default/adbd
6PRODUCT=0x0000
7SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
8 6
9case "$1" in 7case "$1" in
10start) 8start)
11 modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL} 9 if [ "$USE_ETHERNET" = "no" ]; then
12 mkdir -p /dev/usb-ffs 10 modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL}
13 chmod 770 /dev/usb-ffs 11 mkdir -p /dev/usb-ffs
14 mkdir -p /dev/usb-ffs/adb 12 chmod 770 /dev/usb-ffs
15 chmod 770 /dev/usb-ffs/adb 13 mkdir -p /dev/usb-ffs/adb
16 mount -t functionfs adb /dev/usb-ffs/adb -o uid=0,gid=0 14 chmod 770 /dev/usb-ffs/adb
15 mount -t functionfs adb /dev/usb-ffs/adb -o uid=0,gid=0
16 fi
17 start-stop-daemon --start --quiet --exec $DAEMON & 17 start-stop-daemon --start --quiet --exec $DAEMON &
18 ;; 18 ;;
19stop) 19stop)
20 start-stop-daemon --stop --quiet --exec $DAEMON 20 start-stop-daemon --stop --quiet --exec $DAEMON
21 sleep 1 21 if [ "$USE_ETHERNET" = "no" ]; then
22 umount /dev/usb-ffs/adb 22 sleep 1
23 rmmod g_ffs 23 umount /dev/usb-ffs/adb
24 rmmod g_ffs
25 fi
24 ;; 26 ;;
25restart) 27restart)
26 start-stop-daemon --stop --quiet --exec $DAEMON 28 start-stop-daemon --stop --quiet --exec $DAEMON
diff --git a/recipes/adbd/files/defaults b/recipes/adbd/files/defaults
new file mode 100644
index 0000000..d2a3cc0
--- /dev/null
+++ b/recipes/adbd/files/defaults
@@ -0,0 +1,4 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=no
diff --git a/recipes/adbd/files/emulator/adb-init b/recipes/adbd/files/emulator/adb-init
deleted file mode 100755
index 8910e0e..0000000
--- a/recipes/adbd/files/emulator/adb-init
+++ /dev/null
@@ -1,21 +0,0 @@
1#!/bin/sh
2
3DAEMON=/usr/bin/adbd
4
5case "$1" in
6start)
7 start-stop-daemon --start --quiet --exec $DAEMON &
8 ;;
9stop)
10 start-stop-daemon --stop --quiet --exec $DAEMON
11 ;;
12restart)
13 start-stop-daemon --stop --quiet --exec $DAEMON
14 sleep 1
15 start-stop-daemon --start --quiet --exec $DAEMON &
16 ;;
17*)
18 echo "Usage: $0 {start|stop|restart}"
19 exit 1
20esac
21exit 0
diff --git a/recipes/adbd/files/emulator/defaults b/recipes/adbd/files/emulator/defaults
new file mode 100644
index 0000000..0fbba4c
--- /dev/null
+++ b/recipes/adbd/files/emulator/defaults
@@ -0,0 +1,4 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=yes
diff --git a/recipes/adbd/files/imx53qsb/defaults b/recipes/adbd/files/imx53qsb/defaults
new file mode 100644
index 0000000..0fbba4c
--- /dev/null
+++ b/recipes/adbd/files/imx53qsb/defaults
@@ -0,0 +1,4 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=yes
diff --git a/recipes/adbd/files/raspberrypi/adb-init b/recipes/adbd/files/raspberrypi/adb-init
deleted file mode 100644
index 8910e0e..0000000
--- a/recipes/adbd/files/raspberrypi/adb-init
+++ /dev/null
@@ -1,21 +0,0 @@
1#!/bin/sh
2
3DAEMON=/usr/bin/adbd
4
5case "$1" in
6start)
7 start-stop-daemon --start --quiet --exec $DAEMON &
8 ;;
9stop)
10 start-stop-daemon --stop --quiet --exec $DAEMON
11 ;;
12restart)
13 start-stop-daemon --stop --quiet --exec $DAEMON
14 sleep 1
15 start-stop-daemon --start --quiet --exec $DAEMON &
16 ;;
17*)
18 echo "Usage: $0 {start|stop|restart}"
19 exit 1
20esac
21exit 0
diff --git a/recipes/adbd/files/raspberrypi/defaults b/recipes/adbd/files/raspberrypi/defaults
new file mode 100644
index 0000000..0fbba4c
--- /dev/null
+++ b/recipes/adbd/files/raspberrypi/defaults
@@ -0,0 +1,4 @@
1VENDOR=0x18d1
2PRODUCT=0x0000
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
4USE_ETHERNET=yes
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb
index a9ec3bf..8daffbd 100644
--- a/recipes/images/b2qt-embedded-image.bb
+++ b/recipes/images/b2qt-embedded-image.bb
@@ -33,51 +33,10 @@ IMAGE_FEATURES += "\
33 " 33 "
34 34
35inherit core-image 35inherit core-image
36 36inherit bootfs-image
37EXTRA_IMAGEDEPENDS_mx6 += "u-boot-script-boundary"
38
39MACHINE_EXTRA_INSTALL ?= ""
40
41GSTREAMER_EXTRA_INSTALL = "\
42 gst-meta-video \
43 gst-meta-audio \
44 gst-plugins-good \
45 gst-plugins-base-app \
46 gst-plugins-good-videofilter \
47 gst-plugins-good-id3demux \
48 gst-plugins-good-auparse \
49 gst-plugins-good-isomp4 \
50 gst-plugins-ugly-rmdemux \
51 gst-plugins-ugly-asf \
52 gst-plugins-ugly-a52dec \
53 gst-ffmpeg \
54 "
55
56TOOLS_EXTRA_INSTALL = "\
57 adbd \
58 ldd \
59 binutils \
60 binutils-symlinks \
61 "
62 37
63IMAGE_INSTALL += "\ 38IMAGE_INSTALL += "\
64 kernel-modules \ 39 packagegroup-b2qt-embedded-base \
65 psplash \ 40 packagegroup-b2qt-embedded-tools \
66 openssh-sftp-server \ 41 packagegroup-b2qt-embedded-gstreamer \
67 openssl \ 42 "
68 libpng \
69 jpeg \
70 tiff \
71 libxslt \
72 icu \
73 freetype \
74 fontconfig \
75 liberation-fonts \
76 tslib \
77 tslib-calibrate \
78 alsa-utils-amixer \
79 hunspell \
80 ${GSTREAMER_EXTRA_INSTALL} \
81 ${TOOLS_EXTRA_INSTALL} \
82 ${MACHINE_EXTRA_INSTALL} \
83 "
diff --git a/recipes/mkcard/files/mkcard.sh b/recipes/mkcard/files/mkcard.sh
deleted file mode 100755
index e75a176..0000000
--- a/recipes/mkcard/files/mkcard.sh
+++ /dev/null
@@ -1,62 +0,0 @@
1#! /bin/sh
2# mkcard.sh v0.5
3# (c) Copyright 2009 Graeme Gregory <dp@xora.org.uk>
4# Licensed under terms of GPLv2
5#
6# Parts of the procudure base on the work of Denys Dmytriyenko
7# http://wiki.omap.com/index.php/MMC_Boot_Format
8
9export LC_ALL=C
10
11if [ $# -ne 1 ]; then
12 echo "Usage: $0 <drive>"
13 exit 1;
14fi
15
16DRIVE=$1
17
18dd if=/dev/zero of=$DRIVE bs=1024 count=1024
19
20SIZE=`fdisk -l $DRIVE | grep Disk | grep bytes | awk '{print $5}'`
21
22echo DISK SIZE - $SIZE bytes
23
24CYLINDERS=`echo $SIZE/255/63/512 | bc`
25
26echo CYLINDERS - $CYLINDERS
27
28{
29echo ,9,0x0C,*
30echo ,,,-
31} | sfdisk -D -H 255 -S 63 -C $CYLINDERS $DRIVE
32
33sleep 1
34
35# handle various device names.
36# note something like fdisk -l /dev/loop0 | egrep -E '^/dev' | cut -d' ' -f1
37# won't work due to https://bugzilla.redhat.com/show_bug.cgi?id=649572
38
39PARTITION1=${DRIVE}1
40if [ ! -b ${PARTITION1} ]; then
41 PARTITION1=${DRIVE}p1
42fi
43
44PARTITION2=${DRIVE}2
45if [ ! -b ${PARTITION2} ]; then
46 PARTITION2=${DRIVE}p2
47fi
48
49# now make partitions.
50if [ -b ${PARTITION1} ]; then
51 umount ${PARTITION1}
52 mkfs.vfat -F 32 -n "boot" ${PARTITION1}
53else
54 echo "Cant find boot partition in /dev"
55fi
56
57if [ -b ${PARITION2} ]; then
58 umount ${PARTITION2}
59 mke2fs -t ext3 -j -L "rootfs" ${PARTITION2}
60else
61 echo "Cant find rootfs partition in /dev"
62fi
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index f32bac4..9c92438 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -28,7 +28,6 @@ LICENSE = "CLOSED"
28require recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb 28require recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
29 29
30RDEPENDS_${PN} = "\ 30RDEPENDS_${PN} = "\
31 mkcard-nativesdk \
32 python-nativesdk \ 31 python-nativesdk \
33 python-subprocess-nativesdk \ 32 python-subprocess-nativesdk \
34 " 33 "
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
index 4cdd404..457ea56 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
@@ -47,5 +47,8 @@ RDEPENDS_${PN} += "\
47 udev-dev \ 47 udev-dev \
48 tslib-dev \ 48 tslib-dev \
49 hunspell-dev \ 49 hunspell-dev \
50 libcap-dev \
51 wpa-supplicant-dev \
52 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \
50 ${MACHINE_EXTRA_INSTALL_SDK} \ 53 ${MACHINE_EXTRA_INSTALL_SDK} \
51 " 54 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
new file mode 100644
index 0000000..0942a7e
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 kernel-modules \
31 adbd \
32 psplash \
33 openssh-sftp-server \
34 openssl \
35 libpng \
36 jpeg \
37 tiff \
38 libxslt \
39 icu \
40 freetype \
41 fontconfig \
42 liberation-fonts \
43 tslib \
44 tslib-calibrate \
45 alsa-utils-amixer \
46 hunspell \
47 ca-certificates \
48 ${MACHINE_EXTRA_INSTALL} \
49 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
new file mode 100644
index 0000000..f6a8a54
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
@@ -0,0 +1,42 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 gst-meta-video \
31 gst-meta-audio \
32 gst-plugins-good \
33 gst-plugins-base-app \
34 gst-plugins-good-videofilter \
35 gst-plugins-good-id3demux \
36 gst-plugins-good-auparse \
37 gst-plugins-good-isomp4 \
38 gst-plugins-ugly-rmdemux \
39 gst-plugins-ugly-asf \
40 gst-plugins-ugly-a52dec \
41 gst-ffmpeg \
42 "
diff --git a/recipes/mkcard/mkcard_0.5.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
index 8d71f81..61ca211 100644
--- a/recipes/mkcard/mkcard_0.5.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -20,17 +20,14 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23DESCRIPTION = "mkcard.sh v0.5" 23DESCRIPTION = "Additional tools packagegroup for B2Qt embedded Linux image"
24LICENSE = "GPLv2+" 24LICENSE = "CLOSED"
25LIC_FILES_CHKSUM = "file://${COREBASE}/bitbake/COPYING;md5=751419260aa954499f7abaabaa882bbe" 25PR = "r0"
26SECTION = "devel"
27PR = "0"
28 26
29SRC_URI = "file://mkcard.sh" 27inherit packagegroup
30 28
31do_install () { 29RDEPENDS_${PN} = "\
32 install -d ${D}${bindir}/ 30 ldd \
33 install -m 0755 ${WORKDIR}/mkcard.sh ${D}${bindir}/ 31 binutils \
34} 32 binutils-symlinks \
35 33 "
36BBCLASSEXTEND = "nativesdk"
diff --git a/recipes/u-boot/u-boot-uenv-script.bb b/recipes/u-boot/u-boot-uenv-script.bb
new file mode 100644
index 0000000..b15dd1f
--- /dev/null
+++ b/recipes/u-boot/u-boot-uenv-script.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "U-Boot script to start up BeagleBone Black"
24LICENSE = "CLOSED"
25PR = "r0"
26
27COMPATIBLE_MACHINE = "(beaglebone)"
28PV = "20140225"
29
30SRC_URI = "file://uEnv.txt"
31
32inherit deploy
33
34do_deploy () {
35 install -d ${DEPLOYDIR}
36 install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv-${MACHINE}-${PV}-${PR}.txt
37
38 cd ${DEPLOYDIR}
39 rm -f uEnv-${MACHINE}.txt
40 ln -sf uEnv-${MACHINE}-${PV}-${PR}.txt uEnv-${MACHINE}.txt
41}
42
43addtask deploy after do_install before do_build
44
45do_compile[noexec] = "1"
46do_install[noexec] = "1"
47do_populate_sysroot[noexec] = "1"
48
49PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/u-boot/u-boot-uenv-script/uEnv.txt b/recipes/u-boot/u-boot-uenv-script/uEnv.txt
new file mode 100644
index 0000000..f8385a4
--- /dev/null
+++ b/recipes/u-boot/u-boot-uenv-script/uEnv.txt
@@ -0,0 +1,3 @@
1bootfile=zImage
2optargs=consoleblank=0 vt.global_cursor_default=0
3mmcboot=echo Booting from mmc ...; run mmcargs; bootz ${kloadaddr} - ${fdtaddr}
diff --git a/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend b/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend
new file mode 100644
index 0000000..9a200b2
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -0,0 +1,18 @@
1do_install_append () {
2 install -d ${D}${includedir}/wpa-supplicant
3
4 install -m 0644 ${S}/src/common/wpa_ctrl.c ${D}${includedir}/wpa-supplicant/
5 install -m 0644 ${S}/src/common/wpa_ctrl.h ${D}${includedir}/wpa-supplicant/
6
7 install -m 0644 ${S}/src/utils/build_config.h ${D}${includedir}/wpa-supplicant/
8 install -m 0644 ${S}/src/utils/common.h ${D}${includedir}/wpa-supplicant/
9 install -m 0644 ${S}/src/utils/includes.h ${D}${includedir}/wpa-supplicant/
10 install -m 0644 ${S}/src/utils/os.h ${D}${includedir}/wpa-supplicant/
11 install -m 0644 ${S}/src/utils/os_unix.c ${D}${includedir}/wpa-supplicant/
12 install -m 0644 ${S}/src/utils/trace.h ${D}${includedir}/wpa-supplicant/
13 install -m 0644 ${S}/src/utils/wpa_debug.h ${D}${includedir}/wpa-supplicant/
14 install -m 0644 ${S}/src/utils/wpabuf.h ${D}${includedir}/wpa-supplicant/
15}
16
17FILES_${PN}-dev += "${includedir}/wpa-supplicant/*"
18