summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-06-25 08:58:39 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-06-25 13:52:03 +0300
commitb7ab4499e4daf15d3cc06e6c3032cc010c7c48aa (patch)
tree4a3592d5038bab8bf91db82b304f01e123c05026
parent965e22e4d2b339750915f0ddda7b6730fecb103a (diff)
downloadmeta-boot2qt-b7ab4499e4daf15d3cc06e6c3032cc010c7c48aa.tar.gz
beagleboard specific u-boot was removed from meta-ti
Remove bbappend for the beagleboard specific u-boot. Since beagleboard is no longer a reference device, adding u-boot changes back to the latest u-boot is left for the customers. Change-Id: I752f67bcd0b9adef499cfc5aff5ea6304e569c33 Reviewed-by: Gatis Paeglis <gatis.paeglis@digia.com>
-rw-r--r--recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-kernel-args.patch77
-rw-r--r--recipes/u-boot/u-boot-beagleboard_2011.09.bbappend26
2 files changed, 0 insertions, 103 deletions
diff --git a/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-kernel-args.patch b/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-kernel-args.patch
deleted file mode 100644
index 1dea7f5..0000000
--- a/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-kernel-args.patch
+++ /dev/null
@@ -1,77 +0,0 @@
1From 9ac6875931f5f9d073ca31cd6e1fb7636afb76bc Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Thu, 23 May 2013 14:37:10 +0300
4Subject: [PATCH] beagle: change default kernel args
5
6- default resolution to 800x600
7- increase VRAM for fb0
8- disable console blank
9- disable console cursor blinking
10- use extrabootargs
11---
12 include/configs/omap3_beagle.h | 20 ++++++++++++++++----
13 1 file changed, 16 insertions(+), 4 deletions(-)
14
15diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
16index 1cc46dc..945e15e 100644
17--- a/include/configs/omap3_beagle.h
18+++ b/include/configs/omap3_beagle.h
19@@ -224,7 +224,7 @@
20 "optargs=\0" \
21 "camera=none\0" \
22 "vram=12M\0" \
23- "dvimode=640x480MR-16@60\0" \
24+ "dvimode=800x600MR-16@60\0" \
25 "defaultdisplay=dvi\0" \
26 "mmcdev=0\0" \
27 "mmcroot=/dev/mmcblk0p2 ro\0" \
28@@ -240,20 +240,28 @@
29 "buddy2=${buddy2} "\
30 "camera=${camera} "\
31 "vram=${vram} " \
32+ "omapfb.vram=0:${vram} " \
33 "omapfb.mode=dvi:${dvimode} " \
34 "omapdss.def_disp=${defaultdisplay} " \
35 "root=${mmcroot} " \
36- "rootfstype=${mmcrootfstype}\0" \
37+ "rootfstype=${mmcrootfstype} " \
38+ "consoleblank=0 " \
39+ "vt.global_cursor_default=0 " \
40+ "${extrabootargs}\0" \
41 "nandargs=setenv bootargs console=${console} " \
42 "${optargs} " \
43 "mpurate=${mpurate} " \
44 "buddy=${buddy} "\
45 "camera=${camera} "\
46 "vram=${vram} " \
47+ "omapfb.vram=0:${vram} " \
48 "omapfb.mode=dvi:${dvimode} " \
49 "omapdss.def_disp=${defaultdisplay} " \
50 "root=${nandroot} " \
51- "rootfstype=${nandrootfstype}\0" \
52+ "rootfstype=${nandrootfstype} " \
53+ "consoleblank=0 " \
54+ "vt.global_cursor_default=0 " \
55+ "${extrabootargs}\0" \
56 "bootenv=uEnv.txt\0" \
57 "loadbootenv=fatload mmc ${mmcdev} ${loadaddr} ${bootenv}\0" \
58 "importbootenv=echo Importing environment from mmc ...; " \
59@@ -263,10 +271,14 @@
60 "mpurate=${mpurate} " \
61 "buddy=${buddy} "\
62 "vram=${vram} " \
63+ "omapfb.vram=0:${vram} " \
64 "omapfb.mode=dvi:${dvimode} " \
65 "omapdss.def_disp=${defaultdisplay} " \
66 "root=${ramroot} " \
67- "rootfstype=${ramrootfstype}\0" \
68+ "rootfstype=${ramrootfstype} " \
69+ "consoleblank=0 " \
70+ "vt.global_cursor_default=0 " \
71+ "${extrabootargs}\0" \
72 "loadramdisk=fatload mmc ${mmcdev} ${rdaddr} ramdisk.gz\0" \
73 "loaduimagefat=fatload mmc ${mmcdev} ${loadaddr} uImage\0" \
74 "loaduimage=ext2load mmc ${mmcdev}:2 ${loadaddr} /boot/uImage\0" \
75--
761.7.10.4
77
diff --git a/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend b/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
deleted file mode 100644
index f6fbde1..0000000
--- a/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += " \
25 file://0001-beagle-change-default-kernel-args.patch \
26 "