summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-06-25 08:55:43 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-06-25 13:51:58 +0300
commit965e22e4d2b339750915f0ddda7b6730fecb103a (patch)
treee9013238adf0aed675fa0d837b33a11239c0583b
parentbda5e004b96afb928ee49ff8529c1407386ba1f2 (diff)
downloadmeta-boot2qt-965e22e4d2b339750915f0ddda7b6730fecb103a.tar.gz
Old libgles-omap3 packages were removed from meta-ti
Remove bbappends for recipes that don't exists anymore, and use the latest package for BBB. Change-Id: Iacf1de8631e2e8218dc18e97bc6f993ad0d2da6f Reviewed-by: Gatis Paeglis <gatis.paeglis@digia.com>
-rw-r--r--recipes/libgles/libgles-omap3_4.05.00.03.bbappend39
-rw-r--r--recipes/libgles/libgles-omap3_5.00.00.01.bbappend46
-rw-r--r--recipes/libgles/libgles-omap3_5.01.01.01.bbappend (renamed from recipes/libgles/libgles-omap3_5.01.00.01.bbappend)0
3 files changed, 0 insertions, 85 deletions
diff --git a/recipes/libgles/libgles-omap3_4.05.00.03.bbappend b/recipes/libgles/libgles-omap3_4.05.00.03.bbappend
deleted file mode 100644
index 73a2408..0000000
--- a/recipes/libgles/libgles-omap3_4.05.00.03.bbappend
+++ /dev/null
@@ -1,39 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
24
25TOOLCHAIN_PATH = "${STAGING_DIR_TARGET}"
26
27FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
28SRC_URI += " file://0001-Add-GLchar-typedef.patch"
29
30LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
31
32do_install_append() {
33 echo "ParamBufferSize=33554432" >> ${D}${sysconfdir}/powervr.ini
34}
35
36pkg_postinst_${PN}_append() {
37ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
38echo ${ESREV} > $D${sysconfdir}/powervr-esrev
39}
diff --git a/recipes/libgles/libgles-omap3_5.00.00.01.bbappend b/recipes/libgles/libgles-omap3_5.00.00.01.bbappend
deleted file mode 100644
index f0b5754..0000000
--- a/recipes/libgles/libgles-omap3_5.00.00.01.bbappend
+++ /dev/null
@@ -1,46 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24
25BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
26BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x"
27
28LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
29
30do_install_append() {
31 echo "ParamBufferSize=33554432" >> ${D}${sysconfdir}/powervr.ini
32}
33
34# Inhibit warnings about files being stripped.
35INHIBIT_PACKAGE_SPLIT = "1"
36
37pkg_postinst_${PN}_append() {
38ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
39echo ${ESREV} > $D${sysconfdir}/powervr-esrev
40}
41
42RRECOMMENDS_${PN} = "omap3-sgx-modules"
43RRECOMMENDS_${PN}-blitwsegl = ""
44RRECOMMENDS_${PN}-flipwsegl = ""
45RRECOMMENDS_${PN}-frontwsegl = ""
46RRECOMMENDS_${PN}-linuxfbwsegl = ""
diff --git a/recipes/libgles/libgles-omap3_5.01.00.01.bbappend b/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
index 9a90577..9a90577 100644
--- a/recipes/libgles/libgles-omap3_5.01.00.01.bbappend
+++ b/recipes/libgles/libgles-omap3_5.01.01.01.bbappend