summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-04-13 17:49:24 +0200
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-04-21 10:58:57 +0300
commit95d48b04f054e698fc548f2b907c66d13b954f83 (patch)
treedf2b6543fd4c47095f5ec7a870380152c6b2f485
parent3d363df976d644aab7592be1a32bd77935ba679c (diff)
downloadmeta-boot2qt-95d48b04f054e698fc548f2b907c66d13b954f83.tar.gz
Install CJK fonts on eLinux image
This is needed so we can enable Chinese, Korean and Japanese input method support in VKB. Task-number: QTEE-765 Change-Id: I86db44cc4ebfbaf9e72854a9a4ffa0708193c442 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r--recipes/fonts/otf-noto.bb23
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/fonts/otf-noto.bb b/recipes/fonts/otf-noto.bb
new file mode 100644
index 0000000..8a9f942
--- /dev/null
+++ b/recipes/fonts/otf-noto.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Noto Sans CJK"
2SECTION = "fonts"
3HOMEPAGE = "http://www.google.com/get/noto"
4LICENSE = "Apache-2.0"
5# see https://code.google.com/p/noto/issues/detail?id=331
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8INHIBIT_DEFAULT_DEPS = "1"
9
10inherit allarch fontcache
11
12SRC_URI = "http://www.google.com/get/noto/pkgs/NotoSansCJKSC-hinted.zip"
13
14SRC_URI[md5sum] = "fdbacee7b538c42cf1d3a6fc3dd3d106"
15SRC_URI[sha256sum] = "71d32727053c9677956b7aff7b150c3c2521072f40d334a37806a577d86fa33d"
16
17do_install() {
18 install -m 0644 -d ${D}${datadir}/fonts/otf/noto
19 install -m 0644 ${WORKDIR}/*.otf ${D}${datadir}/fonts/otf/noto
20}
21
22PACKAGES = "${PN}"
23FILES_${PN} += "${datadir}/fonts/otf/noto"
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 2c986ac..a99c76a 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -51,5 +51,6 @@ RDEPENDS_${PN} = "\
51 ttf-dejavu-common \ 51 ttf-dejavu-common \
52 ttf-dejavu-sans \ 52 ttf-dejavu-sans \
53 dbus-session-init \ 53 dbus-session-init \
54 otf-noto \
54 ${MACHINE_EXTRA_INSTALL} \ 55 ${MACHINE_EXTRA_INSTALL} \
55 " 56 "