summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@digia.com>2014-10-02 10:40:51 +0200
committerGatis Paeglis <gatis.paeglis@digia.com>2014-10-07 12:00:15 +0300
commit4240ef58f339d11ae8cd2540c001085a711da90d (patch)
tree43615fb618da89227e33a464131538b008df4dea
parente2ef75f16d54d30945bef4ff761bc1151f47f015 (diff)
downloadmeta-boot2qt-4240ef58f339d11ae8cd2540c001085a711da90d.tar.gz
Install fonts with help of Yocto recipes
Install fonts with help of Yocto recipes instead of installing fonts from many "random" shell scripts and b2qt-launcher repository. Change-Id: I906d022cfab1dfabeca1a8cd0b4c39cc8a886842 Task-number: QTEE-757 Reviewed-by: Samuli Piippo <samuli.piippo@digia.com> Reviewed-by: Kalle Viironen <kalle.viironen@digia.com>
-rw-r--r--recipes/fonts/ttf-devanagari_2.94.0.bb24
-rw-r--r--recipes/fonts/ttf-opensans.bb21
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb4
3 files changed, 49 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-devanagari_2.94.0.bb b/recipes/fonts/ttf-devanagari_2.94.0.bb
new file mode 100644
index 0000000..69e66c8
--- /dev/null
+++ b/recipes/fonts/ttf-devanagari_2.94.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Lohit Devanagari Fonts"
2SECTION = "fonts"
3HOMEPAGE = "https://fedorahosted.org/lohit/"
4LICENSE = "OFL-1.1"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/lohit-devanagari-ttf-${PV}/OFL.txt;md5=7dfa0a236dc535ad2d2548e6170c4402"
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9inherit allarch fontcache
10
11SRC_URI = "https://fedorahosted.org/releases/l/o/lohit/lohit-devanagari-ttf-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8"
14SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353"
15
16do_install() {
17 install -m 0644 -d ${D}${datadir}/fonts/truetype/lohit
18 install -m 0644 -d ${D}${sysconfdir}/fonts/conf.d/
19 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/66-lohit-devanagari.conf ${D}${sysconfdir}/fonts/conf.d/
20 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/Lohit-Devanagari.ttf ${D}${datadir}/fonts/truetype/lohit
21}
22
23PACKAGES = "${PN}"
24FILES_${PN} += "${datadir}/fonts/truetype/lohit"
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb
new file mode 100644
index 0000000..ad40b81
--- /dev/null
+++ b/recipes/fonts/ttf-opensans.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Open Sans Fonts"
2SECTION = "fonts"
3HOMEPAGE = "https://www.google.com/fonts"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87"
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9inherit allarch fontcache
10
11SRC_URI = "https://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ;downloadfilename=Open_Sans.zip"
12# Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check
13BB_STRICT_CHECKSUM = ""
14
15do_install() {
16 install -m 0644 -d ${D}${datadir}/fonts/truetype/opensans
17 install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans
18}
19
20PACKAGES = "${PN}"
21FILES_${PN} += "${datadir}/fonts/truetype/opensans"
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 6dd78bd..dd1ab44 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -47,5 +47,9 @@ RDEPENDS_${PN} = "\
47 hunspell \ 47 hunspell \
48 ca-certificates \ 48 ca-certificates \
49 linux-firmware \ 49 linux-firmware \
50 ttf-devanagari \
51 ttf-opensans \
52 ttf-dejavu-common \
53 ttf-dejavu-sans \
50 ${MACHINE_EXTRA_INSTALL} \ 54 ${MACHINE_EXTRA_INSTALL} \
51 " 55 "