summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Nichols <andy.nichols@theqtcompany.com>2014-10-09 14:07:40 +0200
committerAndy Nichols <andy.nichols@theqtcompany.com>2014-11-20 17:39:06 +0200
commit2d3cd8347bc92780906c75583994c1e5adac4286 (patch)
treefcc15f63eb699bdc367a6646822a4596f07a378c
parent21bad4d54bea4d7c0891829c7de56bd24e2afca8 (diff)
downloadmeta-boot2qt-2d3cd8347bc92780906c75583994c1e5adac4286.tar.gz
Add Support for Colibri-VF devices
Change-Id: Ie4fdf57b986eb24cb16dfb9f347ae02e7648bf86 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rwxr-xr-xb2qt-init-build-env2
-rw-r--r--conf/distro/include/colibri-vf.conf44
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend2
-rwxr-xr-xscripts/setup-environment.sh2
4 files changed, 47 insertions, 3 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index 8b7dee3..b1a13ab 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -82,7 +82,7 @@ get_repo() {
82 82
83get_groups() { 83get_groups() {
84 case ${DEVICE} in 84 case ${DEVICE} in
85 apalis-imx6) 85 apalis-imx6|colibri-vf)
86 PROJECT_GROUPS="toradex" 86 PROJECT_GROUPS="toradex"
87 ;; 87 ;;
88 imx53qsb|imx6qsabresd|nitrogen6x) 88 imx53qsb|imx6qsabresd|nitrogen6x)
diff --git a/conf/distro/include/colibri-vf.conf b/conf/distro/include/colibri-vf.conf
new file mode 100644
index 0000000..c5a3343
--- /dev/null
+++ b/conf/distro/include/colibri-vf.conf
@@ -0,0 +1,44 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23include conf/distro/include/toradex.inc
24
25IMAGE_FSTYPES = "tar.gz"
26
27BOOTFS_CONTENT = "\
28 ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
29 u-boot-${MACHINE}.imx:u-boot.imx \
30 "
31BOOTFS_DEPENDS = "u-boot:do_deploy"
32
33ADB_PRODUCTID = "0x0000"
34
35SERIAL_CONSOLES = "115200;ttymxc0 \
36 115200;ttymxc1"
37
38MACHINE_EXTRA_INSTALL = "\
39 opengldummy \
40 "
41
42MACHINE_EXTRA_INSTALL_SDK = "\
43 opengldummy-dev \
44 "
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
index aa33199..3d32eb9 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
@@ -21,6 +21,6 @@
21############################################################################# 21#############################################################################
22 22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += " \ 24SRC_URI_apalis-imx6 += " \
25 file://0001-Update-default-args-for-apalis-imx6.patch \ 25 file://0001-Update-default-args-for-apalis-imx6.patch \
26 " 26 "
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index 16815a8..d4bb051 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -49,7 +49,7 @@ BUILDDIR=${BUILDDIR:-build-${MACHINE}}
49 49
50if [ ! -f ${PWD}/${BUILDDIR}/conf/bblayers.conf ]; then 50if [ ! -f ${PWD}/${BUILDDIR}/conf/bblayers.conf ]; then
51 case ${MACHINE} in 51 case ${MACHINE} in
52 apalis-imx6) 52 apalis-imx6|colibri-vf)
53 LAYERSCONF="bblayers.conf.toradex.sample" 53 LAYERSCONF="bblayers.conf.toradex.sample"
54 ;; 54 ;;
55 imx53qsb|imx6qsabresd|nitrogen6x) 55 imx53qsb|imx6qsabresd|nitrogen6x)