summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-03-25 13:41:19 +0200
committerSamuli Piippo <samuli.piippo@digia.com>2014-03-26 12:42:51 +0200
commit13c0a0c319524012c2b6cc7aa92d6b5f487d4d58 (patch)
tree67a4277cb54768ea1bf4ec71d7369d3d15bf75c3
parentac491beed785edeea0e8ae3d883864ab521da6b0 (diff)
downloadmeta-boot2qt-13c0a0c319524012c2b6cc7aa92d6b5f487d4d58.tar.gz
Create boot.tar.gz as part of the image build
Each machine config defines what is included in the boot.tar.gz package. For beaglebone, include the uEnv.txt u-boot script that is used to start up the device. Change-Id: Ia509dd61c789fda53889cea8ea9221cfa8b469a9 Reviewed-by: Andy Nichols <andy.nichols@digia.com>
-rw-r--r--classes/bootfs-image.bbclass51
-rw-r--r--conf/distro/include/am335x-evm.conf6
-rw-r--r--conf/distro/include/beagleboard.conf6
-rw-r--r--conf/distro/include/beaglebone.conf9
-rw-r--r--conf/distro/include/imx53qsb.conf6
-rw-r--r--conf/distro/include/nitrogen6x.conf9
-rw-r--r--conf/distro/include/raspberrypi.conf6
-rw-r--r--recipes/images/b2qt-embedded-image.bb1
-rw-r--r--recipes/u-boot/u-boot-uenv-script.bb49
-rw-r--r--recipes/u-boot/u-boot-uenv-script/uEnv.txt3
10 files changed, 146 insertions, 0 deletions
diff --git a/classes/bootfs-image.bbclass b/classes/bootfs-image.bbclass
new file mode 100644
index 0000000..9218bd3
--- /dev/null
+++ b/classes/bootfs-image.bbclass
@@ -0,0 +1,51 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23BOOTFS_NAME = "${IMAGE_BASENAME}-boot-${MACHINE}-${DATETIME}"
24BOOTFS_LINK_NAME = "${IMAGE_BASENAME}-boot-${MACHINE}"
25
26BOOTFS_DEPENDS ?= ""
27
28do_bootfs () {
29 if [ -n ${BOOTFS_CONTENT} ]; then
30 exit 0
31 fi
32
33 mkdir -p ${S}/bootfs
34
35 for item in ${BOOTFS_CONTENT}; do
36 src=`echo $item | awk -F':' '{ print $1 }'`
37 dst=`echo $item | awk -F':' '{ print $2 }'`
38
39 install -m 0755 ${DEPLOY_DIR_IMAGE}/$src ${S}/bootfs/$dst
40 done
41
42 cd ${S}/bootfs
43 rm -f ${DEPLOY_DIR_IMAGE}/${BOOTFS_NAME}.tar.gz ${DEPLOY_DIR_IMAGE}/${BOOTFS_LINK_NAME}.tar.gz
44
45 tar czvf ${DEPLOY_DIR_IMAGE}/${BOOTFS_NAME}.tar.gz .
46 ln -s ${BOOTFS_NAME}.tar.gz ${DEPLOY_DIR_IMAGE}/${BOOTFS_LINK_NAME}.tar.gz
47}
48
49addtask bootfs before do_rootfs
50
51do_bootfs[depends] += "${BOOTFS_DEPENDS}"
diff --git a/conf/distro/include/am335x-evm.conf b/conf/distro/include/am335x-evm.conf
index 5799db7..6772a2a 100644
--- a/conf/distro/include/am335x-evm.conf
+++ b/conf/distro/include/am335x-evm.conf
@@ -22,6 +22,12 @@
22 22
23IMAGE_FSTYPES = "tar.gz" 23IMAGE_FSTYPES = "tar.gz"
24 24
25BOOTFS_CONTENT = "\
26 u-boot-${MACHINE}.img:u-boot.img \
27 MLO-${MACHINE}:MLO \
28 "
29BOOTFS_DEPENDS = "u-boot:do_deploy"
30
25PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" 31PREFERRED_VERSION_libgles-omap3 = "4.09.00.01"
26PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" 32PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01"
27 33
diff --git a/conf/distro/include/beagleboard.conf b/conf/distro/include/beagleboard.conf
index 829b4fa..dab9c68 100644
--- a/conf/distro/include/beagleboard.conf
+++ b/conf/distro/include/beagleboard.conf
@@ -22,6 +22,12 @@
22 22
23IMAGE_FSTYPES = "tar.gz" 23IMAGE_FSTYPES = "tar.gz"
24 24
25BOOTFS_CONTENT = "\
26 u-boot-${MACHINE}.img:u-boot.img \
27 MLO-${MACHINE}:MLO \
28 "
29BOOTFS_DEPENDS = "u-boot:do_deploy"
30
25PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" 31PREFERRED_VERSION_libgles-omap3 = "4.09.00.01"
26PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" 32PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01"
27 33
diff --git a/conf/distro/include/beaglebone.conf b/conf/distro/include/beaglebone.conf
index ba13aaa..376e3c6 100644
--- a/conf/distro/include/beaglebone.conf
+++ b/conf/distro/include/beaglebone.conf
@@ -17,6 +17,15 @@
17############################################################################ 17############################################################################
18IMAGE_FSTYPES = "tar.gz" 18IMAGE_FSTYPES = "tar.gz"
19 19
20BOOTFS_CONTENT = "\
21 u-boot-${MACHINE}.img:u-boot.img \
22 MLO-${MACHINE}:MLO \
23 uEnv-${MACHINE}.txt:uEnv.txt \
24 "
25BOOTFS_DEPENDS = "u-boot:do_deploy u-boot-uenv-script:do_deploy"
26
27EXTRA_IMAGEDEPENDS += "u-boot-uenv-script"
28
20PREFERRED_VERSION_libgles-omap3 = "5.01.00.01" 29PREFERRED_VERSION_libgles-omap3 = "5.01.00.01"
21PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01" 30PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01"
22 31
diff --git a/conf/distro/include/imx53qsb.conf b/conf/distro/include/imx53qsb.conf
index d83f6b4..a7099a5 100644
--- a/conf/distro/include/imx53qsb.conf
+++ b/conf/distro/include/imx53qsb.conf
@@ -22,6 +22,12 @@
22 22
23IMAGE_FSTYPES = "tar.gz" 23IMAGE_FSTYPES = "tar.gz"
24 24
25BOOTFS_CONTENT = "\
26 u-boot-${MACHINE}.${UBOOT_SUFFIX}:u-boot.${UBOOT_SUFFIX} \
27 ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
28 "
29BOOTFS_DEPENDS = "u-boot:do_deploy"
30
25MACHINE_EXTRA_INSTALL = "\ 31MACHINE_EXTRA_INSTALL = "\
26 amd-gpu-bin-mx51 \ 32 amd-gpu-bin-mx51 \
27 " 33 "
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf
index 5f6df70..2a64026 100644
--- a/conf/distro/include/nitrogen6x.conf
+++ b/conf/distro/include/nitrogen6x.conf
@@ -22,6 +22,15 @@
22 22
23IMAGE_FSTYPES = "tar.gz" 23IMAGE_FSTYPES = "tar.gz"
24 24
25BOOTFS_CONTENT = "\
26 ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
27 6x_bootscript-${MACHINE}:6x_bootscript \
28 6x_upgrade-${MACHINE}:6x_upgrade \
29 "
30BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy u-boot-script-boundary:do_deploy"
31
32EXTRA_IMAGEDEPENDS += "u-boot-script-boundary"
33
25MACHINE_EXTRA_INSTALL = "\ 34MACHINE_EXTRA_INSTALL = "\
26 libgal-mx6 \ 35 libgal-mx6 \
27 libegl-mx6 \ 36 libegl-mx6 \
diff --git a/conf/distro/include/raspberrypi.conf b/conf/distro/include/raspberrypi.conf
index 12f1033..61cebb4 100644
--- a/conf/distro/include/raspberrypi.conf
+++ b/conf/distro/include/raspberrypi.conf
@@ -22,6 +22,12 @@
22 22
23IMAGE_FSTYPES = "tar.gz" 23IMAGE_FSTYPES = "tar.gz"
24 24
25BOOTFS_CONTENT = "\
26 bcm2835-bootfiles/*: \
27 ${KERNEL_IMAGETYPE}:kernel.img \
28 "
29BOOTFS_DEPENDS = "bcm2835-bootfiles:do_deploy virtual/kernel:do_deploy"
30
25PREFERRED_PROVIDER_virtual/libgles1 = "userland" 31PREFERRED_PROVIDER_virtual/libgles1 = "userland"
26 32
27MACHINE_EXTRA_INSTALL = "\ 33MACHINE_EXTRA_INSTALL = "\
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb
index 4b492cd..8daffbd 100644
--- a/recipes/images/b2qt-embedded-image.bb
+++ b/recipes/images/b2qt-embedded-image.bb
@@ -33,6 +33,7 @@ IMAGE_FEATURES += "\
33 " 33 "
34 34
35inherit core-image 35inherit core-image
36inherit bootfs-image
36 37
37IMAGE_INSTALL += "\ 38IMAGE_INSTALL += "\
38 packagegroup-b2qt-embedded-base \ 39 packagegroup-b2qt-embedded-base \
diff --git a/recipes/u-boot/u-boot-uenv-script.bb b/recipes/u-boot/u-boot-uenv-script.bb
new file mode 100644
index 0000000..b15dd1f
--- /dev/null
+++ b/recipes/u-boot/u-boot-uenv-script.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "U-Boot script to start up BeagleBone Black"
24LICENSE = "CLOSED"
25PR = "r0"
26
27COMPATIBLE_MACHINE = "(beaglebone)"
28PV = "20140225"
29
30SRC_URI = "file://uEnv.txt"
31
32inherit deploy
33
34do_deploy () {
35 install -d ${DEPLOYDIR}
36 install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv-${MACHINE}-${PV}-${PR}.txt
37
38 cd ${DEPLOYDIR}
39 rm -f uEnv-${MACHINE}.txt
40 ln -sf uEnv-${MACHINE}-${PV}-${PR}.txt uEnv-${MACHINE}.txt
41}
42
43addtask deploy after do_install before do_build
44
45do_compile[noexec] = "1"
46do_install[noexec] = "1"
47do_populate_sysroot[noexec] = "1"
48
49PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/u-boot/u-boot-uenv-script/uEnv.txt b/recipes/u-boot/u-boot-uenv-script/uEnv.txt
new file mode 100644
index 0000000..f8385a4
--- /dev/null
+++ b/recipes/u-boot/u-boot-uenv-script/uEnv.txt
@@ -0,0 +1,3 @@
1bootfile=zImage
2optargs=consoleblank=0 vt.global_cursor_default=0
3mmcboot=echo Booting from mmc ...; run mmcargs; bootz ${kloadaddr} - ${fdtaddr}