summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-01-10 11:32:58 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-01-11 08:47:58 +0000
commitc3eff2040f541e67ad2f9447459d435f7e88353b (patch)
tree1a6741e3130bdab70bb5bc9914168d7f51a250a0
parent75e93a6ecb121d9aa0ee4aa986b3eef0dd20ea22 (diff)
downloadmeta-boot2qt-c3eff2040f541e67ad2f9447459d435f7e88353b.tar.gz
Add configs for mips and mips64 CI toolchains
Add include files for building mips and mips64 toolchains for CI usage. gcc-sanitizers are not available on mips, so filter those out. Task-number: QTQAINFRA-2535 Change-Id: I6a90a95169985020b7eac01344c61789fe9cac49 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/conf/distro/b2qt.conf2
-rw-r--r--meta-boot2qt-distro/conf/distro/include/qemumips.conf32
-rw-r--r--meta-boot2qt-distro/conf/distro/include/qemumips64.conf32
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb4
-rw-r--r--meta-boot2qt/classes/b2qt-utils.bbclass36
5 files changed, 104 insertions, 2 deletions
diff --git a/meta-boot2qt-distro/conf/distro/b2qt.conf b/meta-boot2qt-distro/conf/distro/b2qt.conf
index 4e3e42f..ac24fac 100644
--- a/meta-boot2qt-distro/conf/distro/b2qt.conf
+++ b/meta-boot2qt-distro/conf/distro/b2qt.conf
@@ -40,6 +40,8 @@ BUILDCFG_VARS += "SDKMACHINE"
40 40
41MAINTAINER = "B2Qt <b2qt@qt.io>" 41MAINTAINER = "B2Qt <b2qt@qt.io>"
42 42
43INHERIT += "b2qt-utils"
44
43SANITY_TESTED_DISTROS += " \ 45SANITY_TESTED_DISTROS += " \
44 Ubuntu 11.04 \n \ 46 Ubuntu 11.04 \n \
45 Ubuntu-15.10 \n \ 47 Ubuntu-15.10 \n \
diff --git a/meta-boot2qt-distro/conf/distro/include/qemumips.conf b/meta-boot2qt-distro/conf/distro/include/qemumips.conf
new file mode 100644
index 0000000..3e58d44
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/qemumips.conf
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30include conf/distro/include/ci.inc
31
32DISTRO_FEATURES_remove = "webengine"
diff --git a/meta-boot2qt-distro/conf/distro/include/qemumips64.conf b/meta-boot2qt-distro/conf/distro/include/qemumips64.conf
new file mode 100644
index 0000000..3e58d44
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/qemumips64.conf
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30include conf/distro/include/ci.inc
31
32DISTRO_FEATURES_remove = "webengine"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index 281d9b6..9fac3f6 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2019 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -40,7 +40,7 @@ MACHINE_EXTRA_INSTALL_SDK ?= ""
40RDEPENDS_${PN} += " \ 40RDEPENDS_${PN} += " \
41 ${MACHINE_EXTRA_INSTALL_SDK} \ 41 ${MACHINE_EXTRA_INSTALL_SDK} \
42 packagegroup-core-standalone-sdk-target \ 42 packagegroup-core-standalone-sdk-target \
43 gcc-sanitizers \ 43 ${@contains_regex('MACHINEOVERRIDES', '(x86_64|i.86|powerpc|sparc|s390|arm|aarch64)', 'gcc-sanitizers', '', d)} \
44 \ 44 \
45 qt3d-dev \ 45 qt3d-dev \
46 qt3d-runtime-dev \ 46 qt3d-runtime-dev \
diff --git a/meta-boot2qt/classes/b2qt-utils.bbclass b/meta-boot2qt/classes/b2qt-utils.bbclass
new file mode 100644
index 0000000..7c27348
--- /dev/null
+++ b/meta-boot2qt/classes/b2qt-utils.bbclass
@@ -0,0 +1,36 @@
1############################################################################
2##
3## Copyright (C) 2019 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30def contains_regex(variable, regex, truevalue, falsevalue, d):
31 import re
32 val = (d.getVar(variable) or "").split(":")
33 for m in val:
34 if re.match(regex, m):
35 return truevalue
36 return falsevalue